Latest Mac Pro as Server - How to not sleep this thing and it's headless?

Discussion in 'Mac Pro' started by jmille44, Jul 17, 2014.

  1. jmille44 macrumors member

    Joined:
    Oct 31, 2005
    #1
    I have the latest Mac Pro using it as a server with no monitor (headless).
    This thing goes to sleep and the Energy Saver System Preference has only one
    slider for Turn Display off after 1min - Never. I have selected Never and check marked Prevent computer from sleeping automatically when the display is off, but there is no display, so it just goes to sleep.

    Anyone have a solution to get the other slider back so this computer does not go to sleep?

    Another thread suggested the solution below but the Your-Mac-Model.plist has a lot of files in it and no way of knowing which file is for my Mac. Anyone know which file I should use?

    edit "/S/L/E/IOPlatformPluginFamily.kext/Contents/PlugIns/X86PlatformPlugin.kext/Contents/Resources/Your-Mac-Model.plist

    find:
    <key>UnifiedSleepSliderPref</key>
    <true/>

    replace:
    <key>UnifiedSleepSliderPref</key>
    <false/>

    rebuild kext cache and reboot.
     
  2. tuxon86 macrumors 65816

    Joined:
    May 22, 2012
    #2
    What type of server?

    IMO using a workstation instead of a dedicated server has two big negative...

    1- The cost - Especially for a simple use like a file and print server. You can get more for less money. The Mac Mini server is a nice exemple.

    2- Expendability and redundancy - Dedicated server are made to grow and adapt to the need of the enterprise. A workstation is more of a specialist for a dedicated task. Many server also include redundant component to prevent downtime, like dual PSU and controller.
     
  3. omvs macrumors 6502

    Joined:
    May 15, 2011
    #4
    If you're okay with Terminal.app, might try pmset...

    pmset sleep 0
    pmset displaysleep 0
    ...

    There's a ton of options - maybe "pmset autopoweroff 0" will help too. Much more here than system preferences exposts
     
  4. jmille44 thread starter macrumors member

    Joined:
    Oct 31, 2005
    #5
    Apple helped find the solution for me.

    http://support.apple.com/kb/HT200106?viewlocale=en_US

    Use the following Terminal command (with an administrator password) to prevent the computer from sleeping:

    sudo pmset -a disablesleep 1
    When the value is set to 1, all sleep functions are disabled. The Sleep item in the Apple menu is also dimmed ("grayed out").
     

Share This Page