LaunchPad challenges

Discussion in 'Mac OS X Lion (10.7)' started by Killerbob, Apr 19, 2011.

  1. Killerbob macrumors 6502a

    Jan 25, 2008
    OK, I have a problem with LaunchPad, and need to know if it is just me, or if it is a general problem in Lion. I have logged a Bug, but heard nothing back thus far.

    I have a lot of programs, and have gotten used to using XMenu in SL. However, with LaunchPad I thought my troubles were over, and using DP1 and DP2 it looked like it. I actually like LaunchPad - I have a lot of personalization, with all programs in a few folders on the first page in LaunchPad.

    However, since the service pack for DP2, all of these personal settings have reset back to square one. It is all gone, and even if I now set it all up again, it will reset upon next reboot.

    I have three files in the "dock" folder, a .db, a .corrupt, and a .db-journal file, and even if I replace these with the "correct" ones (copied after setting LaunchPad up like I want it, it will all reset eventually.

    How many people are having problems with LP?

  2. edmartin macrumors member

    Jul 23, 2007
  3. Killerbob thread starter macrumors 6502a

    Jan 25, 2008
    Nope, never heard anything back from the fruit company, or from other users, except confirmation I am not the only one:mad:
  4. paris18m macrumors member

    Jun 10, 2011
    having problems with launchpad as well, i spend 30 min setting up icons in folders for launchpad and a restart did reset launchpad! everything is gone out of folder now. agrrrrrrrr

    anyone knows what is up with launchpad? maybe its a permission problem or am i missing something?
  5. Killerbob thread starter macrumors 6502a

    Jan 25, 2008

    Looks like all these issues with LP, are solved with DP4!

  6. pcmxa macrumors regular


    Apr 9, 2011
    Just had this happen on the official release of Lion. My dock, launchpad, desktop, and mission control spaces were reset on a reboot. Ever hear anything back?
  7. Killerbob thread starter macrumors 6502a

    Jan 25, 2008
    Nope. After DP4 all has worked fine. One thing though, I read somewhere that if you had played around with the DB files, you may need to do a complete reinstall of Lion for it to work correctly. This is what I did.


Share This Page