Launchpad, stuck phantom download.

Discussion in 'OS X Yosemite (10.10)' started by x3n0n1c, Jul 26, 2014.

  1. x3n0n1c macrumors regular

    Joined:
    Jul 9, 2014
    #1
    Hello Friends,

    I was trying to download the public beta of Yosemite at work yesterday and the wireless was being flaky. It resulted in the download failing multiple times, after which I gave up and waited until I got home that night.

    When I got home, I was able to get the download to finish without issue, but I now have a phantom download of the Beta in Launchpad that does not appear within the App Store.

    I have tried starting a new download and cancelling it in hopes it would disappear but this has had no effect.

    Here is a screenshot of the issue.

    [​IMG]

    This "download" does not appear in the applications folder, and searching for it come up with nothing. If I click and hold the icon and try to hit the X button then select "delete", nothing happens. I am also unable to drag the icon into the Dock in order to "Show in Finder".

    I have tried resetting the Dock and launcher to default and it has still remained. I am out of ideas.

    Anyone know how to fix this?

    Thanks!
     
  2. anp27 macrumors regular

    Joined:
    Jan 17, 2011
    Location:
    Brooklyn, NY
    #2
    Try entering these into Terminal:

    defaults write com.apple.dock ResetLaunchPad -bool true

    killall Dock
     
  3. lokasdekartas macrumors newbie

    Joined:
    Apr 1, 2013
    #3
    I was having the same problem and this worked for me , Thank you very much!
     
  4. x3n0n1c thread starter macrumors regular

    Joined:
    Jul 9, 2014
    #4
    I totally love you right now, worked like a charm.

    +1 Internetz point for you! Spend it wisely my friend!

    <3
     
  5. anp27 macrumors regular

    Joined:
    Jan 17, 2011
    Location:
    Brooklyn, NY
    #5
    No problem guys! Glad everything is fixed! Remember to help other people too :)
     
  6. davidventer macrumors newbie

    Joined:
    Jul 31, 2014
    Location:
    South Africa
    #6
    Fixed!

    I was also having the same problem with LaunchPad in OS X Yosemite Beta. This also fixed it for me. Thanks!
     
  7. fribster64 macrumors newbie

    Joined:
    Aug 1, 2014
    #7
    Oh my god thank you so much I couldn't find a solution for hours its really late now and I'm not supisrd to be up (I'm a kid) but I will try it tommorow thank you so much!!!!
     
  8. anp27 macrumors regular

    Joined:
    Jan 17, 2011
    Location:
    Brooklyn, NY
    #8
    I think this needs to be made into a sticky because apparently many people are having the same problem and this question gets asked over and over again.
     
  9. Hockeygoalie101 macrumors newbie

    Joined:
    Aug 28, 2014
    #9
    Thank you very much!

    I had the exact same problem and I was starting to get paranoid with it. This fix the problem and I am so glad. Thanks!
     
  10. Toltepeceno Suspended

    Toltepeceno

    Joined:
    Jul 17, 2012
    Location:
    SMT, Edo MX, MX
    #10
    I just came across this and it worked for me, but one warning to anyone else that comes across it. If you have your apps in "categorries" they will not be afterwards. I now have pages of apps to bring together again.
     
  11. cjbryce macrumors 6502

    cjbryce

    Joined:
    Jun 4, 2008
    Location:
    London
    #11
    Fab fix.

    As noted above it really does reset Launchpad completely but for me at least this was A Good Thing as all my apps are now in nice neat alphabetical order - with the Apple default apps on page one.
     
  12. SugarPlum1, Sep 10, 2016
    Last edited: Sep 10, 2016

    SugarPlum1 macrumors newbie

    SugarPlum1

    Joined:
    Sep 10, 2016
    #12
    Yay, it worked! Thank you so much, its been annoying me for quite a while. Cheers
     

Share This Page