Leapard keeps asking for my password

Discussion in 'Mac Basics and Help' started by iamthefly, Nov 1, 2011.

  1. iamthefly macrumors newbie

    Joined:
    Nov 1, 2011
    #1
    Hi,

    Whenever I want to install or update any software on my macmini running Leapard, I have to type in my password. it's really frustrating. How do I stop it asking me for my password, I can't find it anywhere?

    Thanks.
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    You don't, as it is a security feature. Whenever something gets installed, that needs access to system folders or files, you have to authorise it, thus preventing everyone with access to your Mac mini to install any harming software. Malware also needs access to system folders and files, but as you have to enter a password to allow such access, malware can't install itself, you have to do it yourself.

    Btw, it is "Leopard".
     
  3. mstrze macrumors 68000

    Joined:
    Nov 6, 2009
    #3
    And it's only when you install software (like previously stated, to protect your system from the possibility of malware being installed without your knowledge) so how annoying can it be?

    I mean, how many apps are you installing daily that typing your password gets to be interminable?
     
  4. iamthefly thread starter macrumors newbie

    Joined:
    Nov 1, 2011
    #4
    Its also whenever I need to install an update, and as I don't use it that often, there is basically an update needed for one thing or another every time I switch it on. My aluminium keyboard broke, so I bought a cheap wireless one to replace it, but I can't install the driver because I have to type in my password without a working keyboard. Going to have to borrow a USB one from work to get the job done. Fresh installs are not the main problem, its the updates that bug me most.

    Can anyone help?
     
  5. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #5
    You could use the "on screen keyboard" to enter a password:

    [​IMG]
     
  6. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    #6
    Open System Preferences.
    Click the Software Update pane.
    Click the "Check for updates" popup.
    Choose Weekly instead of Daily.

    Or uncheck the "Check for updates" checkbox, then perform checks manually.
     
  7. iamthefly thread starter macrumors newbie

    Joined:
    Nov 1, 2011
    #7
    thanks simsaladbamba,

    that was really helpful. I knew there must have been an onscreen keyboard, but i couldn't find it. I would never have looked in 'International'.

    Shame about the update needing a password thing.

    Cheers.
     

Share This Page