Leapord dock is very sluggish

Discussion in 'macOS' started by weemanpow3, May 14, 2008.

  1. weemanpow3 macrumors 6502

    weemanpow3

    Joined:
    Mar 14, 2008
    #1
    On my MacBook Pro the dock is very laggy when I scroll with magnifier on. This has always happened when I first baought it on day one. when I take the dock glass of and go to 2D dock it is silk smooth. When I go to 3D it feels laggy like the FPS has been cut in half. I dont have any apps running or anything and it always has done this. I even reformated it, problem still exists. Everything works perfect though. Is there any fix I could do.

    Thanks
     
  2. iBunny macrumors 65816

    Joined:
    Apr 15, 2004
    #2
    What I dont understand is I own a MacBook Pro as well.

    I have the same issues.

    I work with a guy who has a MacBook. I use it often.

    That computer does not have this issue.

    ? It seems the Integrated X3100 graphics on the MacBook process the OSX GUI better than the Dedicated GeForce 8600. I dont know why, I know its not hardware issues. So It must be drivers.

    What the real question is, why have new drivers have not come out to correct this after all this time?
     
  3. weemanpow3 thread starter macrumors 6502

    weemanpow3

    Joined:
    Mar 14, 2008
    #3
    ok, found a temporarily fix after some research. Type this into Terminal.

    sudo defaults write /Library/Preferences/com.apple.windowserver Compositor -dict deferredUpdates 0

    Then restart your mac

    deferredUpdates 1 turns beam sync back on which is the default behavior. 0 should result in smoother animations with an increased chance of windows tearing.

    Apple need to fix this

    Source - http://discussions.apple.com/thread.jspa?messageID=5679203&
     

Share This Page