LED Cinema Display stopped charging MBP

Discussion in 'MacBook Pro' started by harry20larry, Sep 28, 2009.

  1. harry20larry macrumors 6502a

    harry20larry

    Joined:
    Aug 14, 2008
    #1
    Hey,
    I have an LED cinema display and a MBP unibody, and they have been working fine together for around 3 months.
    However, have just noticed that the cinema display magsafe connector no longer charges my macbook, it just says (Not Charging) in the battery zone.
    I was wondering if anybody has had this problem, because they have both been working fine since day one, and this has just started.
    Harri

    PS, my normal magsafe charger works fine
     
  2. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #2
    Sounds like the charger on the display might be defective and they'd need to fix that.
     
  3. cerulean.blue macrumors newbie

    Joined:
    Oct 13, 2007
    #3
    FYI, I had the same problem. Monitor was 9 months old, still under warranty. Had to take it in and get serviced (they're replacing a logic board or power supply - not entirely clear from last communication).

    In any case, the person I talked to at Apple seemed to suggest this is not the first time they've heard of this problem with the LED Cinema Displays, but they had a fairly clunky way of dealing with it in my case. Unlike other hardware, the monitor had to be taken in for servicing instead of mailed to Apple. I haven't gotten it back yet, but the service tech said it's working now...
     

Share This Page