LED Flash not working

Discussion in 'iPhone Tips, Help and Troubleshooting' started by SilverFang, Dec 3, 2010.

  1. SilverFang macrumors newbie

    Joined:
    Dec 3, 2010
    #1
    I just got my iPhone 4 a couple of hour ao, so when I got home and plugged it in and checked it out, I noticed that even when I pick ON in the camera "menu" there is no flash... I even tried downloading a free Flashlight app and the flash still didn't work!
    Any solutions?
     
  2. vincenz macrumors 601

    vincenz

    Joined:
    Oct 20, 2008
    #2
    Try restarting the phone or turning it off/turning it back on if you haven't already. If that doesn't work, back up and do a complete restore and see if the flash works on a clean phone with no apps installed. If none of those work, the LED is probably DOA and you'll need to get a replacement.
     
  3. SilverFang thread starter macrumors newbie

    Joined:
    Dec 3, 2010
    #3
    I tried to turn it off & on a couple of times, I even updated it from 4.1 to 4.2.1 but still...
    Meh... I guess I'll hav to bring it back on Sunday. The thing is, they probably won't have another one to give me, right?
     
  4. vincenz macrumors 601

    vincenz

    Joined:
    Oct 20, 2008
    #4
    They probably will have another if you got it at an Apple Store. A few months ago you may have had some trouble, but the demand has died down, so many, if not all, stores will have new or replacements in stock for you. Just make an appointment first, I'm sure you'll get a new one when you walk in.
     
  5. SilverFang thread starter macrumors newbie

    Joined:
    Dec 3, 2010
    #5
    There are no Apple stores where I live.
    I'm from Israel, we have an Apple premium authorized reseller but I doubt they have any.
    I got it from my local carrier, and I had to wait a day or 2 since I ordered it till it arrived...
     

Share This Page