Left 4 Dead 2-Mac OS 10.5.8

Discussion in 'Mac and PC Games' started by ency, Dec 21, 2010.

  1. ency macrumors newbie

    Joined:
    Dec 21, 2010
    #1
    Alright, I'm new to this whole mac thing so this question will sound scrubby, but I have a Mac OS X 10.5.8. I've been reading all throughout these boards and it appears my mac can run as graphically demanding games and better(as l4d2). But when I try to run L4d2 it says, "You must be running MacOS 10.6.4 w/ apple's snow leopard graphics update or later to run this game." I've done all the updates etc etc, but I just don't know what this means.

    Am I missing something? Or am I just hosed?

    Thanks!
     
  2. rbarris macrumors 6502

    Joined:
    Oct 28, 2003
    Location:
    Irvine CA
    #2
    L4D / L4D2 only run on Snow Leopard (10.6) and do not run on Leopard (10.5.x). The upgrade from 10.5.8 to 10.6.5 is usually $29.
     
  3. Sambo110 macrumors 68000

    Joined:
    Mar 12, 2007
    Location:
    Australia
    #3
    Yeah, just buy Snow Leopard, which is a new OS, it's cheap, $29 USD, and then it will work fine, not to mention all your other games will run better.
     
  4. harveypooka macrumors 65816

    Joined:
    Feb 24, 2004
    #4
    What Mac do you own?
     

Share This Page