Lens malfunction?

Discussion in 'Digital Photography' started by Music_Producer, May 29, 2006.

  1. Music_Producer macrumors 68000

    Sep 25, 2004
    My nikkor 85mm f/1.8 D seems to be messed up.. it was working fine when all of a sudden the displayon my nikon d-50 shows "F--" .. its unable to autofocus, can't set the f-stop.. etc. I can manually focus but i can't set the aperture.. Its happened before and i gave it a 'whack' once.. and it was ok. That treatment doesn't seem to be working right now!

    Is this a significant problem? Or is it one that nikon service should be able to fix pretty easily? I don't want to spend too much time or money.. i'd rather just buy a new lens but i'm concerned it might happen again. All my other lenses work fine.
  2. Frank (Atlanta) macrumors regular

    Oct 29, 2004
    You may have already tried the following, but take the lens off and clean the contacts with a (clean) eraser. Take a look at the contacts in the lens mount; however, obviously be careful about how you clean these - don't want eraser bits (much less dust) getting on your sensor.

    Good luck,
  3. ChrisA macrumors G4

    Jan 5, 2006
    Redondo Beach, California
    If a "whack" fixed it then likely some electrical contact is loose is slightly corroded. If the lens is no longer under Nikon warenty look for a local independent repair shop. Many can do a faster turnaround and cost less and if local there is no two way shipping. The one I used to use for my medium formet stuff typically told me to come back and pick it up after one or two days. If it's under warenty then you would want to send it in to Nikon

Share This Page