Leopard 10.5.2 Freezes

Discussion in 'macOS' started by friosn, Feb 17, 2008.

  1. friosn macrumors newbie

    Joined:
    Feb 17, 2008
    #1
    Leopard 10.5.2 keeps freezing all apps on my PowerBook G4 1.67GHz. The only thing that remains active is the curser but all applications including Force quit become completely unresponsive. Help please!!!! I have already reinstalled a Mac OS Xbut the problem keeps occurring.
     
  2. Ugg macrumors 68000

    Ugg

    Joined:
    Apr 7, 2003
    Location:
    Penryn
  3. jesstech macrumors member

    Joined:
    Jun 12, 2007
    #3
    I'm having this same trouble with 10.5.2 on my SR MacBook Pro 3,1.

    Sometimes it is accompanied by graphical glitching (static garbage filling the screen where the GPU would is redrawing), and sometimes there are breaks of about five seconds during which everything returns to normal but then it freezes again.

    iTunes continues to play songs when everything is frozen, so I think this only affects screen output and keyboard input.
     
  4. friosn thread starter macrumors newbie

    Joined:
    Feb 17, 2008
    #4
    How do I fix permissions? What is accomplished by fixing permission?
     
  5. iCeFuSiOn macrumors 6502a

    Joined:
    Jul 18, 2007
    #5
    You can repair permissions using Disk Utility (located in /Applications/Utilities) -- simply click on your hard drive, click on the First Aid tab, and click on Repair Permissions.

    Or, you can run it from the command line -- sudo diskutil repairpermissions /

    Repairing permissions basically looks at the receipt files (or "Bill of Materials") to see what system files are supposed to have as far as permissions. If these permissions do not match, Disk Utility will reset the permissions to what it thinks is appropriate.

    NOTE: If you see "ACL found but not expected on" messages during the repair process, do not worry about them. These are classified as being normal and nothing to worry about, right from Apple.
     
  6. friosn thread starter macrumors newbie

    Joined:
    Feb 17, 2008
    #6
    Thanks I will try that right away. I just wonder how come reformatting my hard drive and reinstalling OS X didn't fix the issue.
     
  7. jesstech macrumors member

    Joined:
    Jun 12, 2007
    #7
    Just repaired disk permissions from the Leopard install DVD -- no change.
     
  8. NeXTLoop macrumors member

    NeXTLoop

    Joined:
    Jul 22, 2003
    #8
    The issue is not 10.5.2, its the Leopard Graphics Update (provided your graphics card is an NVIDIA card). I spent 3 days installing, testing, reinstalling, testing some more... until I finally tracked it down to the LGU.

    If you look in the Console after one of those freezes, you'll see all kinds of "NVChannel(GL): Graphics channel exception" errors. The ironic thing is, that for people experiencing this issue before the update, the LGU was supposed to fix it. In many cases it did. But for some people, especially ones who didn't have the issue before, the LGU actually caused the issue.

    I ended up installing 10.5.2 and setting Software Update to just ignore the LGU. Whereas before I could reproduce the freeze 100% of the time with a certain sequence of actions, now I can't reproduce it no matter how much I try. Also, my overall graphics performance is better without the LGU than it was with it.

    Of course, YMMV... but hopefully this helps.
     
  9. ewing1871 macrumors newbie

    Joined:
    Mar 14, 2008
    #9
    Same problem, no solution

    I've had the same issue -- I updated to 10.5.2 and am now having problems with all my applications freezing. I tried to verify or repair my disk permissions -- both through disk utility and through terminal -- and got stuck at after reading about 20%. It seems my machine can't even fully read my permissions anymore and is snagging on something.

    Any ideas?
     
  10. 617arg macrumors 6502

    Joined:
    Mar 3, 2008
    #10
    My computer just froze out of nowhere too. I was only on Safari and Adium at the time and the apps suddenly just froze.
    I could see the cursor moving, and iTunes was still playing, but none of the clicks or keyboard commands worked.
    I held down the power button to restart, restarted, and it's still just frozen. No apps open, I can move the cursor but clicks don't take effect.
    Restarted again and still having the same problem.

    What can I do? I'm new to Macs, on an early 2008 Mac Pro. Between this and the restart from sleep issue I'm beginning to seriously question the switch.

    I don't know how to "repair permissions" or even get to the command line. Especially if mouse clicks and keyboard commands aren't working.

    Any ideas?

    :confused:

    (I typed this from my HP laptop)
     
  11. 617arg macrumors 6502

    Joined:
    Mar 3, 2008
    #11
    ok.....restarted again and keyboard commands seem to be working. Mouse clicks are still not having any effect though.
    :confused::confused::confused::confused:
     
  12. 617arg macrumors 6502

    Joined:
    Mar 3, 2008
    #12
    just an update.

    I called Apple tech support and after a few special restarts everything is running normally again.

    First I had to start-up in safe mode (holding Shift at the dong)
    Then restart without logging in. I had to plug in a standard usb mouse to be able to click the restart button.

    After starting back up the usb mouse worked fine, but the bluetooth Mighty Mouse still couldn't click, so I had to shut down again and restart while holding Option - :apple: - P - R until hearing three start-up dongs.

    Everything works fine now.....not really sure what it did but I have to say that I'm pleased with Apple's tech support. :)
     
  13. friosn thread starter macrumors newbie

    Joined:
    Feb 17, 2008
    #13
    My screen has been getting yellow verticle lines that run down it since this problems started. Could this problem be causing this sort of damage to my screen?
     
  14. NeXTLoop macrumors member

    NeXTLoop

    Joined:
    Jul 22, 2003
    #14
    No. That sounds like a hardware issue. Some of the early LED MBP's had defective screens that would yellow.
     
  15. macnewbie7 macrumors newbie

    Joined:
    Jun 8, 2008
    #15
    hey, i followed the steps to plug in a USB mouse and restart in safe mode and it worked. I didnt have to do the combo keys of "Option+Apple+P+R" though. Thanks

    I think the problem is at the Bluetooth software or something. The OS would allow the movements of the mouse but not the clicking. I did turn off the BT mouse though during the restarting for safe mode.

    Anyway, by doing that... it works fine now. Safe me a trip to apple store or calling the apple tech guys.

    Thanks again
     

Share This Page