Leopard Admin problem...

Discussion in 'macOS' started by PaulMoore, Dec 3, 2007.

  1. PaulMoore macrumors regular

    Joined:
    Dec 3, 2007
    #1
    I upgraded my mid-2007 20 inch iMac to Leopard- an erase and install. I am logged in to the only account- which has Admin rights- it says so in the system preferences and the box for 'Allow user to administer this computer' is checked.

    BUT

    For some reason I am having problems- eg when I download an updated version of some software and try to copy the new program into applications I get "This operation cannot be completed because you do not have sufficient privileges for some of the items."

    Does anyone have any idea why this is and what I can do to remedy it? I am running 10.5.1- I even tried the Apple website suggested fix for upgrade installs with Admin user changing to standard (it suggests logging in as the root user and enabling Admin privileges for the account you're having trouble with) but it hasn't helped...
     
  2. akadmon macrumors 68010

    Joined:
    Aug 30, 2006
    Location:
    New England
    #2
    I assume you have tried repairing permission :)

    Is this a migrated account? Have you tried creating another admin account? If that works, it might just be easiest to move your files/setting manually to the new account.

    One fix that often works for these types of issues -- reply a 10.5.1 update (you'll have to download if you installed it through Software Update the first time).

    Another thing to try -- start up in Safe mode, then restart.

    Have you tried changing the status to standard then back to admin using the root account?
     
  3. PaulMoore thread starter macrumors regular

    Joined:
    Dec 3, 2007
    #3
    I have now tried all of the above and still the same problem. Any ideas?
     
  4. settledown macrumors regular

    Joined:
    Feb 28, 2003
    Location:
    pittsburgh
    #4
    manually change the permissions of the applications folder:
    Default install should be like this:


    Owner: system
    Access: read write

    Group: admin
    Access: read write

    Others: read only (leopard uses "everyone" instead of "others")
     
  5. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #5
    click on applications in the sidebar and press command-I. check out sharing and permissions, does it say "read" next to admin? if so click the lock, supply your password and change admin to "read and write".
     
  6. Mlobo01 macrumors 6502

    Joined:
    Jan 23, 2003
    Location:
    Weehawken New Jersey
    #6
    issues...

    One good factor is enabling the root user or the system admin account, if you go to: applications>utilities>Directory Utility there is a menu selection that allows you to set the password for the root user, set the password and under the accounts panes in System Preferences set the login to "list of users" when you log out you should see the "other" icon on the login window, select it and login, you can install any items from there, just know that this account is NOT for everyday use, it is capable of deleting any system file without warning etc so be extremely aware of your activities there, log out then go back to your normal account and see if it has reset the privileges, also know that from the Terminal app you may install any upgrade as long as you know the commands etc, you may google: Mac OS X Terminal commands, and see a whole list of proper Terminal goodies. If this does not work try an 'archive and install' to keep your account settings and files, you get a new BSD without the corrupted caches from migrated files or from the upgrade from Tiger that has proven to be buggy, I did an archive and install and it fixed all the bugs.
     
  7. PaulMoore thread starter macrumors regular

    Joined:
    Dec 3, 2007
    #7
    I did the right-click and Get Info for the applications folder and added my user account to the list (though it already had 'admin' down as 'read and write'- there is also a 'system' listed too) and gave myself 'read & write' permissions.

    That seemed to solve the problem of copying in updated versions of software- but then generated another bug- I couldn't eject the disc image files of the new software either from the desktop or via Finder. I eventually managed to do it in Disk Utility.

    Leopard has been such a disappointment.
     
  8. MacNutty macrumors newbie

    Joined:
    Jan 31, 2008
    #8
    Same feelings here

    Leopard has seem to be more of a disappointment from the admin side.

    I'm having this same issue all over my campus. Random users. The fix is to add their user to applications. What a pain in the ass. It happens to me too. I hope leopard becomes a much less buggy system as time does on and updates continue.
     
  9. heyp macrumors 6502

    Joined:
    Jan 29, 2008
    #9
    i'm having a similar issue since upgrading to leopard. i have "custom access" to my music folder so that when i try added music to my ipod it won't sync because i "dont have enough access privileges"

    how do i fix this?
     

Share This Page