Leopard: Administrator privileges gone

Discussion in 'macOS' started by mrzeve, Oct 27, 2007.

  1. mrzeve macrumors 6502a

    Jan 25, 2005
    After upgrading (and having the install fail once, and then have the new mac version of blue screen of death) I have now noticed that the admin privileges on my account are now gone.

    I cant authenticate anything and my account is listed as "Standard" in the preferences pane.

    I came home from Florida last night and left the install disc in my dorm. Any way to do this without using the Password Reset on the dvd? Regardless, I dont think it would help, since there isnt even an admin account listed.

    Any help?
  2. aussie_geek macrumors 65816


    Apr 19, 2004
    Sydney Australia
    There is a fix.

    I ran into this problem with my PowerBook. My other Mac's were ok.

    Step 1: Boot in single user mode (Single user mode bypasses the GUI, which is all the visual stuff, and gives you something called "root access") by pressing Command + S (Apple+S) when the first shade of blue appears on the screen, and holding it down until the screen turns black with white text.

    Step 2: Wait for all the code stuff to load. Now, the first thing we need to do in single user mode is mount the hard drive so we can edit it. You enter this command in : /sbin/mount -uw /

    It should say something about removing orphaned unlinked files.

    Step 3: We are going to delete a little file that tells your computer every time you start up that you've completed the setup by entering this commmand: rm /var/db/.applesetupdone

    It should just bump down, waiting fotr the next command if it worked.

    Step 4: Now type, reboot

    Step 5: It should shut down and reboot. Than, a setup window will appear, asking you what language you want your computer to be in, just like you see when you setup a newly purchased Mac.

    WARNING: A welcome video will play after you select the language. It has some pretty cool music, but if your in a room with other people, I'd mute it right after the video starts.

    Step 6: Setup the computer. Select "DO NOT TRANSFER MY DATA". Don't worry, all your old stuff will still be there. Choose your internet connection and network, here is where you need your WEP or security password if you have one.

    Step 7: Create a new local account to administer that computer. You usually want to enter the name of the computer as the longname, and the shortname what you'll log in as. Say your computer's old name was "Frank's Computer", than just put Frank as the longname, because it will automatically as "'s Computer" at the end. MAKE SURE THAT BOTH USERNAMES ARE DIFFERENT FROM THE EXSISTING ONES, OTHERWISE IT WILL OVERWRITE.

    Step 8: Finish the setup, and you should automatically be logged into your new administrator account.

    After logging into your admin account, go to system preferences and open the accounts pane. Select your old account and enable it as an admin account. Logout of the one you have just made and re- login using your original account. You now should be an administrator again. You can go back to system preferences and delete the account you made in the exercise.

    ps - in step 7 it is really important about the account names. I used BillyGates as mine.
  3. Emrtr4 macrumors regular

    Feb 6, 2006

    Is there any easier way?

    This happened to me too and there must be some way to do it from inside the OS.

    And btw Apple-myself included, this is the fourth major issue i've encountered amongst my friends who upgraded.
  4. aussie_geek macrumors 65816


    Apr 19, 2004
    Sydney Australia
    No that I know of. It's pretty easy.
    Boot into single user,
    delete the file,
    setup a new account
    go to system prefs and enable your old account as an admin one
    login as your account
    delete the one you made.

    It's a 10 min job mate. :)

  5. iVoid macrumors 65816

    Jan 9, 2007

    It might be a good idea to keep the new admin account around as an emergency admin user.

    Even though I only use my home Mac, I have an emergency user on it just in case my main account gets locked or unusable for some reason.
  6. aussie_geek macrumors 65816


    Apr 19, 2004
    Sydney Australia
    Good point. Might do that! :D

  7. nampa07 macrumors newbie

    Oct 27, 2007
    admin previlege gone..

    I am facing similar issues after leopard upgrade... my admin rights are lost and cannot log in as admin... I tried the solution posted by aussie_geek and while deleting the applesetupdone file it gives me this "override -w----r-- root/wheel for .AppleSetupDone?" and does not allow me to delete the file... not sure what to do now..

    Any other solution for this...

  8. deoson macrumors newbie

    Oct 27, 2007
    easier solution:

    boot into single user mode just like aussie geek instructed with "apple + s" while turning on your mac.

    then after after typing "/sbin/mount -uw /"

    type "passwd"

    then type what you want for your root password...

    then type reboot

    log into your account... go to the accounts preference pane and click the lock at the bottom left...this time when prompted for username/password use:

    User: root
    password: (one you just created)


    now upgrade your account to admin....

    logout and back in and you're good as gold.
  9. soffici macrumors newbie

    Nov 5, 2007
    Hi all!
    I tried the second version (the simpler one) and it worked perfectly:).
    Thanks all for posting good ideas.

    BTW doesn't Leopard seem to be slowing down the computer compared to 10.4.10:confused::eek::mad:?
    Just an impression
    Maybe Mr Jobs should tell us something?
  10. jenmenke macrumors newbie

    Nov 6, 2007
    I've tried the suggestions, but after a string of odd errors in the terminal mode or single user mode which I can't remember, but had something like "family specific matching fails" for the keyboard and trackpad, I entered the
    /sbin/fsck -fy and /sbin/mount -uw commands and after a LONG time it came bask with "macintosh HD is OK" (or something) and then "checking..." various things then the blinking cursor with
    /: root#

    what does that mean? I'm too scared to type anything else. Please help.I can't do anything right now because I have no priviledges. I've got to reinstall some printer drivers, etc.etc.

    I have an external 10.4 boot drive. Can I get the repair done from there?
  11. ShellyFM macrumors regular

    Aug 1, 2006
    I just noticed the same problem, but mine came up long after I installed Leopard. I did a clean install of Leopard on 10/26.

    Today, I changed my computer's name due to the Apple support article titled Mac OS X 10.5: Time Machine backups are not visible.

    Shortly after this, I noticed that my user account no longer had administer privileges. My user account is the only user account (other than the guest account) on the computer. So, now there is no administrator account at all.

    I'll try the suggestions above and see what happens.
  12. ShellyFM macrumors regular

    Aug 1, 2006
    The short version above worked.

    Is there a way to reverse the setting of the root password? I assume that it was not set before this, correct?

    In case I need to fix this in the future, I would hate to think I could possibly forget the root password and lock myself out for good. However, if I set it back to the way it was just before I made this change, then all I would have to do is follow these steps again.
  13. Sharkey macrumors newbie

    Nov 8, 2007
    Tried ...

    Thanks everyone for the help but I have one small problem. I have leopard on my macbook and lost my admin rights also. My problem is that 'apple-s' on bootup brings me to a signin box. Is there another way to enter the system changes mentioned above?

    My permissions are denied when I try to make any changes in Terminal.


  14. ShellyFM macrumors regular

    Aug 1, 2006
    Anybody know how to do this?

  15. ashcat macrumors newbie

    Nov 15, 2007
    Still having problem with file permissions

    I lost administrator privileges too when I installed Leopard. Thanks deoson & aussie_geek - the short method above worked for me too. All I'd say - for other beginners like me - is that I had to press command-S straight away, BEFORE the blue screen appeared, otherwise it booted up the normal way.

    I still have a problem with file permissions, not sure if it is related - there are some files which I now cannot delete or change - eg an iMovie file - it says I don't have permissions. When I do File Info on this file, under the Sharing & Permissions tab, there are three Names listed - 'system, (unknown), everyone'. My username is not listed at all. The '(unknown)' Name has the privilege 'Read only' and it will not change to Read and Write. I tried running Repair Permissions in Disk Utility, but it doesn't help.

    Another complication is that after installing Leopard, I upgraded to a bigger harddrive, and everything was cloned across to the new one - not sure if that could be the culprit instead of Leopard.

    Any idea what has happened or how to fix it? Apologies if this is off topic, I'm not sure if it's the same issue or not.

  16. ben/jegek macrumors newbie

    Jun 21, 2007
    South Jersey
    thanks for posting this

    i lost admin privileges a couple times before i found this thread, thought it was just me. has anyone successfully used an auxilliary admin account to circumvent this? maybe all admin accounts turn into standard ones..?
  17. ozchap macrumors newbie

    Nov 15, 2007
    All admin accounts reset to standard

    The same happened to me. But I had 3 admin accounts on my macbook, all were reset. The second method described here worked like a charm.
  18. joegomolski macrumors 6502


    Apr 28, 2006
    So CA
    Leopard: Administrator privileges gone


    Thank you so much!

    I was ready to, well be very mad.

    Thanks for the solution.
  19. veronika macrumors newbie

    Nov 21, 2007
    admin restored still can't access account

    I have followed both instructions above and created a new admin account as well as a root account. Seems to work fine. However, when I attempt to reset the password for my original account it seems OK but then it still is not recognized when I try to log in. Any suggestions?
  20. ZFuzzy macrumors newbie

    Nov 21, 2007
    ShellyFM, you can reverse this by running "Directory Utility", from the Finder - go to Applications -> Utilities. After this runs click on the Lock icon, log yourself in then go to "Edit" on the menu and you can choose to disable Root. Hope that helps.
  21. Mal macrumors 603


    Jan 6, 2002
    That's exactly what it's supposed to do. When you get the /: root# command, just enter step 3 above and then continue from there. Don't work, you're not likely to do any damage, just make sure you type the rm command exactly as written and you won't have any trouble.

  22. WhiteNoiseMaker macrumors regular


    Apr 22, 2007
    Thanks for this tip its a one I will be sure not to forget! I can't believe its so easy to lose admin status! This tip has saved me loads of time, thanks so much :D

    Are there any problems that might show up later with regards to setting the root password? I'm sure I never set the password for the root account during set-up, now its changed from whatever the system default is.

    EDIT: just noticed ZFuzzy post about removing root user! thanks for that.
  23. vitopod macrumors newbie

    Nov 24, 2007
    I had the same problem with my Imac Intel but even can't type quite anything on my keyboard while booting (keyboard tested).
    If I try command+s i have no response.
    If i try to boot from Leopard DVD or external HD no results. :(
    But it goes in Target mode. I haven't figure out other ideas on how to access my previous admin account :(((
    Any new ideas?

    UPDATE: it turns out that Leopard has enabled my Firmware password and set one i don't know. Maybe i am not the only one that had this problem. Any solution you know?
  24. itgoesforfun macrumors newbie

    Aug 9, 2004
    Short solution = Happy Mac

    Short solution worked perfectly. Thanks! This is the worst upgrade experience i've had with a Mac, including the original OSX fun. Had the lovely BSOD and then this darn mystery Admin deletion which drove me up the wall. So far everything else seems to be OK with Leopard and running quite smoothly and ugh, snappy.
  25. Sealevel macrumors newbie


    May 26, 2005
    Belleair, Florida, USA
    I can't even get it to switch to single user or start from leopard disc. Can't update, nothing works to get rid of standard user. It only comes on to standard user and guest. Any help is welcome!

Share This Page