Leopard and anoying X11 icon

Discussion in 'macOS' started by keitaro85, Oct 28, 2007.

  1. keitaro85 macrumors member

    Joined:
    Jun 5, 2007
    #1
    Does anyone know how to make it so that the X11 icon on the dock is never shown? for example, if i run java from terminal, the X11 icon pops up on my doc. This never happened in Tiger. Any ideas?

    Thanks
     
  2. dr_lha macrumors 68000

    Joined:
    Oct 8, 2003
    #2
    This is because in Leopard, X11 is run automatically whenever it thinks it is needed. In Tiger you had to run X11 manually. To stop this behaviour you can type:

    unset DISPLAY

    or if you are using tcsh instead of bash

    unsetenv DISPLAY.
     
  3. TilJ macrumors member

    Joined:
    Jun 1, 2007
    #3
    dr_lha is right. There's more details in the thread at http://discussions.apple.com/thread.jspa?messageID=5662892, especially the long post from bbeyer. i had to edit my .bashrc/.bash_profile and ditch my .xinitrc. Also, full-screen mode no longer works with X11.

    Now if I only I could get the scrollbar in Terminal to go away again :-(
     
  4. keitaro85 thread starter macrumors member

    Joined:
    Jun 5, 2007
    #4
    I have a bash profile which does:

    unset DISPLAY

    And I modified the ~/Libary/Preferences/org.x.x11.plist to not point to xterm. However, no matter what I do, an X11 icon always pops up when i launch something such as javac.

    I've been scouring the net, and looked at the post TilJ linked to, but still no luck. Has anyone been able to launch anything X related, and not have an X icon on the dock show up?

    Thanks.
     

Share This Page