Leopard and XP network

Discussion in 'Mac Basics and Help' started by Wayne s, Feb 26, 2008.

  1. Wayne s macrumors regular

    Joined:
    Oct 12, 2007
    Location:
    UK
    #1
    I have finally got Leopard to see my XP laptop and vice versa, the problem now is that XP can see my entire Mac drive, even though I have only shared two files on it with XP.

    I have tried every thing I can think of and spent ages searching the forums and the web for a solution to this, it is driving me insane.

    Please help and save my sanity.

    Wayne.

    Ps. Using Leopard 10.5.2
     
  2. stomer macrumors 6502a

    Joined:
    Apr 2, 2007
    Location:
    Leeds, UK
    #2
    By default, admin users have all their volumes shared, not just the ones specified.

    There's a config file generated at /var/db/smb.conf
    In this file, there is a line which reads:
    Code:
    com.apple: show admin all volumes = yes
    
    Just after the include for /var/db/smb.conf, you will need to add something like this to the /etc/smb.conf file:
    Code:
    [homes]
    com.apple: show admin all volumes = no
    
    The problem is that /etc/smb.conf and /var/db/smb.conf are both managed by the OS, so are prone to being overwritten, thus losing any user specified changes.
    Another solution would be to change your user level from administrator to standard.
     
  3. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #3
    you can share only your public folder to a windows PC by ticking "Allow guests to connect to shared folder" in the Guest Account preferences,

    [​IMG]

    ticking "Share files and folders using SMB" but not ticking your user name in the File Sharing options

    [​IMG]

    and then typing "guest" after your PC's name in the password prompt when double clicking your Mac's public folder in "My Network Places".

    [​IMG]

    make sure your public folder has been added to the "Shared Folders" list in File Sharing.

    [​IMG]
     
  4. Wayne s thread starter macrumors regular

    Joined:
    Oct 12, 2007
    Location:
    UK
    #4
    Tried that richthomas, when I enter the user name and pass word in xp it rejects it.

    Right, got it now. Had to type my user name in upper case.

    Thanks for that
     
  5. Wayne s thread starter macrumors regular

    Joined:
    Oct 12, 2007
    Location:
    UK
    #5
    Next problem,:confused::confused: I just tried to share a new folder and it does not show up in xp, the public folder shows as well as my printer but nothing else.

    I tried restarting xp and Leopard but still no good.
     
  6. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #6
    not sure sorry it took me a while to work out how to share my public folder. its a lot easier to share folders to other Macs using AFP. you will maybe have to share your whole home folder by ticking your user name under "Share files and folders using SMB" and then place the folder in your home folder. this will also share you docs, music, pics etc folders but im not sure if this will share your whole hard drive again though.

    i would test it out but im just about to crash. good luck!
     
  7. spincrasher macrumors newbie

    Joined:
    Mar 9, 2008
    Location:
    Singapore
    #7
    hi wayne, reading your post is like reading my post! we have the same problem :confused: were you able to fix the sharing problem? appreciate if you can give the details.. thanks a lot! :D
     
  8. thejadedmonkey macrumors 604

    thejadedmonkey

    Joined:
    May 28, 2005
    Location:
    Pa
    #8
    I had the same problem, but it was for a business, so I had to have 100% reliability... Networking XP to Leopard is ridiculously buggy, in the end I got rid of Leopard and installed Vista on the mac mini..

    Between the networking issues and the bastard program that is Office 2008, I must say I've never been so happy to use Windows.
     
  9. eenduiker macrumors newbie

    Joined:
    Apr 2, 2007
    #9
    Problems

    Hi,

    I have the same problem as Wayne s and Spincrasher. Any solution yet?
     
  10. kenmoberg macrumors newbie

    Joined:
    Nov 26, 2007
    #10
    Having the same issue on 10.6.2

    Is there a solution out there for this? All my users can see and modify all the shares. I've tried everything in this thread with no luck. When I log in as a user and map the smb mount in windows xp, i can create a new folder. When I look at the owner of it on the mac, the user and group is _unknown not the user as I would expect.

    So it would appear the authentication is happening to smb with the users id and password but samba is not maintaining that userid for permissions. I've administered samba before but not on a mac. Obviously this is different.

    Any help out there?
    Thanks in advance,
    Ken
     
  11. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #11
    just tested it again, but this time with Snow Leopard.

    sharing your Public folder using my steps above will only just share your Public folder to Windows clients. just make sure your name is unticked in advanced Sharing options and guests are allowed to connect in Accounts.

    then in XP just open Network Places and view workgroup computers. your Mac should show and you will be able to view your Public folder without providing credentials. if its not working or your whole home folder is still visible i find logging out and back in helps.
     

Share This Page