Leopard Boot Camp Partition

chriswg

macrumors member
Original poster
Jun 4, 2007
73
0
Colorado, USA
Has anybody else noticed that their Windows Partition shows up on the Leopard desktop when your finder preferences are set to show "CDs, DVDs, and iPods" on the desktop. I have the preference for showing hard drives turned off in the preferences (see picture). It wasn't like this in Tiger, so I'm just curious to see if it is normal in Leopard or if I have some sort of issue. I'd really appreciate a quick response from anyone because I asked a couple of times in another thread, but I think the question got lost in all the discussion. Everything else about the installation and Leopard is running perfectly.

Thanks everyone.

So am I the only having this problem? I'm kind of new to this, so I'm not sure what to do. If it's not normal, then I will probably try a reinstall to see if that fixes it. Please...somebody...respond...
 

Attachments

nsjfoster

macrumors newbie
Jun 6, 2007
8
0
10.4 had this

So am I the only having this problem? I'm kind of new to this, so I'm not sure what to do. If it's not normal, then I will probably try a reinstall to see if that fixes it. Please...somebody...respond...
I have a MacBook that I have installed Leopard on but don't use BootCamp so can't address this question.
However, I have an iMac that I'll install later. It has BootCamp. And it shows the C: drive on the desktop for a Vista install. So I'm not sure this arrived with Leopard. I didn't notice it till yesterday but it's not Leopard related.

I'm not sure if it is dangerous or not (ie to delete files or something) but we may get some more guidance from someone else.

I'll install Leopard on the iMac later this week so can see then what happens.
 
Comment

chriswg

macrumors member
Original poster
Jun 4, 2007
73
0
Colorado, USA
Thanks a lot for the reply; I was beginning to think everyone was avoiding me on purpose.

That is very strange because I also have a Vista install, but Tiger always recognized it as a hard drive. Now Leopard seems to be recognizing it as a "CD, DVD, or iPod." Did Finder maybe have different Preference options in Tiger? Is your Windows partition NTFS or FAT32? I wonder if that has something to do with it. Mine is NTFS, so maybe Leopard considers that a "CD, DVD, or iPod?" It just doesn't make sense to me, so that's why I'm concerned.
 
Comment

matt321

macrumors member
Oct 27, 2007
94
2
I experience the same thing. I have a vista NTFS partition and when I uncheck that box, the bootcamp disk disappears from the desktop.
 
Comment

chriswg

macrumors member
Original poster
Jun 4, 2007
73
0
Colorado, USA
@ matt321 -- Thanks so much for the confirmation of this situation. Now I don't have to do a reinstall!

I just wonder if this is by design or if it is a bug...
 
Comment

wjanoch

macrumors newbie
Oct 26, 2007
25
0
Montana
Sounds like a BootCamp Bug (mild)

I just wonder if this is by design or if it is a bug...
@chriswg

Clearly a partition on the hard drive is not a CD, DVD, or iPod... except that an iPod is an external HDD. Even still, I doubt they want to seriously associate iPods with Vista directly.

It'd make more sense to end users if they made the "External disks" control that, or add an entirely new check box for "Boot Camp disks".

it shows the C: drive on the desktop for a Vista install. So I'm not sure this arrived with Leopard. I didn't notice it till yesterday but it's not Leopard related.
This sounds like Windows in Parallels, not Boot Camp. Parallels 3.0 added the "feature" of automatically mounting the Windows drives when a Windows session is open. It also added another tool called "Parallels Explorer" which allows you to browse the contents of Parallels Disk Images without having to boot Windows.

Wm
 
Comment

dpfenninger

macrumors regular
Nov 23, 2005
118
21
Any updates on this? I just converted my Boot Camp partition today from FAT32 to NTFS, and suddenly the Windows hard drive is showing up on my Mac desktop...also being recognized as a "CD, DVD, or iPod."

I've got to think this is a bug. Anyone have a solution?
 
Comment

Amigalander

macrumors regular
Jan 13, 2008
137
4
Rename the NTFS partition (in Windows) to start with a period. Then it will be hidden on the Mac.
 
Comment

ColinEC

macrumors 6502
Apr 4, 2008
296
0
Hey guys, didn't want to make a new thread on this so I decided I'd super bump this post :p

The problem has been fixed in the 10.5.3, you can now uncheck "Hard disks" and both the Macintosh HD and Windows HD won't show anymore :D
 
Comment

phenixbleu

macrumors member
Feb 12, 2008
41
0
The Bug still remains

Hey guys, didn't want to make a new thread on this so I decided I'd super bump this post :p

The problem has been fixed in the 10.5.3, you can now uncheck "Hard disks" and both the Macintosh HD and Windows HD won't show anymore :D
After I tested 10.5.3 The bug still remains. If the boot camp drive is partitioned as FAT32 it will be recognized as a hard drive. If NTFS then CD,ipod. Its a format thing. I have reported it to apple and it seems that they are getting closer to fixing it. Just to make sure, report it again to apple.
 
Comment

bconeill

macrumors newbie
Feb 7, 2009
12
0
After I tested 10.5.3 The bug still remains. If the boot camp drive is partitioned as FAT32 it will be recognized as a hard drive. If NTFS then CD,ipod. Its a format thing. I have reported it to apple and it seems that they are getting closer to fixing it. Just to make sure, report it again to apple.
Does anyone know if Apple has provided a fix or workaround to this, yet?
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.