Leopard Bootcamp drivers any better?

Discussion in 'Windows, Linux & Others on the Mac' started by simonpickard, Aug 27, 2009.

  1. simonpickard macrumors regular

    Joined:
    Mar 1, 2009
    #1
    Hello all,

    So has anyone tried the new Bootcamp 3.0 drives off the Leopard disk with Windows yet?

    Do they support Windows 7 now? Any improvements to battery life, heat, etc?

    Post your findings! :)

    Regards,
    Simon
     
  2. ilkevinli macrumors 6502

    ilkevinli

    Joined:
    Apr 8, 2006
    Location:
    NYC
  3. Stridder44 macrumors 68040

    Stridder44

    Joined:
    Mar 24, 2003
    Location:
    California
    #3
    Be more specific.
     
  4. ilkevinli macrumors 6502

    ilkevinli

    Joined:
    Apr 8, 2006
    Location:
    NYC
    #4
    Ok. The audio volume is still low and the Video drivers don't install properly. Better ?

     
  5. simonpickard thread starter macrumors regular

    Joined:
    Mar 1, 2009
    #5
    That's a shame if it's true.

    I wish Apple would sort out the bootcamp drivers.
    There's no reason why battery life under windows should be way less that under osx.

    Regards,
    Simon
     
  6. palexandridis macrumors newbie

    Joined:
    Nov 2, 2007
    Location:
    Portland, OR
    #6
    It took me several restarts to get all of the drivers installed. Now, the sound seems have developed a buzz I'm assuming is from the new audio drivers. But I'm sure this buzz is finely tuned...:D
     
  7. RITZFit macrumors 65816

    RITZFit

    Joined:
    Sep 16, 2007
    Location:
    In my Corner
    #7
    I did a clean install on a fresh HD when I got SL so I also had to do another BC partition. After I installed xp sp2 I tried the 3.0 drivers from SL right off the bat...the installation seemed a bit choppy, plus when I tried to run sp3, the installer "magically" couldn't find the files it just extracted :rolleyes: anyway the installer quit w/ undoing the changes it did make and screwed my fresh installation (btw, I've used these same disks for BC partitions MANY times in the past and NEVER seen an error like this). Just reinstalled windows again and now (and until further notice) running 2.1 drivers.
     
  8. simonpickard thread starter macrumors regular

    Joined:
    Mar 1, 2009
    #8
    Good job Apple.
    :(

    The main reason I ordered SL was for Bootcamp 3.0.
    Seems like it's a step backwards.

    Wonder when Bootcamp 3.1 will be out?

    Regards,
    Simon
     
  9. psingh01 macrumors 65816

    Joined:
    Apr 19, 2004
    #9
    Yep, the new drivers suck. I have a Late 2006 17" MBP. Was running XP Sp3 from bootcamp with no problem until I updated the drivers to snow leopard. Got random blue screen with automatic reboot!

    Got rid of my XP partition and started over from scratch (instead of upgrading an existing one). Same deal.

    I recreated my bootcamp partition a 2nd time, this time with the leopard drivers and XP is back to being stable.
     
  10. simonpickard thread starter macrumors regular

    Joined:
    Mar 1, 2009
    #10
    Hello all,

    Well I had to post as I've been running via bootcamp 3.0 today.

    Have to say the new drivers have been rock solid for me under Windows 7 64Bit.

    I can see my mac hard disk just fine (although read only? anyway to change this?).

    Everything seems perfectly stable for me. It's only been a day so that could well change but so far everything has been perfect.

    Regards,
    Simon
     

Share This Page