Leopard bug or router problem? :s

Discussion in 'macOS' started by tibi08, Jan 31, 2008.

  1. tibi08 macrumors 6502a

    tibi08

    Joined:
    Sep 17, 2007
    Location:
    Brighton, UK
    #1
    When I wake my MBP from sleep, it takes ages to connect to my home network (a wireless G router, with latest firmware) - at least 15 seconds and sometimes more like 25 seconds.

    I thought this was odd since it used to take less than 5 seconds on my Powerbook G4 under Tiger.

    I have narrowed the problem down to network encryption - with either WPA or WEP encryption enabled on my router, it takes significantly longer for my MBP to connect to the network. However, with no encryption it is < 5 seconds.

    Anyone have any ideas on whether this is Leopard or my router at fault?
     
  2. zirkle2007 macrumors 6502

    zirkle2007

    Joined:
    Sep 25, 2007
    Location:
    Indiana, USA
    #2
    Well WPA slows things waaaay down with home routers. They just are meant for that kind of encryption. I use WEP on my Linksys WRT54G with no trouble at all. Takes about 5 seconds.

    Just realized I completely didn't help you at all. :rolleyes:

    I would say check the router. Maybe do a factory reset and redo your settings with a WEP encryption. What kind of router is it?
     
  3. motulist macrumors 601

    motulist

    Joined:
    Dec 2, 2003
    #3
    leopard has tons of wifi problems. Just search the forum for 'leopard wifi' or 'leopard airport' and you'll get tons of people reporting major problems. If you can connect after 25 seconds and then everything is fine, then count yourself lucky and keep pestering Apple for a fix like the rest of us are doing.
     
  4. iBecks macrumors 6502

    Joined:
    Nov 24, 2006
    Location:
    Nottingham, UK
    #4
    I use WPA and have used WEP and WPA2 with a MBP and a iMac and have never had the connection times that you are stating.

    I'm really not sure where the above poster zirkle2007 has got his information from, but WPA is fine on any router.

    Is 25 seconds really that bad from sleep, does it take as long from a cold boot?

    The problem will more than likely be Leaopard, as you say it works fine under Tiger.

    You could try setting up MAC address filtering and turning of encryption, this will give you some level of security, also try disabling the broadcast of you wireless networks SSID, again another precaution.

    Encryption should always be used, but try the above as a work around.
     
  5. northernmunky macrumors 6502a

    northernmunky

    Joined:
    Jan 19, 2007
    Location:
    London, Taipei
    #5
    Yeah, theres def a few Leopard bugs especially with wireless-n (we're on 'n' with WPA2), my MBP has been on a LAN cable since I installed Leopard because the connection is so unstable and our iMac is the same. No problems when booting to Windows, or our one Windows laptop.

    ...although recently my MBP seems to have corrected itself... to a point....
     
  6. tibi08 thread starter macrumors 6502a

    tibi08

    Joined:
    Sep 17, 2007
    Location:
    Brighton, UK
    #6
    I tried WEP, it is just as slow as WPA. Only no encryption is quick.

    It's a 3Com router and I have upgraded it to the latest firmware and done a factory reset.

    Maybe a new router is required, but I feel a bit miffed to do so, since I find it hard to believe it's not the MBP/Leopard :(
     
  7. cogsinister macrumors 6502a

    Joined:
    Aug 24, 2006
    Location:
    Fredericton NB Canada
    #7
    The WEP encryption on my cheapo Siemens router connects to my MacBook in about 5 seconds......so it may well be the way your 3M router impliments the encryption.......

    Try another router and see if its any faster.............
     
  8. aross99 macrumors 68000

    aross99

    Joined:
    Dec 17, 2006
    Location:
    East Lansing, MI
    #8
    How about going into the Network control panel (under the Airport Tab?), and clearing out old networks from the "Known Network" list (sorry if the terminology isn't quite right - I don't have access to my MBP right now). I'm talking about the list of wireless networks you have connected to over time -

    I thought I read somwhere that there is something about having alot of networks in your "known network list", and that it has to do something with each one, until it gets down to yours.

    If you travel with your Mac very much, you can accumulate a bunch of networks in that list. I just delete them every now and then, so they don't accumulate.

    If nothing else, make sure your network is on the top of the list...
     
  9. theman macrumors 6502a

    Joined:
    Jul 26, 2007
    #9
    it suddenly started to take a very long time for me last week. i have WEP encryption. then, evertime i awoke my mac it would say it couldn't find my network. i had to type in my network name and password every time i woke it.... but now, today, it miraculously cured itself and connects instantly when waking. really weird.
     

Share This Page