Leopard - cannot install on this volume

Discussion in 'macOS' started by ansalmo, Oct 26, 2007.

  1. ansalmo macrumors regular

    Joined:
    May 23, 2005
    #1
    So I got my copy of Leopard in my grubby little hands and eagerly stuck it in my MacBook to do an update over lunchtime. It gets to the "select a destination" screen and my drive has a big red exclamation mark in it.

    Apparently it can't install onto this volume as it needs repartitioning as a "GUID Partition Table" type, and that will of course obliterate the contents. It's currently "Apple Partition Map", which Disk Utility claims will only boot PowerPC machines. Hmmm, seems to have been working like that quite happily in Tiger for a year :confused:

    Ah well, I guess I'll have to wait until I get home this evening, install it on my Mac Pro and then backup the MacBook and do a clean install. :(
     
  2. Slip macrumors 6502a

    Slip

    Joined:
    Oct 16, 2007
    Location:
    Wiltshire, England
    #2
    I think you're gunna have to go the GUID Partition Table way...
    Personally I didn't know Intel's could even boot with the Apple Partition Map :confused:
    Boot into Tiger and backup all the files you need and then I think you'll have to do an Erase and Install.
    Hope that helps and good luck! :)
     
  3. Selenolycus macrumors regular

    Joined:
    Feb 23, 2006
    Location:
    Northern Hemisphere
    #3
    Might want to try opening Disk Utility during installation, unmount then remount the partition - might do nothing at all, but it might work.
     
  4. juliuspleaser macrumors newbie

    Joined:
    Feb 22, 2007
    #4
    I am having the same issue saying that my hard drive can't be selected (red exclamation) as the install location as it "cannot start up from this volume" yet in disk utility it says it is bootable, and obviously without the install DVD in I can boot just fine into my computer so I know the HD is fine. I even tried repairing permissions and repairing disk to make sure.
    So my install fails if I try and pick it anyways as it can't "prepare" that HD for install.
    The partition is formatted as "Mac OS Extended(journaled)"

    Any ideas?
     
  5. juliuspleaser macrumors newbie

    Joined:
    Feb 22, 2007
    #5
    I double checked i had a "Guid partition table" and I tried the unmount/mount suggestion.
    Still get the same cannot startup from this volume warning.
     
  6. janstett macrumors 65816

    Joined:
    Jan 13, 2006
    Location:
    Chester, NJ
    #6
    Same problem here on my Macbook Pro. I did just recently replace this hard disk (swapped out the 100gb 5400 that came with it for a 200gb 7200 drive) using Carbon Copy Cloner to clone the disk. Obviously it boots fine but Leopard won't let me install onto this drive. Some signature that Carbon Copy doesn't write?
     
  7. kevinwiz macrumors regular

    Joined:
    Feb 1, 2007
    Location:
    socal
    #7
    same problem here. i really don't want to do backups because i want everything to be the same as it was before. this is so frustrating.
     
  8. Troyundroy macrumors newbie

    Joined:
    Oct 27, 2007
    #8
    You guys got further than I did with my install of Leopard. When it comes to the select a destination screen, there's simply nothing to select. No red exclamation mark. Any ideas of what's going on there? Tiger is running fine. After reading all of the installation problems are having I'm thinking of staying with Tiger.... annoying!
     
  9. RosieO macrumors member

    Joined:
    Sep 28, 2007
    #9
    Leopard-Install failed

    On my first try I was able to get past the part where it says "checking Install DVD" After that ran, took about 20 minutes, I now get an install failed. When I tried to redo it I got a yellow triangle in my HD icon and it said I had to do an erase and install. I called Apple Care and they pretty much said that is what I had to do (erase). So I started over, erased and and it once again ran past the "checking install DVD' and then when that was finished it started the install again and a screen came up, "Install failed. Mac OS X could not be installed on your computer. The installer could not create the folder "/volumes/Macintosh HD?Basesystem.pkg.147amuPgU" Now I am on hold once again with Applecare. Any ideas what might be wrong?
     
  10. brbubba macrumors 6502

    brbubba

    Joined:
    May 20, 2006
    #10
    Hey I used carbon copy cloner on mine too and I am having the same problem. WTF? I guess this gives me an excuse to get my PC back up and running so I have somewhere to backup to. UGH!
     
  11. inderweltsein macrumors newbie

    Joined:
    Oct 28, 2007
    #11
    About the yellow exclamation mark problem ...

    I have succeeded in solving this problem without having to do any backup.

    But this involves correcting hexadecimal values in the GPT (first deleting other entries than EFI and the HFS+ partition of Tiger, then calculating two checksums, in order these changes are not replaced by the GPT backup).

    And after installation of Leopard, rewriting the original GPT (to get access back to all your partitions)

    Basically, the installer seems to support GUID partition tables with :
    - either just one HFS+ partition, with any size, it does not matter if it does not fit on 100% of the disk
    - or two partitions, a HFS+ one and a "Basic Data" one (that can be FAT32/NTFS for Windows or ext3/reiserfs/jfs/whatever for Linux) but in this case, the installer absolutely wants that the sum of both equals 100% of the disk.


    I came to these conclusions because in my case, I had three partitions :
    + the HFS+ one
    + an ext3 one (described as "Basic data" by the GPT)
    + a Linux swap one
    = 100% of the disk

    First I tried to make something that is not data-destructive : delete the Linux swap. I was thinking it would work because the installer would see an HFS+ one and a "Basic Data" one (and would think I have a Boot Camp/Windows installation)
    But it did not worked, because HFS+ plus Basic Data does not fit the whole disk (Bootcamp partitioner partitions disks like this)

    I could have chosen to resize, extend the ext3 one in order that all the disk but I did not think about it.

    So my solution was finally what I have said earlier : to edit the GPT to make the installer believe there is just a HFS+ partition (and empty space instead of Linux/Linux swap partitions) then after the installation, to restore the GPT to its full extent.

    I may post a page with a HOW TO of my method in the coming few hours or few days (I made my hack under Linux, but it is doable under Mac OS X)

    But in all cases, this is the presence of another partition, that the installer doesn't like, that is causing you the yellow exclamation mark problem. So if you can delete it, you can solve it without my method or the "obligatory" backup.
     
  12. hughjaas macrumors newbie

    Joined:
    Jun 29, 2007
    Location:
    San Diego
    #12
    Leopard install GUID Partition workaround


    I succeeded without having to mess with any hexadecimals to bypass the GUID partition requirement:

    when you get to the screen that has the red exclamation point and all the other options grayed out, just double click on your hard drive icon and you can choose 'archive and install'.

    Update: nevermind, this doesn't get all the way through. after further research, there is no way to change the partition scheme without repartitioning/reformatting. I ended up logging in as 'root', copying my user folder to another drive and then wiped it clean with a repartition.
     
  13. VociferousOnion macrumors newbie

    Joined:
    Oct 29, 2007
    Location:
    Austin
    #13
    Same Problem

    I got the same error message when indicated to select a volume on which to install. Why might I (and apparently a few others) have a different partitioning on my MacBook Pro than most? I've erased and restored between a couple computers a couple times, but I am very fastidious, and can't imagine clicking to change partitioning without knowing what I was doing. Any ideas?? I really don't want to have to do a clean install... really.
     
  14. janstett macrumors 65816

    Joined:
    Jan 13, 2006
    Location:
    Chester, NJ
    #14
    The key seems to be how you format the blank disk. The Apple partition scheme appears to be an artifact of the power pc era but apple left it the default. Worse, while tiger and leopard have no problem booting such a system the installer won't even let you try.
     
  15. VociferousOnion macrumors newbie

    Joined:
    Oct 29, 2007
    Location:
    Austin
    #15
    update...

    I've got Leopard on my computer now without too much hassle, but only due to fortunate circumstances. I'm lucky in that I happened to have another identical MacBook Pro as mine lying around. It is actually my Mom's. She bought it from my brother, and it was in transit to her via me. She was about to wipe it clean and start from scratch on it. I first confirmed that it did have the correct (GUID) partitioning. I booted it up as a firewire drive, and safe booted my computer. I erased my Mom's computer and restored to it from mine. Then, I repartitioned my computer, and reversed the process: erasing mine and restoring to it from my Mom's. Then, I just installed Leopard, since I now had my data and GUID partitioning on mine. Then I did a clean install of Leopard onto my Mom's and gave it to her. I ended up where I wanted to be without as much headache as I was dreading. It is just perplexing still how I ended up with the wrong partitioning in the first place, and why it seems to be such an unusual problem. I'd be interested in any thoughts people might have regarding that.
     

Share This Page