Leopard cannot print in Word but yes with others

Discussion in 'macOS' started by tivoboy, Nov 8, 2007.

  1. tivoboy macrumors 68030

    Joined:
    May 15, 2005
    #1
    So, my trusty HP laserjet 1012 seems to have a problem with Leopard.

    I DOES seem to print from a webpage or some other sources, but with MSFT WORD, I get a dialogue that says, cannot print, check the Printer Center, which is nowhere. What is up?
     
  2. glennyboiwpg macrumors 6502

    Joined:
    Feb 16, 2007
    #2
    I actually posted something today with a VERY similar problem. Only diff is that this was tiger not leopard.


    This was solved by doing an update.

    do you have an update available.
     
  3. tivoboy thread starter macrumors 68030

    Joined:
    May 15, 2005
  4. tivoboy thread starter macrumors 68030

    Joined:
    May 15, 2005
    #5
    what I did

    Here is what I had to do, time machine saved the day!

    Yep, saved my butt.

    Here is the story. I am still not TOO happy with the upgrade, speed, some interface issues, firewall, etc. But, it is a .1 version, right.

    I had done the install, and done some cleanup, printers I didn't use, and monolingual to reduce languages that I should NOT have installed in advance. I DIDNT do many architecture removes, and CERTAINLY didn't do any PPC architecture removes. But,

    I could not longer PRINT from Word or Excel, which is BAD!

    I found over at the apple forums, that monolingual is doing something bad and removes something that the PPC side of the OS requires, to print from previous PPC version only applications.

    And then I remembered, I had done a Time Machine backup RIGHT after install. So, to the printers folder I went, clicked on the folder, hit RESTORE, and boom, I was back in business printing.

    So, TM certainly made it easier for me to repair this issue. Was it a leopard problem, maybe not, but it was something that could have taken a long time to repair.
     
  5. naburleson macrumors newbie

    Joined:
    Sep 2, 2007
    #6
    I have the same problem but I don't have a saved backup, anyone know how to restore the drivers to the directory? I used monolingual and am unable to print from word, excel ,and powerpoint. :confused:
     
  6. naburleson macrumors newbie

    Joined:
    Sep 2, 2007
    #7
    Ok FYI, for anyone having problems printing from work, excel, and powerpoint, below is the solution, I found it on apple support forums thanks to Axel F.

    --Here's THE SOLUTION that worked for me---

    1. download Pacifist and Onyx from Macupdate.com
    2. print out these instructions, then QUIT ALL APPLICATIONS (except Console, if you wish)
    3. Insert OS X Install Disk
    4. Launch Pacifist and select "Open Apple Install Packages", then "OS Install"
    5. Look in OSInstall->EssentialSystemSoftware->EssentialSystemSoftwareGroup->Essentials.pkg
    6. In that package, Open System --> Library --> Printers(Leopard users look below)
    7. Right click on "CVs" Folder, and select "Install to Default Location". Select "Replace" for any duplicate files.
    8. Do the same for the "Libraries" Folder
    9. Restart and Fix permissions with Onyx
    10. Enjoy
    Everything is good until you get to Step 7 in LEOPARD. There is no "CVs" Folder. So what I did was right clicked on PRINTERS mentioned in Step 6 and selected install to default location. In other words I installed the entire contents of the Printer folder. It was a little under 3MB (not big). The Folder in step 8 "LIBRARIES" is also a subfolder of PRINTERS so that too was copied.
    That was it and Word and office components began to print again to the printer and PDF.
     

Share This Page