Leopard Disk Utility Formatted HDD-FAT Not recognized by XP

Discussion in 'macOS' started by mikaeltan, Dec 19, 2007.

  1. mikaeltan macrumors newbie

    Joined:
    Dec 19, 2007
    #1
    I recently formatted one of my HardDisk using the Leopard's Disk Utility into FAT32 format.

    The HDD works well with the MAC however it will not mount on a windows XP machine.

    The hardware detector detects the USB external harddisk but is not able to mount it. When i use the Windows Disk Management Utility, the hard disk appears with a (Not Initialized) and Unallocated warning message.

    Any clues anyone?
     
  2. WildPalms macrumors 6502a

    WildPalms

    Joined:
    Jan 4, 2006
    Location:
    Honolulu, HI
    #2
    Formatted the whole drive for use with Windows? What's the partition table set? GUID? MBR? You'll need to use MBR for Windows XP to correctly read it.
     
  3. mikaeltan thread starter macrumors newbie

    Joined:
    Dec 19, 2007
    #3
    The reason for me to format the HDD using FAT32 is so that it can be used for read and write for both XP and Mac. I have done this a dozen times using Mac OSX Tiger and never had a problem with this.

    I do not need to set the MBR as the Disk Utility on Mac OSX takes care of this for me automatically. Something has changed in Leopard. The newly formatted FAT32 drives by Leopard are no longer recognized by XP.

    Has anyone else experienced this?
     
  4. apfhex macrumors 68030

    apfhex

    Joined:
    Aug 8, 2006
    Location:
    Northern California
    #4
    Yes. I have an external Firewire that Windows couldn't read after formatting it in Disk Utility (which doesn't let you choose the partition table). Had to instead find some funky Windows command line utility to format the drive FAT32 (as Windows doesn't let you do it above 32GB :mad:).
     
  5. Bonebreaker macrumors newbie

    Joined:
    Jun 4, 2008
    #5
    Leopard's disk utility seems to create FAT32 partitions with GUID partition scheme by default. Just click on the disk in disk utility and see what it shows under "Partition Map Scheme". This is for use on an Intel based Mac.

    Click on Partition, Change Volume scheme from "current" to "1 partiton". click Options, select "master boot record", to create a windows compatible partition. Select ok and hit the apply button.

    Does it work now?
     
  6. mitziron macrumors newbie

    Joined:
    Jul 30, 2008
    #6
    I had this exact problem and the solution provided by Bonebreaker worked great on my Intel Mac with Maxtor USB 250GB drive. Thanks!

    Only thing I would add is that once you select "1 partition" you will need to (re)set the format to MS-DOS (FAT) on the right hand side. It goes back to Mac OS Extended.
     
  7. Gee macrumors 65816

    Joined:
    Feb 27, 2004
    Location:
    London, UK
    #7
    I had the same problem reformatting a pen drive. Haven't tried, but thanks for the fix. I agree with the OP though - it used to work fine by default in Tiger.
     
  8. rickogorman macrumors newbie

    Joined:
    Aug 18, 2008
    #8
    Works

    Gee, just tried formatting a pen drive using Bonebreaker's tip and it works. I had a drive that would appear in the Finder sidebar if I plugged it directly into my MBP but not if I plugged it in through a hub. It was somehow corrupted because even when I could open it, files would not show up that OS X itself said were there. Re-formatting fixed the problem.
     
  9. hypermaster macrumors newbie

    Joined:
    Jun 22, 2007
    #9
    can someone help me out here... i had an external HDD working perfectly fine with my MBP on leopard.
    i have sold my MBP (getting a new one). Till my new one comes, i wanted to copy the documenst backup from my External HDD to my win 7 laptop at home.
    But the HDD is not being recognized... its actually being recognized, but does not show up a drive ??

    Please help,. i need some things urgently.

    Thanks in advance..

    FOUND THE PERFECT TOOL - - -
    http://hem.bredband.net/catacombae/hfsx.html

    I'm NOT SORTED NOW.
     

Share This Page