Leopard: DMG files no longer mount on double-click

Discussion in 'macOS' started by kife, Jul 8, 2010.

  1. kife macrumors newbie

    Joined:
    Jul 8, 2010
    #1
    Something must have changed with the last software update I did. The DMG files now open in Disk Utility instead of automatically mounting when I double-click. Not really a show-stopper as I can still mount thru D.U. but kind of annoying...

    How do I get the old behavior back?

    I am on Leopard.
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
    Select .dmg file,
    press CMD+I (or right click > Get Info), ​
    go to the Open With section ​
    and select the DiskImageMounter, ​
    then press Change All.​

    [​IMG]
     
  3. kife thread starter macrumors newbie

    Joined:
    Jul 8, 2010
    #3
    Thanks, that helped.

    For the record, the DiskImageMounter disappeared from the drop-down menu in the file info box, not sure why.
    Had to locate it manually in /System/Library/CoreServices (had to uncheck "Recommended Applications" first).
     

Share This Page