Leopard: Endless Boot Loop

Discussion in 'macOS' started by matd, Mar 17, 2008.

  1. matd macrumors member

    Joined:
    Jul 14, 2004
    #1
    Hello I have a real weird problem,

    I've updated my Tiger 10.4.11 to Leopard 10.5.1 and now in an neverending reboot loop. My MacBook (2Ghz Core Duo, 2 GB Ram) starts, then I get a grey screen with Apple Logo, then after 2 minutes, the computer reboots and so one....

    To stop this (infinite) reboot loop I need to put the Leopard DVD !!!! :confused: in the drive and wait for an unknown time of reboots to finally get the login screen. After that I can log in and use Leopard without any problem.

    I have no clue, what is going wrong, I've checked the Startupitems ( none, deactivated the Time Machine) and reset PRAM several times...

    I'm really upset because I really don't know why the MacBook is rebooting and needs the Leopard DVD to correctly boot ???
    Thanks a lot for your help !
     
  2. nufanec macrumors regular

    Joined:
    Sep 10, 2005
    #2
    Sounds like software - try an archive and install.
     
  3. Duff-Man macrumors 68030

    Duff-Man

    Joined:
    Dec 26, 2002
    Location:
    Albuquerque, NM
    #3
    Duff-Man says...doing an archive and install is a bit harsh as a first-try fix. I would try some simpler things first. Download the 10.5.2 combo updater and apply that and see if it helps....oh yeah!
     
  4. matd thread starter macrumors member

    Joined:
    Jul 14, 2004
    #4
    Hi,

    Now I have tried to update 10.5.2 (Combo Update) unfortunately same problem :-( I don't know what to do else...
     
  5. steerpikegg macrumors member

    Joined:
    Nov 19, 2007
    #5
    I had a similar problem to this - I fixed mine by deleting everything in /Library/Caches/

    May be worth a try.
     
  6. ThirteenXIII macrumors 6502a

    Joined:
    Mar 8, 2008
    #6
    Verify Disk with Restore disks
    Repair Permissions w/ Restore Disk

    Do a safe mode boot to disable any nuisance log in item or remove any file that might be a culprit

    goodluck!
     
  7. Duff-Man macrumors 68030

    Duff-Man

    Joined:
    Dec 26, 2002
    Location:
    Albuquerque, NM
    #7
    Duff-Man says....another culprit can be external devices. If you have anything connected (other than kybd and mouse) temporarily unplug them...oh yeah!
     
  8. matd thread starter macrumors member

    Joined:
    Jul 14, 2004
    #8
    Ok, so I've tried following stuff:

    PRAM reset several times, no devices connected, SMC reset several times

    - Clean install of Leopard : endless boot loop until I press Command + V and reboot. Sometimes "You need to restart your computer" message

    - Install of Leopard with Update 10.5.2 : endless boot loop
    Sometimes "You need to restart your computer" message

    - Clean install of Tiger: works wonderful
    - Clean install of Tiger + Upgrade to Leopard : endless boot loop

    Once started (after a random number of minutes, going from 5 to 20 minutes of reboot loops)

    Leopard works without any problem and is very fast.

    I bought my MacBook (1,1) in June 2006 and it has 2Ghz and 2 GB Ram. Apple Hardware Check was also ok.

    Here is an excerpt of a "strange" message coming when I boot in verbose mode

    BSM Auditing present and then reboots
    panic cpu 0 caller 0x001A7BED) : Kernel Trap at 0x001a1ca2
    Backtrace terminated-invalid frame pointer 0

    BSP process name corresponding to current thread: kernel_task

    Mac OS version:
    Not yet set

    kernel Version:
    Darwin Kernel Version 9.10.0
    System model name: MacBook 1,1

    Here is a pic (sorry for the quality) of my error message: http://matdonline.free.fr/macbook.jpg

    I'm really disappointed. It seems as if Leopard can't boot correctly with early MacBooks !

    What else could I do ? Thanks a lot!
     
  9. Dave Nagel macrumors newbie

    Joined:
    May 29, 2008
    #9
    Found One Cause of Endless Reboot

    This probably isn't the cause or solution to your problem, but I might as well post my experience with the Leopard endless reboot here for future generations.

    The mistake: I changed the permissions for the folder System/Library/LaunchDaemons and the file com.apple.backupd-auto.plist to reset my Time Machine backup interval. Unfortunately, I forgot to set the permissions back to normal when I finished. At the next startup, my MacBook Pro (2.5 GHz, Leopard 10.5.2) went into the endless reboot.

    The fix: I restarted in FireWire target disk mode and accessed the files from another one of my Macs, changed the permissions back to normal, and restarted. Everything worked fine after that. (This problem was NOT fixed using Repair Permissions in Disk Utility. I had to change the permissions back manually using Get Info on the specific folder and file.)

    As a side note, at one point I had given up on fixing the endless reboot and decided to restore from my Time Capsule. But the Time Capsule wouldn't accept my password! Well, that forced me to keep trying, and I was eventually successful. But what's the deal with the password not being recognized? Anybody encountered this? I haven't fixed it yet.
     
  10. AussieSusan macrumors member

    Joined:
    May 29, 2006
    Location:
    Melbourne, Australia
    #10
    We (my son and I) had this happen on a G5 iMac a week or so back. Running the TechTools software (booted from the DVD) identified a bad disk node structure and bad memory.

    We replaced the memory (we had some spare to test with) and restored the disk from a backup. Now all is well.

    We suspect that the memory failed and this caused something bad to happen to the disk structure.

    Looking back, the thing that pointed to the bad RAM was the boot process was crashing (hence the restart) with a message about a corrupted skiplist (can't remember the exact wording now) which typically is a memory-only structure.

    Susan
     
  11. chetvolpe macrumors newbie

    Joined:
    Jan 15, 2009
    #11
    I have the exact same problem... except I don't have another Mac to do the firewire/target thing... any details on changing the permissions via the terminal from the install disk... any help would be appreciated.

    Thanks,
    Chet
     
  12. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #12
    You changed the same files? In that case, you can do:

    chmod 755 /System/Library/LaunchDaemons
    chown root:wheel /System/Library/LaunchDaemons
    chmod 644 /System/Library/LaunchDaemons/com.apple.backupd-auto.plist
    chown root:wheel /System/Library/LaunchDaemons/com.apple.backupd-auto.plist
     
  13. chetvolpe macrumors newbie

    Joined:
    Jan 15, 2009
    #13
    File system is Read-Only...

    BlueRevolution, thanks for your very prompt reply... tried and get a response to the chmod - chmod: LaunchDaemons: Read-only file system. Did an ls -l and LaunchDaemons is 757 and root wheel...

    same for the other.

    still stuck looping...

    Chet
     
  14. gjbrouhard macrumors newbie

    Joined:
    Feb 26, 2009
    #14
    Same TimeMachine problem

    I also suffer from the endless reboot loop.

    My problem also originates from changing the permissions on /System/Library/LaunchDaemons/.

    I changed them back in single-user mode with the commands posted above, but the problem did not resolve itself.

    Any ideas why? Where else could there be a permissions problem?

    I might do an Archive and Install if I can't get this fixed soon.:(
     
  15. chetvolpe macrumors newbie

    Joined:
    Jan 15, 2009
    #15
    Endless Boot Loop

    The Archive install is what I did to fix mine.

    Was very painless...

    Chet
     
  16. coupdetat macrumors 6502

    Joined:
    Jul 11, 2008
    #16
    My PowerBook did this also! I wound up going back to Tiger... Leopard was too slow on G4 anyways.
     
  17. DanielSosMac macrumors newbie

    Joined:
    Mar 3, 2011
    Location:
    Paris
    #17

    I've tried that booting as target mode. I cross fingers now...
     
  18. DanielSosMac macrumors newbie

    Joined:
    Mar 3, 2011
    Location:
    Paris
    #18
    MAAN you're a GENIUS.

    I booted in Target Mode and from the terminal accessed Volumes

    since Macintosh HD appears with spaces all I had to do to access it was backslash between the spaces

    cd Macintosh\ HD

    Then the chown and chmod things.

    Voilà the computer stopped rebooting!!!

    If you come by Paris I owe you a Pint
     

Share This Page