Leopard + Entourage 2004 + Exchange Server

Discussion in 'Mac Apps and Mac App Store' started by malenfant, Oct 26, 2007.

  1. malenfant macrumors member

    Joined:
    Dec 31, 2006
    #1
    Anyone else having this problem?:

    Leopard 10.5
    Entourage 2004 with all updates
    Exchange 2003 Server
    self-published certificate

    In Tiger 10.4, Entourage was able to connect to the Exchange Server without any problems. Since I upgraded to Leopard 10.5, Entourage now fails to connect with the error message "Unable to establish a secure connection to servername.com because the correct root certificate is not installed." I've tried removing and reinstalling the certificate, but the old X509Anchors keychain is gone and recreating it doesn't help.

    Any ideas? I don't especially want to spend hundreds of dollars buying a certificate from Verisign when there is nothing wrong with the self-published certificate I already have.

    EDIT: Forgot to mention: If I click OK, I can connect and send/receive mail, etc. I just want to know if there is a way to get rid of the stupid error message.
     
  2. ahintz macrumors member

    ahintz

    Joined:
    Mar 25, 2007
    #2
    I'm having the same problem. I've tried installing the cert to the Microsoft Intermediate Certificates keychain, and I have added it to the System and Login keychains. While Safari now trusts the site, I still get the error message from Entourage. Biggest problem is while I can get email, it is doing it over plain HTTP, not SSL-encrypted.

    Hopefully we'll have an update (either new procedures, or a patch) from Microsoft. Though I'm not holding my breath.

    Andrew
     
  3. jgma100 macrumors newbie

    Joined:
    Oct 30, 2007
    #3
    I'm having the same problem with Entourage 2004 and Microsoft Messenger into Corporate Account when I try to sign in with TLS protocol. Where are X509Anchors KeyChain in Leopard?
     
  4. jgma100 macrumors newbie

    Joined:
    Oct 30, 2007
    #4
    Resolved!

    I resolved my issue:

    1. Open Keychain Access Utility
    2. In FILE click ADD KEYCHAIN
    3. I look in System > Library > Keychains. Here I found X509Anchors Keychain.
    4. I have now X509Anchors keychain .
    5.I install my self-published certificate into X509Anchors Keychain and now Entourage and Messenger works fine.

    I hope this help you
     
  5. astromac macrumors newbie

    Joined:
    Oct 31, 2007
    #5
    I did import the X509Anchors for /System/Library/Keychains but it is locked and none of my passwords will unlock it. Any ideas?
     
  6. jgma100 macrumors newbie

    Joined:
    Oct 30, 2007
    #6
    My Leopard installation was a clean installation.

    Do you upgrade from Tiger?
     
  7. astromac macrumors newbie

    Joined:
    Oct 31, 2007
    #7
    Clean install. Also had the Leopard Keychain update applied.
     
  8. marlier macrumors newbie

    Joined:
    Nov 1, 2007
    #8
    Same issue as Astromac

    Same error message, same problem with the imported X509Anchors keychain being locked and unavailable with any of the passwords that I've ever used.

    I also did a clean install, using the "Move the prior system folder aside" option. I did choose to retain settings.

    I've tried the same things, without success, so far.

    Is there a way to "reset" the X509Anchors keychain -- to just create a new one? It seems like kind of a specialized sort of thing...
     
  9. CashGap macrumors 6502

    CashGap

    Joined:
    Sep 15, 2007
    Location:
    Music City, USA
    #9
    Can you elaborate on step 5? I have the self-published certificate from our Exchange admin, but I couldn't get this to work on Tiger and I'm eager to give it a shot on Leopard.

    THANKS
     
  10. nix.hanno macrumors newbie

    Joined:
    Nov 2, 2007
    Location:
    Oz
    #10
    Don't waste your time

    Hi,

    I specially joined this forum as I didn't want others to waste as much time as I have trying to resolve this issue. Unfortunately, connections to an Exchange server from Entourage via SSL is completely broken in Leopard until either Apple provide a fix or Microsoft provide a patch (or a 3rd party provides a hack)...

    I have spent many hours with many combinations and permutations of certificates/keychains, you name it - all unsuccessful.

    Note: I am talking here from the point of view of a CLEAN Leopard install. In most cases, an UPGRADE from a previous working installation of Mac OS X will not break a properly configured Entourage -> Exchange SSL connection.

    I have gone as far as using the 'security' tool and adding trusted certificates etc. (add-trusted-cert) to a myriad of keychains including the "System Roots" keychain which, in Leopard, one is not supposed to be able to add anything too but which is possible using this security tool!

    So, in short, don't bother unless you really think you can do it otherwise you'll just waste countless hours...

    Thanks Apple! Thanks Microsoft! You think you could get your act together being such large multi-national companies yet you still don't care to bother to test your products carefully! I mean really, broken SSL connections STILL! Bloody grow up!

    <Pissed off>
     
  11. gbsigz macrumors newbie

    Joined:
    Nov 8, 2007
    #13
    I´ve been using Thunderbird with the exhange server and cant connect to it now that I´ve installed Leopard. I also tried Mail but get the same errors as I got on Tiger so I want to stick with Thunderbird if I can get that going again.

    Has anybody been having trouble with Thunderbird?

    I get Error Code: -12263
     
  12. gbsigz macrumors newbie

    Joined:
    Nov 8, 2007
    #14
    If anybody has had this problem then I have a solution :)

    I just changed the server settings from SSL to TLS, if available and I´m able to access my inbox now.

    Hope this can help somebody.
     
  13. gbsigz macrumors newbie

    Joined:
    Nov 8, 2007
    #15
    Well, this fix I mentioned in my previous post worked fine last week. But when I came to work on monday I couldnt connect to my mail via Thunderbird or Mail. The funny thing is that I can send mail but not get mail. The TLS thing no longer works.

    Has anybody found something to fix this?
     
  14. Jermaineum macrumors newbie

    Joined:
    Nov 30, 2007
    #16
    I found that upgrading to Leopard will sometimes change your Administrator account to a Standard account. You have to boot from your 10.5 disk, select reset passwords from the Utilities dropdown and reset the root password on your hard disk. Once that is done you can boot back into your OS and fix your accounts or use your new root password to make the necessary changes.

    I am having real troubles with Entourage and my Exchange server at work. I'm in IT but am not a Mac user. Could anyone point me to some good documentation?
     

Share This Page