Leopard Finder 100% CPU usage

Discussion in 'macOS' started by smashingnick, Oct 26, 2007.

  1. smashingnick macrumors newbie

    Joined:
    Oct 26, 2007
    #1
    My finder seems to start randomly using 100% CPU for no reason. Finder still responds and there is no noticeable performance effect but it does make the fan in my Macbook go crazy. Even when I relaunch finder it still uses %100 CPU. Anyone else have this problem?
     
  2. mmendoza27 macrumors 6502

    Joined:
    Oct 18, 2007
    #2
    It could be that it might be indexing the files to use with Spotlight, I heard another user going through something similiar. Try bringing up Spotlight and check it out. That's really only when you first start up though, after the index, your CPU usage should go down.
     
  3. smashingnick thread starter macrumors newbie

    Joined:
    Oct 26, 2007
  4. edesignuk Moderator emeritus

    edesignuk

    Joined:
    Mar 25, 2002
    Location:
    London, England
    #4
    Open your Activity Monitor and see what process is causing it.
     
  5. smashingnick thread starter macrumors newbie

    Joined:
    Oct 26, 2007
    #5
    Like I said earlier...... it's Finder.
    I did as]n lsof | grep Finder to get a list of the open files that finder was accessing and noticed that the flip4mac wmv component was opened by finder and since that causes quicktime to hang i though that might be it so i moved the flip4mac component files and restarted finder but that didn't help either.
     
  6. yee379 macrumors newbie

    Joined:
    Feb 12, 2008
    #6
    Hi, i would like to just add a 'me too' to this thread. the finder cpu problem appears to be completely random. the only thing that i could imagine is causing a problem is that i have nfs automounts and afs installed.

    it's really quite annoying as it really kills the battery.
     
  7. tracetritt macrumors member

    Joined:
    Jun 10, 2007
    Location:
    Northwestern Wisconsin, USA
    #7
    Add me to the list as well. There is nothing that I have running that would be causing this. It's starting to get really annoying.
     
  8. madprog macrumors newbie

    Joined:
    Feb 15, 2008
    #8
    Hello, I'm concerned too by this problem.

    The Finder takes 100% of CPU but the system runs normally.
    What I've seen is that it calms down when some applications are hidden or minimized, like Firefox, iTunes, Mail, Preview, TeXShop, …
    Anyway, when these are shown back, the overrun restarts.

    I think the problem is from a module shared by all these applications by Finder.
    The Finder itself doesn't seem to use it, though I believe that it has something to do with display (as when the window is hidden the CPU calms down) and that I must have not found the correct file type to show in Finder, or something like that…

    madprog
     
  9. madprog macrumors newbie

    Joined:
    Feb 15, 2008
  10. guiohm macrumors newbie

    Joined:
    Feb 15, 2008
    #10
    Hello,

    I have the same problem of 100% CPU rate. I've done the "Leopard graphic Update 1.0" but it's still the same.

    I think the first time I got the problem was when Parallels mounted an image of the guest OS (win XP).
    Since then, Finder is constantly at 100% so I have to quit it to get the macbook pro fans quiet.
    That's very annoying...
    If someone have an Idea...:confused:
     
  11. guiohm macrumors newbie

    Joined:
    Feb 15, 2008
    #11
    In fact I've just found that it's a graphical problem.

    When a window like Safari or Firefox or iTunes is open and the surface of this window is greater than 1600*600 (approximately) or 600*1600 (so it's a surface problem;)), Finder goes to 100%; and I see when I sample it that this is essantially due to "RIPLayerSymmetricConvolve". One of his parent is "HIThemeDrawTextBox", and another is "HIView...", and all this run in "RunApplicationEventLoop".

    Well I don't have the knowledge to interprete this, but I assume that Finder is looping a graphical object and can't "get out of this"...
     
  12. guiohm macrumors newbie

    Joined:
    Feb 15, 2008
    #12
    If someone is interested, here is an extract of the sample of Finder :
    One when a window is greater than 1600*600 (100%CPU).
    And another when the windows are less than 1600*600 (5 to 8% CPU).
     

    Attached Files:

  13. cyantist macrumors newbie

    Joined:
    Sep 11, 2007
    Location:
    Canada
    #13
    For some reason I remember having this issue a while back, and the solution was this: right-click on the desktop > show view options > deselect show item info. It worked for me, but it wasn't Finder that was giving me 100% cpu, it was Safari or Camino.

    Give it a try.
     
  14. guiohm macrumors newbie

    Joined:
    Feb 15, 2008
    #14
    And by the way, I can add that this only happen when any visible portion of a window is bigger than aproximately 1600*600 and is located on the screen with menubar and dock.
    I have two screens and it don't happen on the other. If I put menubar and dock on the other screen, the problem follow the menubar...

    Since I work all the time with windows in full screen (1680*1050): I'm still searching for a solution...
    My CPU temperature is around 80°C/176°F and the fans of my macbook pro are very noisy at full speed...:(
     
  15. guiohm macrumors newbie

    Joined:
    Feb 15, 2008
    #15
    Well, Cyantist, Thanks!

    your trick worked!

    All this is very strange but the problem is solved. I could have search for a while before finding this! :)
     
  16. yee379 macrumors newbie

    Joined:
    Feb 12, 2008
    #16
    I have no such issues with large windows.

    i noticed that the finder was taking up a large chunk of the cpu, and i decided to try to disable afs. i found a prefpane called afscommander and stopped afs. low and behold, the finder's cpu dropped back to normal levels.

    i'm using the devel branch (1.5) - but it did appear to perform better (ie not affect finder as such) as the stable 1.4 branch.
     
  17. kwfl macrumors 6502

    Joined:
    Aug 20, 2007
  18. mayoko185 macrumors member

    Joined:
    Jun 15, 2007
    #18
    Im also getting this on my MBP its a very weird bug
     
  19. Vaca macrumors newbie

    Joined:
    Mar 3, 2008
    #19
    Thank you very much cyantist. It works. I had the same problem with finder and I tried this fix and just I deselected the checkbox the finder slowed down on pleasant 0,2% of usage :) ... I hope there will be some update as soon as possible...
     
  20. Lord Sam macrumors regular

    Lord Sam

    #20
    Wow. That's not too good. Why don't you turn them off using Terminal? I belive the command is No >/dev/null but i'm not sure. To turn your processor/s to full speed is Yes > /dev/null but I don't know how to undo it.

    Wait, scrap that. That is for an independent, terminal-run process. So don't do that... last resort, take it into your local Apple Store.
     
  21. yee379 macrumors newbie

    Joined:
    Feb 12, 2008
    #21
    This actually works! thanks! :)
     
  22. PeaceOut macrumors member

    Joined:
    May 17, 2008
    #22
    I was having this problem too.
    All of a sudden after upgrading to 4gig of ram, Finder was taking 100% cpu power while I was using iCal, Lightroom, Photoshop, etc. The strange thing was that it was normal if I was using firefox, safari, or pathfinder.

    I took the advice of unchecking the show item info and that seemed to fix it but I really like knowing the extra info. So I checked "show item info" and restarted the computer. Then when the problem was still there, I went hunting for a solution to the problem and finally found someone suggesting that it could be a corrupt file on my desktop. After looking, I decided to ejected the CD that was in my macbook pro and poof the problem is now gone.

    Funny thing is that the CD that was in the drive was a Windows XP SP2 cd that i was using to install some extras on my bootcamp partition. I guess finder really hates windows...haha :rolleyes:

    Just thought I'd share since this resolved my problem.
     
  23. crucesignati macrumors newbie

    crucesignati

    Joined:
    Sep 11, 2008
    #23
    That Worked!

    Thank you, Cyantist! Turning off "show view options" fixed it.

    This was heating up my new MBP and killing the battery life too.

    You're a genius!

    crucesignati
     
  24. pyramind macrumors newbie

    Joined:
    Dec 16, 2008
    #24
    In my case, this was caused by a corrupt file on desktop. I deleted it (it was locked) and problem was solved.
     
  25. FareThoughts macrumors newbie

    FareThoughts

    Joined:
    Jan 16, 2009
    #25
    Same here

    For me, both Show item info and a Firefox window maximized (I'm on a MBP, so widescreen here) was causing this, separately and in combo.

    I read in MacOSXHints about the same problem in 10.3; they suggested deleting the following from your User->Library->Preferences folder: com.apple.finder.plist, com.apple.systemuiserver.plist, com.apple.loginwindow.plist. I did that and restarted. (I suggest leaving these files in your Trash until you're sure you haven't done something bad, but since they're just preferences files you should be safe.) From what I am reading, these files can become corrupt and/or bloated over time. You will have to reset a few of your Finder preferences if you've modified them, but that took all of 5 seconds for me.

    Right now I have my Firefox window maximized and item info showing. The Finder is hovering around 0.3 percent, and my fans aren't about to send my laptop into orbit. All of my temps are dropping, and so is my blood pressure.

    I have no idea if this solution will last, but it's working fine so far.
     

Share This Page