Leopard Firewall continuously prompts for iPhoto permission

Discussion in 'macOS' started by m021478, Mar 3, 2008.

  1. m021478 macrumors 6502

    Joined:
    Nov 23, 2007
    #1
    Can someone help me figure out why every time I launch iPhoto, the Leopard firewall prompts me to choose whether or not I want to allow or deny access for this application to accept incoming network connections...regardless of the fact that every single time, I choose 'Allow'? Here's a screenshot of the exact prompt that appears:

    [​IMG]

    I've checked the Leopard firewall configuration in the 'Security' preference pane (which is obviously configured to "Set Access for Specific Services and Applications", and sure enough, iPhoto appears in the list with the 'Allow Incoming Connections' setting chosen....but it still asks me every time if I want to allow or deny connections, and I can't figure out how to make it stop asking??

    Any suggestions would be greatly appreciated... Thanks!
     
  2. slicedbread macrumors regular

    Joined:
    Nov 5, 2006
    #2
    I would like to know this as well.

    I've had this issue since 10.5.0 and none of the subsequent updates have fixed it. Searched on here and the apple support forums, and the most I can tell is that it is a bug that still hasn't been fixed yet.
     
  3. m021478 thread starter macrumors 6502

    Joined:
    Nov 23, 2007
    #3
    This is how I solve the problem:

    1) Quit iPhoto
    2) Open System Preferences and remove iPhoto from the list of allowed apps
    3) Relaunch iPhoto and click "Allow"

    This worked for me...
     
  4. slicedbread macrumors regular

    Joined:
    Nov 5, 2006
    #4
    I have tried that, but every time I reboot the firewall asking pop up appears again. Did it work for you even after restarting the computer?
     

Share This Page