Leopard: Freezed at screensaver, now won't boot

Discussion in 'macOS' started by Alexstre, Jan 6, 2008.

  1. Alexstre macrumors newbie

    Joined:
    Jan 6, 2008
    #1
    Hello!

    Well the title pretty much explains my problem. I woke up last night to get some water and I thought I'd check my emails while I'm up so I moved the mouse to turn the screensaver off but it frozen before going back to the desktop. I then hold the power button to force a reboot, everything went fine.. back to the desktop, checked my mails and went back to bed.

    This morning I wake up, screensaver is on. Move the mouse, screensaver freezes again. I reboot thinking that I should probably disable the screensaver until I find a solution... problem is: my iMac won't reboot. It freezes at the apple logo with the rotating loading thingy. At first I thought it was an update.. but it's been like this for over an hour now. I tried rebooting it, but it freezes on the same screen.

    Then I tried inserting my leopard cd in, hold C (also tried holding alt) and try to fix permissions or something.. but it seems impossible to boot from the CD (or even see the menu to chose where to boot from), it goes straight to the apple logo with the rotating loading icon.

    Any ideas what to do? I'm completely lost..
    Thanks!

    Edit: I thought it could help to list a few things I recently did:
    - Installed Parallel and used it with my boot camp partition
    - Replaced my keyboard by one of the new apple keyboard (the ones that come with the new aluminum imac)

    Edit 2:
    I tried my old keyboard and the alt key worked so I was able to boot on the leopard CD to run disk utility, which told me my hard drive is dead. (S.M.A.R.T: failed) but for some reason installing leopard is working... (not finished yet... but about 20% done)
     
  2. kindian macrumors newbie

    Joined:
    Jan 23, 2008
    #2
    Hello Alexstre.

    Last night I had exactly the same problem as you. My Screensaver frozen, I reboot the macmini and then it freezes at the apple logo. I reboot again and then I went to bed thinking that maybe mac was trying to fix some errors in the disk. Tomorrow morning I realised that the macmini was really freezed...

    The only thing I did yesterday was changing permissions of the Master disk for everyone (can't read or write) and his name...

    Did you have any luck?

    I have the instalation of the Leopard in an external hdd... How can I install it? The last time I did it I was able to choose in System Preferences what drive I wanted to boot from...
     
  3. samh004 macrumors 68020

    samh004

    Joined:
    Mar 1, 2004
    Location:
    Australia
    #3
    What computer is this on... I know the MB shipped with some faulty drives.
     
  4. kindian macrumors newbie

    Joined:
    Jan 23, 2008
    #4
    Mine is a mac mini 1.66, core duo.
     
  5. iCeFuSiOn macrumors 6502a

    Joined:
    Jul 18, 2007
    #5
    kindian: To install Leopard to that external drive, make sure you have the drive plugged in and the Leopard DVD in your optical drive and then restart your computer and hold down the C key to boot from disc. Go through the installer, and eventually it will come to the point where you need to select which disk to install on, just click on your external hard drive.

    If you've already got Leopard installed on the external disk and you're trying to boot from it, plug the drive in and then go to System Preferences > Startup Disk to select which volume you'd like to boot on.

    Alexstre: Have you run Apple Hardware Diagnostics on your iMac? You should be able to find this on your iMac DVD that came with the computer. I'd recommend running this test to check all the components of the computer for any faults.
     
  6. kindian macrumors newbie

    Joined:
    Jan 23, 2008
    #6
    Thanks ;)

    Tonight I will try to boot in "safe user mode" (mac version) and run FSCK to check if it's a disk problem.
     
  7. kindian macrumors newbie

    Joined:
    Jan 23, 2008
    #7
    Problem solved! :D
    I started the system in verbose mode and I found that the disk was trying to access a file that didn't exists.
    Then, in safe user mode and realized that the file was there but that the permissions of / was wrong. Simple: "chmod 775 /". Ctrl-D and everything was fine again. :D
     

Share This Page