Leopard, G5 iMac & AirPort

Discussion in 'macOS' started by clearly, Oct 29, 2007.

  1. clearly macrumors newbie

    Joined:
    Jan 23, 2004
    Location:
    Lancashire, England
    #1
    I have a big problem here and I'd love some help please!

    I've installed Leopard on both my Intel iMac and G5 iMac. Initially no problems. Today, using Software Update, I've installed Remote Desktop Client 3.2.1 and Login & Keychain Update 1.0 on the G5. After the restart the G5 is now failing to recognise my AirPort Card so I've lost my network connection.

    So:
    • Anyone else seen this problem?
    • Is it limited to G5 or will I see the same problem if I update the Intel iMac?
    • How the heck do I get the G5 to recognise my AirPort card again? (I desperately need to get my network connection back.)

    Thanks in advance

    :confused:Clearly:mad:
     
  2. carman63 macrumors regular

    Joined:
    Oct 27, 2006
    #2
    There's a thread on this a few pages down. There's a file you have to delete, airport2.kext.

    "check if the AppleAirPort2.kext is still present in your /System/Library/Extensions folder? It is an older Tiger-only AirPort driver that is no longer used on Leopard. You can simply delete it, or move it aside by changing the extension to something besides .kext. See if that fixes your problem."

    From this article:
    http://discussions.apple.com/thread.jspa?threadID=1200860&tstart=0

    FWIW it happened to me (and the fix worked) on my 24" Intel iMac. Did not happen on my Intel MacBook.
     
  3. clearly thread starter macrumors newbie

    Joined:
    Jan 23, 2004
    Location:
    Lancashire, England
    #3
    I am very grateful for your help. This has solved the problem. I've now updated the Intel iMac and didn't encounter the same problem.

    I must say that I'm a little upset that Apple could have overlooked something like this. Are there other little problems like this lurking round the corner?

    Anyway, other than this, I'm impressed so far with Leopard.

    Thanks

    Clearly
     

Share This Page