Leopard install problems powerbook 12"

Discussion in 'PowerPC Macs' started by indierthanthou, Jan 15, 2008.

  1. indierthanthou macrumors member

    Nov 14, 2007
    I have a Powerbook g4 [12", 1.33ghz, 512mb of ram, 60gb hdd] that I am trying to install Leopard on. When I insert the disc, it will spin, sound like it's reading the disc, then eject it. After about 3 tries, it will read the dvd. When the installer restarts the computer, I get the folder with the "?" in the center, then it ejects the dvd and boots normally.

    Is there a problem with my copy of Leopard, or my hardware?

    When I put the disc into my main power mac [733mhz g4, 640mb ram, 60+40gb hdds] it reads it fine, I don't install it because when I was given this computer, my friend tried to put leopard on it when he reformatted it, and it wouldn't run so he put tiger on.
  2. gkarris macrumors 604


    Dec 31, 2004
    "No escape from Reality..."
    Does another DVD/CD work fine?

    Your drive may be bad...
  3. Shaduu macrumors 6502a


    Jan 31, 2007
  4. indierthanthou thread starter macrumors member

    Nov 14, 2007
    I was thinking bad drive too, but it read a cd-r fine, a dvd-r, and a regular video dvd.

    could it be a bad leopard dvd?
  5. indierthanthou thread starter macrumors member

    Nov 14, 2007

    When i started it up today, I got the ? folder icon for a second, then it went through the semi normal boot sequence. it seems alot slower on boot though.
  6. indierthanthou thread starter macrumors member

    Nov 14, 2007
    Can anyone help me on this? I am getting worried, I don't want to have to replace my computer! I can't afford $2000 for a MBP, and I like the powerbook!
  7. castlefrank macrumors newbie

    May 8, 2008
  8. tonybeyondo macrumors member

    Oct 11, 2007
  9. castlefrank macrumors newbie

    May 8, 2008
    Thanks for the link. The tutorial will definitely come in handy later tonight.

    I'm still curious whether anyone has solved the problem with the SuperDrive itself, maybe via a firmware update. (The Leopard Install DVD can't be the only one affected by this problem, and I'd like to have the drive working 100%.)
  10. dacreativeguy macrumors 68020

    Jan 27, 2007
    This is a common problem. Check your system profiler and see if you have a Matshita drive. A lot of that model drive cannot read the Leopard DVD. I think it is a combination of Apple using cheaper media and a problem with this drive manufacturer. Some people have had luck turning the computer upside down to help the DVD be recognized (search the MacOS forums). I just used another machine to clone the DVD to a hard drive. Installations are much quicker from hard disk anyways compared to the slow, cheap DVD drives Apple is putting in the latest MBPs. ;(
  11. castlefrank macrumors newbie

    May 8, 2008
    Hmm, thanks for the response. Good to know that at least the problem is common.

    Last night I did a successful Leopard install using my desktop as a Target Drive, so now I'm pretty happy overall.
  12. dcjr321 macrumors newbie

    May 8, 2008
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU like Mac OS X; en) AppleWebKit/420.1 (KHTML, like Gecko) Version/3.0 Mobile/4A102 Safari/419.3)

    Had the same problem a couple of months ago with my friends PowerBook 12inch. Replaced the SuperDrive now everything is as good as new.
  13. gd11be macrumors newbie

    Jun 2, 2008
    I used this one ! I had the same problem on my ibook G4, but when I put the DVD in my imac and then my imac in Target mode . yes ! It worked ! Excellent ! :D:D

Share This Page