Leopard install says I need to repartition my drive??! Won't install!

Discussion in 'macOS' started by kevinwiz, Oct 26, 2007.

  1. kevinwiz macrumors regular

    Joined:
    Feb 1, 2007
    Location:
    socal
    #1
    this is very frustrating and i'm hoping someone has a solution. erasing the drive is not an option, i don't want to deal with backups. i already tried verify and repair disk and it said it was fine.

    i'm on a macbook core duo 120gb hd 1.25 ram if that matters. oh and also i upgraded my HD about a month ago from an old 60gb. it went fine and everything works, never had any problems.
     

    Attached Files:

  2. clevin macrumors G3

    clevin

    Joined:
    Aug 6, 2006
    #2
    there is never a unix based system that do good in upgrading, most people choose clean installation

    did you try to call applecare?
     
  3. Peace macrumors P6

    Peace

    Joined:
    Apr 1, 2005
    Location:
    Space--The ONLY Frontier
  4. kevinwiz thread starter macrumors regular

    Joined:
    Feb 1, 2007
    Location:
    socal
    #4
    i never had windows installed and applecare is closed until 3PST (right now) i'll call now.
     
  5. mullet macrumors regular

    Joined:
    Dec 8, 2003
    Location:
    B'klyn
    #5
    I ran into this same problem. It turns out that your hard drive partition map has to be set up as GUID Partition Table. This is the default for Intel based Macs. PPC based Macs use Apple Partition Map. Furthermore, when you format a drive it defaults to Apple Partition Map. The only way to install Leopard on your machine is to go into Disk Utility and reformat your drive via the Partition tab. Go to Options on the bottom and select GUID Partition Table. If you only want one partition don't do any resizing. If you want several partitions then split up the drive and hit the Partition button when you're ready.

    Good Luck,
    Mullet
     
  6. rogersmj macrumors 68020

    rogersmj

    Joined:
    Sep 10, 2006
    Location:
    Indianapolis, IN
    #6
    I just ran into this on our MacBook...crap, does this mean I can't just do an upgrade and preserve all my stuff? There's no way around this other than reformatting the dang drive??
     
  7. kevinwiz thread starter macrumors regular

    Joined:
    Feb 1, 2007
    Location:
    socal
    #7
    thanks. i'm on the phone with applecare right now. if they don't offer me a better solution i'll do this. i assume this will erase my hard drive? how would i go about getting my backups on leopard?
     
  8. janstett macrumors 65816

    Joined:
    Jan 13, 2006
    Location:
    Chester, NJ
    #8
    I have the same problem on my Macbook Pro. I just replaced my 100 gig drive with a 200 gig drive, copied via Carbon Copy cloner about 3 weeks ago.

    I really do not want to do a clean install; if they can't come up with a workaround I'll wait with Leopard until I get around to needing a clean install.

    It must be a carbon copy cloner thing, or they just made this partition requirement between Tiger and Leopard -- I've reformatted my original 100 gig drive 2 or 3 times with Tiger, no PPC macs involved. I guess since I formatted the drive while booted from the original, it got saddled with the Apple partition and CarbonCopy didn't adjust it?
     
  9. rogersmj macrumors 68020

    rogersmj

    Joined:
    Sep 10, 2006
    Location:
    Indianapolis, IN
    #9
    Well I backed up all my wife's stuff on the MacBook to the server so I could just go ahead and wipe it, since I don't see any way around this problem. After booting to the Leopard DVD, I opened Disk Utility and tried to remove one of the extra partitions I had on there back from when I was dual-booting with Linux. I wanted to just make it all one partition for my wife. Well, now Disk Utility is frozen at "Preparing to remove volume". It's been stuck like that for nearly a half-hour, but when I try to quit Disk Utility it warns me that it's in the middle of an operation and it is dangerous to quit. Any ideas?

    P.S. Disk Utility indicated that the partition table was already GUID but it still wouldn't let me upgrade.
     
  10. kevinwiz thread starter macrumors regular

    Joined:
    Feb 1, 2007
    Location:
    socal
    #10
    i feel like one of you geniuses who post on here. i fixed it myself, i'm pretty proud of that lol. i'm on leopard now.
     
  11. janstett macrumors 65816

    Joined:
    Jan 13, 2006
    Location:
    Chester, NJ
    #11
    Care to share the secret?

    By the way I booted from an my original drive (usb) and it worked so its a disk clone issue.
     
  12. xJulianx macrumors 6502a

    xJulianx

    Joined:
    Oct 1, 2006
    Location:
    Brighton, UK
    #12
    I've got this same problem aswell, a clean install isn't an option as I have 120GB of data and only an 80GB backup drive.
     
  13. brbubba macrumors 6502

    brbubba

    Joined:
    May 20, 2006
    #13
    No joke. What a jerkface to brag about fixing it and then not let us in on the secret.
     
  14. hughjaas macrumors newbie

    Joined:
    Jun 29, 2007
    Location:
    San Diego
    #14
    Leopard install GUID partition workaround

    I figured out the 'secret' to bypass the GUID partition requirement:

    when you get to the screen that has the red exclamation point and all the other options grayed out, just double click on your hard drive icon and you can choose 'archive and install'.


    Update: nevermind, this doesn't get all the way through. after further research, there is no way to change the partition scheme without repartitioning/reformatting. I ended up logging in as 'root', copying my user folder to another drive and then wiped it clean with a repartition.
     
  15. budge9 macrumors member

    Joined:
    Sep 14, 2007
    #15
    Will this stop me having to have my HD wiped? Or is there any other way to avoid it?? Thanks!
     
  16. bigandy macrumors G3

    bigandy

    Joined:
    Apr 30, 2004
    Location:
    Murka
    #16
    This happens because files are in the way of the partition you're trying to create.

    Leopard's Disk Utility obviously still can't move files when resizing partitions :(


    Here's the solution. It works very well, moves all your files and then offers up the new partition.

    Remember to back up before you do anything though, as usual with disk modifying stuff. ;)
     
  17. Lollypop macrumors 6502a

    Lollypop

    Joined:
    Sep 13, 2004
    Location:
    Johannesburg, South Africa
    #17
    im thinking of taking this route, can I use the migration utility after the clean install to then copy over my settings and things?
     
  18. hughjaas macrumors newbie

    Joined:
    Jun 29, 2007
    Location:
    San Diego
    #18
    I tried using the migration utility but it wouldn't let me select anything other than another volume on another computer or a computer in firewire target disk mode- it wouldn't let me select an external disk.

    if you had another mac with enough room you could migrate your files to that one and then migrate back after the install. that might take longer than re-installing your apps though. re-insalling wasn't that bad and I freed up almost 30GB by not installing junk I've accumulated over the years. Plus it's nice and defragmented now so it seems faster.
     
  19. brbubba macrumors 6502

    brbubba

    Joined:
    May 20, 2006
    #19
    I just had to buy an external drive, back up everything, reformat, reinstall, and then use the migration utility. The migration utility, however, is extremely slow. It took 30+ hours for 100GB of data!!!
     
  20. cawesjmu macrumors 6502

    Joined:
    Apr 4, 2004
    Location:
    Richmond, VA
    #20
    Similar problem. I have a MBP and tried to install leopard yesterday. When I was asked to select the drive, it gave me a yellow warning instead of the red exclamation mark, but still wouldn't let me install there. It said I had to reformat. I chalked it up to having Ubuntu installed on a partition (along with the other partitions created to enable it. ie. Linux swap disk ect). I was scanning these forums to see if anyone else had this problem when I ran across this thread, but it doesn't look like anyone has a solution to fix this without erasing.

    As a side note, I did go ahead and erase and install, which I thought was going to destroy the Ubuntu partitions and give me one big drive again, but this was not the case. It left everything else untouched and just erased my OS X side. Interested to see if anyone has found a solution yet.
     
  21. lounger540 macrumors newbie

    Joined:
    Dec 26, 2007
    #21
    I've come up with a bit of a solution with this.
    First the problem, to see if yours is the same.

    DiskUtility reports the partition type as MBR, even though you're on an Intel mac and you know you are using GUID.
    or
    DiskUtility says you're using GUID, and everything looks ok, yet you get the yellow ! in the leopard installer saying the system can't boot to the drive, and you've used some sort of odd Boot Camp setup in the past.

    This problem is caused for a few reasons I've come to learn. It's hard for me to tell exactly what the circumstances where as I've just spent the better part of the day and about 100 reboots fixing it. But I did get Leopard to install without destroying any data. My problem was either caused from upgrading to a larger disk using CarbonCopyCloner, or that I was triple booting at one point from this drive. Doesn't matter, it's mostly a matter of getting your MBR and GPT to match, while being Leopard OK. If you'll notice, you're Boot Camp installer probably won't run any more either. At least that was the case for me.

    See http://www.macgeekery.com/tips/troubleshooting/when_the_boot_camp_assistant_fails for info on where I got some of my steps from. Also http://0xfeedbeef.com/appletv/usbboot and http://developer.apple.com/technotes/tn2006/tn2166.html#SECPARTITIONTYPES helped.

    Warning, this requires using the terminal, messing with partition data, and other black magic. Don't do this if you don't know what these commands actually do. Also, this is an estimate of the steps, your results may vary.

    1) Use something like DasBoot to make a small boot able OS X disk. You may want to throw on a partitioning software, I recommend Drive Genius 1.5.3 or above. The others tend to bastardize the MBR and make this tough. Supposedly iPartition 3 will handle all this as well.

    2) Use partitioning software to delete your non OS X partitions. You may be able to do it with out this, but it's not how I did it and some of the future steps will probably make Windows unbootable any way. If you can't or don't want to buy partitioning software, you can use gparted on linux. We only need an accurate GPT as the MBR will be fixed later.

    3) Resize your boot volume to fill the disk. (Again, may not be required, but I did it) You can use diskUtil resizeVolume from the terminal or software from step 2

    4) delete the MBR. From the recovery disk in terminal run
    optional: backup your mbr using DD ie;
    dd if=/dev/disk# of=/Volumes/backupdisk/mbrbackup bs=512 count=1

    mandatory:
    umount /Volumes/[Any volume on the disk we're installing to]
    fdisk -e /dev/rdisk#
    then the commands
    p (save this output incase you need to recover your mbr)
    erase
    edit 1
    Enter EE for partition type
    enter nothing for the question about interactive something or other (this is from memory if you couldn;t tell)
    enter 1 for starting block
    enter nothing for size, it will fill the disk
    enter p to preview, should have 1 partition of EE type filling the whole disk
    enter w to save
    enter q to quit

    if you didn't umount all the volumes it will say you need to reboot to save changes, so do that and come back to the external boot.

    5)
    This is where things change a lot. We're going to change the GPT. This is the other side of the Apple dual format partition scheme. When we deleted the MBR we basically told the computer to use the GPT instead. See the linked apple.com disuccion i linked to before for official explenation.

    Another pain in the butt is after every gpt command the machine remounts the partitons. Keep disk utility open to unmount it each time (But don't eject)

    So first let's take a look at the gpt
    gpt show disk#
    SAVE THIS OUTPUT!! If something goes wrong, you can re-enter these values and your partitions should work fine, as long as you don't modify partitions here after.
    Now, on my machine I had 1 HFS partition and an empty 200.00mb block where the EFI partition should have been. And fdisk even had reported the partition as being there. So, if this is the case for you, you need to format that space as fat32 using a partitiioning tool, and then delete it. You may need to reclear the MBR again like above. The reason is, the EFI partition is really a FAT32 partition under a different name. You may be able to skip this step if you haven't messed around and moved your partitions around too much. Honestly, OS X never really uses the EFI partition, but Leopard won't install with out it in tact.

    I've typed a lot now. So basically, you want your partition table to look like this.
    XXXXX will be your partition size in bytes, but you know this because I told you to save that info before, right.
    C12A.... is the GUID code for EFI protected partition. This partition must be exactly as above. Start at block 40 and be 200.00MB in size. Note, you can't just write these numbers in and expect it to work. When you formatted the 200MB fat32 block above, for those of you that needed to bcs you wiped it in the past, it should have started on the same block and ended at 409600. This is why moving partitions in Linux using gparted is helpful bcs you can narrow down the block sizes exactly.
    4846.... is the GUID code for HFS+Journaled partitions. Could have more than one I assume.
    Also note, the 1st part is type PMBR. It will say MBR is there's an issue with your MBR and will likely not work. You can erase the MBR like above, or you can use DD from the terminal to copy the first 512bytes from a good drive to yours. I did this originally and it did no harm. That would look something like:
    dd if=/dev/gooddrive of=/tempfile bs=512 count=1
    dd if=/tempfile of=/dev/installing_Drive bs=512 count=1

    Now, your partitoins should actually be like this sort of. If you're one of the people like above who didn't ahve the EFI partition, then you main partition will be Index 1. This won't work. What you have to do is delete both entries, and then re-enter them in order. All the values should be the same, but the indexes swapped.

    For an overview of how to do this, see the link to macgeekery.com I pasted at the top. BAsically you just use the delete commands, then the add, and past in the right value for your sizes. Note the EFI partition is 409600 in size. macgeekery has a different value for theirs bcs they were doing something different.
    This is why I had you move partitions around before, because if they line up nice now, you can check against my list.

    Ok, you should be able to reboot into your normal system just fine. If you can't check your MBR again so that it's one large EE partition, you may need to blees your boot volume too like to
    bless --device /dev/disk# --folder /Volumes/your hd/System/Library/CoreServices/ --setBoot

    If that doesn't work, try holding down the alt key on boot. If all these don't work, sorry. I hope you backed up your GPT info. Try restoring it and call it quits.

    Once your system is booted, you can't install leopard still, but you can run boot camp install again. at least that was my case. you need to roll your clock back to before sept 30, 2007 for it to run. I set my disk up with a 5gb win partition and rebooted. I immediataly ran the Leopard installer and it went just fine as an upgrade install.

    Once running, fix permissions on Leo. Better yet, repair disk using the Leo DVD (I had some ACL issues) and get a back up disk already. ALso, you can use boot camp assistant to remove the Windows partition we made to get leo to install now.
    ----
    I typed this all in one shot. I didn't proofread or bother to fix type-os. I didn't really explain what the hell is going on. Your conditions may vary. Use your brain, I did. I've never modified my GPT by hand before and I figured it out while sweating if I'd lose all my data. Real men don't backup, but you should.
     
  22. Blogger macrumors 6502

    Joined:
    Jul 18, 2002
    Location:
    Local
    #22
    This is just complete nonsense, as, upon reflection, the lingual skills of the poster suggests.
     

Share This Page