Leopard installed(clean) Macally Icekey won't work and neither does Winswitch...Help

Discussion in 'macOS' started by zagato27, Dec 28, 2007.

  1. zagato27 macrumors 65816

    zagato27

    Joined:
    Aug 10, 2003
    Location:
    The Hill
    #1
    I just bought a new hard drive (Seagate 320 SATA) for my G5. Installed Leopard (clean install) and now the following keys don't work on my Macally IceKey keyboard: eject; sound up; sound down; and mute. I also tried to install Winswitch and can't get it going. Can anyone help me? Thanks
     
  2. zagato27 thread starter macrumors 65816

    zagato27

    Joined:
    Aug 10, 2003
    Location:
    The Hill
    #2
    I'm bad...Winswitch hasn't been updated for Leopard yet. I hope it's soon. Still the Macally Icekey keyboard is rather annoying.
     
  3. zagato27 thread starter macrumors 65816

    zagato27

    Joined:
    Aug 10, 2003
    Location:
    The Hill
    #3
    Keyboard issue solved! Just bought a new Apple keyboard. Now if only Winswitch was updated. I'll have to keep checking on that one. Kind of hate to quit the IceKey from MaCally. It really was a nice keyboard but this new one isn't bad. Cheers
     
  4. NateP macrumors member

    Joined:
    Sep 20, 2005
    #4
    Any suggestions for those of us that don't want to buy new keyboards? Anybody?

    Thanks.
     
  5. sowana macrumors newbie

    Joined:
    May 18, 2008
    #5
    Universal driver fix

    I just found a fix for this problem, on another site (http://discussions.apple.com/messageview.jspa?messageID=7224925&stqc=true), and now my kb's volume and eject keys are functioning.

    Basically, you need to go back to an earlier driver (according to the site, May 2006). Uninstall your current driver and install this universal driver:

    http://www.macally.com/techsupport/drivers/MacallyICEK.dmg.zip

    Cheers all,

    Sowana

    (BTW, I'm on a Mini 1.83 GHz Intel Core 2 Duo running Leopard (10.5.2))
     
  6. zagato27 thread starter macrumors 65816

    zagato27

    Joined:
    Aug 10, 2003
    Location:
    The Hill
    #6
    Ok, willing to try. Where might my old macally icekey driver be "hiding" so I can delete it?
     
  7. zagato27 thread starter macrumors 65816

    zagato27

    Joined:
    Aug 10, 2003
    Location:
    The Hill
    #7
    Dug out my icekey and installed the "old" driver. Seems to be working.....AHHHHHHHHHHHHHHHHHHH:D:D:D:D:D

    sowana, thanks so much for sharing the fix! Cheers
     
  8. sowana macrumors newbie

    Joined:
    May 18, 2008
    #8
    Hooray!

    Yay, it worked! And yay internets! And yay problemsolving! :D
     

Share This Page