Leopard Internet Sharing Connects but no internet

Discussion in 'macOS' started by luftwaffles08, Nov 5, 2007.

  1. luftwaffles08 macrumors newbie

    Joined:
    Jul 7, 2007
    #1
    Tried to make that title as sensical as possible.

    I recently did a clean install of leopard and then migrated my account back on to my MBP non-santa rosa 2.33. Now, when I attempt to internet share from my ethernet to computers using airport, they are able to see the network, connect to it, and put in the password, but internet fails to connect. I'm on a college network, but this shouldn't really matter since I currently have a network of this type working perfectly on an iMac running Tiger. The signal reads at full strength and behaves just like it should, just it doesn't allow an internet connection.

    No firewall is on. Anybody have any idea why this is happening?
     
  2. nagromme macrumors G5

    nagromme

    Joined:
    May 2, 2002
    #2
    If you want web browsing, then the computer hosting the connection must have Personal Web Sharing enabled, as well as Internet Sharing.
     
  3. luftwaffles08 thread starter macrumors newbie

    Joined:
    Jul 7, 2007
    #3
    I just tried that with no such luck. It is still not even recognizing that there's a full internet connection. And with Web Sharing, wouldn't that only allow for websites that exist in my Sites folder and not the internet in general? Basically I'm just trying to turn my MBP into a wireless router which I was able to do easily under Tiger.
     
  4. luftwaffles08 thread starter macrumors newbie

    Joined:
    Jul 7, 2007
    #4
    If Personal Web Sharing is the solution, could anyone tell me how to make it so that all people connected could surf the internet as usual? A google search just left me with more questions.
     
  5. luftwaffles08 thread starter macrumors newbie

    Joined:
    Jul 7, 2007
    #5
    Update:

    It kind of works now that I have File Sharing, Web Sharing, Remote Login, Internet Sharing, and Bluetooth Sharing all on at the same time. It is running significantly slower than the Tiger Internet Sharing I set up, making me think in reality it's just tunneling using SSH. It is slower than dial-up which really makes no sense. If anyone could give me some insight as to why this is happening, please let me know.
     
  6. luftwaffles08 thread starter macrumors newbie

    Joined:
    Jul 7, 2007
    #6
    I know this is a dead thread, but problem never was solved. A macbook running 10.5.1, a wii, and an Xbox 360 running with a wireless adapter cannot resolve the correct IP or DNS. Even when I tricked the IP into working on the 360, the DNS failed even when the correct one was put in.

    Both work 100% perfectly with internet sharing under Tiger.

    If anybody has any sort of solution, Please help.


    I'm running 10.5.1 and I was hoping that would solve it but never did. If anyone is actually interested, I'll set you the details of all the issues.
     
  7. ahand macrumors member

    Joined:
    Jul 21, 2007
    #7
    hey,
    sorry to hijack your thread PLUS be of no help to you, i noticed you said, "put in password" when you share your ethernet through your airport. i've been trying to do this but i don't know how. could you explain? thank you. (leopard fyi)
     
  8. luftwaffles08 thread starter macrumors newbie

    Joined:
    Jul 7, 2007
    #8
    Under Internet sharing when you have it to as

    Share your Connection From: Built-In Ethernet

    To Computers Using: Airport

    You should see a button for Airport Options. Under there you'll be able to set a password.
     
  9. ondra.kropik macrumors newbie

    Joined:
    Aug 24, 2008
    #9
    exactly the same issue...

    I've got exactly the same issue...
    I'm trying to share the internet connection from my iBOOK G4 with Tiger 10.4.11 to new iMac with Leopard 10.5.2. All works great but the internet connection! Sharing files works, apple remote desktop works, even the IP address is generated by the DHCP server)
    I've tried it both with airport and ethernet cable with the same results...

    any known solution for this problem?

    thank you!
    Ondra
     
  10. lisfolks macrumors newbie

    Joined:
    Sep 2, 2007
    #10
    Leopard Internet Sharing Connects but no internet

    I was trying to share a Windows PC with my Mac. The PC kept saying "limited or no connection" 'til I disabled the firewall on the Mac. Then it connected with no problem.

    I don't have any other sharing on (no remote login, personal web, or anything else at all), but I'm nervous about the security. Can WPA be enabled for Internet Sharing on the Mac?

    (Also, I noticed the original poster said they had no firewall turned on, so I guess this doesn't fix theirs...)
     
  11. lisfolks macrumors newbie

    Joined:
    Sep 2, 2007
    #11
    Answering myself... if I click Airport Options while the Internet Sharing is off, it gives me the option to set up a WEP password. No WPA, though - surprising. :eek:
     

Share This Page