Leopard locked my My Documents folder

joeyjoe9

macrumors newbie
Original poster
Jul 9, 2007
10
0
I formatted my Boot Camp partition to be FAT32 specifically so I would have access to the My Documents folder on the Windows side, but Leopard has now inexplicably locked that folder, preventing me from saving to that folder. I cannot un-lock from either the Mac or Windows side.

Anybody know what I can do?
 

illuminous

macrumors member
Oct 27, 2007
60
0
I have had the exact same problem with a folder on my external hard disk. It is locked in leopard, so cannot add or delete anything from it. To do anything I have to restart into Windows, where I can access it. I have tried removing the 'Locked' option using finder but it just won't let me??? Help!!!
 

theman

macrumors 6502a
Jul 26, 2007
738
0
when i moved a bunch of folders from my old pc to my MBP, it kept locking down some of them, seemingly randomly. i don't understand why.
 

Manna

macrumors newbie
Nov 14, 2007
1
0
I´ve had the same thing happen to me. Several, seemingly random, folders on my external hdd have been locked since I installed Leopard. I´ve tried all sorts of things, anyone know a fix for this?
 

bacchuswng

macrumors newbie
Nov 15, 2007
6
0
In modern versions of Windows, the read-only bit on folders designates them as "special folders." This includes folders such as Program Files, My Documents, My Pictures, etc. Note that Windows Explorer itself does *not* respect the read-only bit (i.e. it allows people to arbitrarily modify these folders), and all of this was apparently done "by design" (although this is quite possibly the most idiotic design I have heard in a while). More info on that here: http://support.microsoft.com/kb/326549

Anyway, Leopard respects the read-only bit, and as a result, you see the lock in Finder. The way to get around this is by removing the read-only bit. As Windows Explorer itself will not allow you to do this, you must do it in the (Windows) command line using attrib. For example:

attrib -r +s "C:\Documents and Settings\username\My Documents"

Although Windows Explorer will not confirm that the read-only bit has been disabled, typing in attrib without the -r +s will confirm this. Note that I am adding a +s to turn on the system flag, which is the suggested workaround by Microsoft (in the link above).

You should be able to write in those folders after this.
 

catroom

macrumors newbie
Nov 28, 2007
18
0
still can't copy from OSX partition to Win XP

I’ve created a bootcamp partition (FAT32) in Leopard, installed Win XP and all my applications etc and everything works OK. Except now, when booted into MacOSX, I cannot copy files from the Mac side into My Documents folder in the Win Partition like I used to be able to do in Tiger. Whenever I try, a window comes up saying “The operation cannot be completed because you do not have sufficient privileges for some of the items”. It seems that it will copy whatever folders I want to copy but not the docs in those folders????

Some of the folders in the Win partition are locked so I tried the suggestion above and although they get unlocked I still can't copy.

Anyone else had success?
 

kenjidnb

macrumors newbie
Jan 6, 2008
3
0
In modern versions of Windows, the read-only bit on folders designates them as "special folders." This includes folders such as Program Files, My Documents, My Pictures, etc. Note that Windows Explorer itself does *not* respect the read-only bit (i.e. it allows people to arbitrarily modify these folders), and all of this was apparently done "by design" (although this is quite possibly the most idiotic design I have heard in a while). More info on that here: http://support.microsoft.com/kb/326549

Anyway, Leopard respects the read-only bit, and as a result, you see the lock in Finder. The way to get around this is by removing the read-only bit. As Windows Explorer itself will not allow you to do this, you must do it in the (Windows) command line using attrib. For example:

attrib -r +s "C:\Documents and Settings\username\My Documents"

Although Windows Explorer will not confirm that the read-only bit has been disabled, typing in attrib without the -r +s will confirm this. Note that I am adding a +s to turn on the system flag, which is the suggested workaround by Microsoft (in the link above).

You should be able to write in those folders after this.
All comprehensive and very nice answer!

Thank you bacchuswng, you fixed my problem!! :eek:
 

penthang

macrumors newbie
Dec 28, 2005
4
0
I’ve created a bootcamp partition (FAT32) in Leopard, installed Win XP and all my applications etc and everything works OK. Except now, when booted into MacOSX, I cannot copy files from the Mac side into My Documents folder in the Win Partition like I used to be able to do in Tiger. Whenever I try, a window comes up saying “The operation cannot be completed because you do not have sufficient privileges for some of the items”. It seems that it will copy whatever folders I want to copy but not the docs in those folders????

Some of the folders in the Win partition are locked so I tried the suggestion above and although they get unlocked I still can't copy.

Anyone else had success?
On an apple support forum I read that a folder containing a desktop.ini file could not be unlocked with the answer being to delete this file. I haven't tried this yet but it seemed to work for the folks there.
 

leena

macrumors newbie
Nov 7, 2008
1
0
In modern versions of Windows, the read-only bit on folders designates them as "special folders." This includes folders such as Program Files, My Documents, My Pictures, etc. Note that Windows Explorer itself does *not* respect the read-only bit (i.e. it allows people to arbitrarily modify these folders), and all of this was apparently done "by design" (although this is quite possibly the most idiotic design I have heard in a while). More info on that here: http://support.microsoft.com/kb/326549

Anyway, Leopard respects the read-only bit, and as a result, you see the lock in Finder. The way to get around this is by removing the read-only bit. As Windows Explorer itself will not allow you to do this, you must do it in the (Windows) command line using attrib. For example:

attrib -r +s "C:\Documents and Settings\username\My Documents"

Although Windows Explorer will not confirm that the read-only bit has been disabled, typing in attrib without the -r +s will confirm this. Note that I am adding a +s to turn on the system flag, which is the suggested workaround by Microsoft (in the link above).

You should be able to write in those folders after this.
does anyone know if it's possible to remove this bit without using windows?
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.