Leopard Mail 3.0 Bug? - Displays fractions in header instead of "to, from, subject"

Discussion in 'macOS' started by danpat, Oct 26, 2007.

  1. danpat macrumors newbie

    Joined:
    Apr 4, 2007
    #1
    When viewing a mail message (Version 3.0 (912.1/912) from a brand new Leopard install) both in the preview pane and when fully opened there are what appears to be a fraction typeface displayed in place of the words "to", "subject", "date", etc as well as the entire subject line. Preferences are set to default for "show header detail", and problem remains when this is switched to 'all'.
    Checked preferences and all fonts are standard and available. Swapped some around to check and the header text is not user editable.

    See screenshot here:
    http://myskitch.com/danpatmore/magical-1.jpg___100___rgb_8__-20071026-221025.jpg
     
  2. tersono macrumors 68000

    tersono

    Joined:
    Jan 18, 2005
    Location:
    UK
    #2
    That's a weird one and suggests a corrupted or missing system font.

    For what it's worth, both Leopard installs I've done so far have been fine, and I've not seen this particular issue.
     
  3. thefunkymunky macrumors 65816

    Joined:
    Feb 24, 2005
    Location:
    London
    #3
    Have you tried repairing permissions and clearing out your font cache and restarting?
     
  4. danpat thread starter macrumors newbie

    Joined:
    Apr 4, 2007
    #4
    already tried the restart, checking and repairing permissions now.
    can i clear font cache without a 3rd party app?
    nice suggestions btw.
     
  5. thefunkymunky macrumors 65816

    Joined:
    Feb 24, 2005
    Location:
    London
    #5
    Probably via terminal but I wouldn't know the commands. You should be able to find a third-party Leopard compatible app for the font cache.
     
  6. danpat thread starter macrumors newbie

    Joined:
    Apr 4, 2007
    #6
    ok, onyx can apparently do it, but my verions isn't 10.5....but found this troubleshoot article:
    http://www.creativetechs.com/tips/quicktips_04.html
    and i'm going to try in Linotype Font Explorer to deactivate Helvetica Fractions which is my guess as the problem..
     
  7. thefunkymunky macrumors 65816

    Joined:
    Feb 24, 2005
    Location:
    London
    #7
    The Linotype app is perfect. I wasn't sure if it was working with Leopard though. It has an option to clean all font caches. It worked before for me when I had this problem in Tiger. Plus, its a much better alternative to Suitcase...and it's free. :)
     
  8. danpat thread starter macrumors newbie

    Joined:
    Apr 4, 2007
    #8
    Easy as!
    Helvetica Fractions was the problem, disabled and fixed without restart or even shutting mail.

    Thanks for the tips.
    I am going to look for font cache clearing now though.
     
  9. danpat thread starter macrumors newbie

    Joined:
    Apr 4, 2007
    #9
  10. thefunkymunky macrumors 65816

    Joined:
    Feb 24, 2005
    Location:
    London
    #10
    The options should be here. Note: I'm on Tiger atm as I'm in work. Should be the same in Leopard though.
     

    Attached Files:

  11. danpat thread starter macrumors newbie

    Joined:
    Apr 4, 2007
    #11
    fontfinagler says on their download page that it will not work in Leopard at all yet.
    Ahh, I see you're using Linotype. Cool
     
  12. thefunkymunky macrumors 65816

    Joined:
    Feb 24, 2005
    Location:
    London
    #12
    That screenie was from Linotype. Do you not have those options under the Tools menu?
     
  13. danpat thread starter macrumors newbie

    Joined:
    Apr 4, 2007
    #13
    Yep, did system font cache clear which required a restart, and then application font cache clear.
    All seems good now.

    Thanks for the tips.
     
  14. netnothing macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #14
    Just for reference, you don't need any utility to clear the system fonts.

    Just delete the folders under /Library/Caches/com.apple.ATS

    Then reboot the system.

    -Kevin
     

Share This Page