Leopard Mail always asks for my password?

Discussion in 'Mac Apps and Mac App Store' started by applefan69, Mar 28, 2008.

  1. applefan69 macrumors 6502a

    applefan69

    Joined:
    Oct 9, 2007
    Location:
    Medicine Hat
    #1
    Hello, for starters, I apologize if this thread has been posted before, im sure it has cause i swear i saw other people asking this question, I never bothered to read those topics, but I remember looking back and thinking "haha I never use leopard mail" anyways... I DO use leopard mail now, and im havin that problem. I tried searching for those other topics I saw, but I couldnt find them. So im gonna just make a new topic, and once again I apologize for asking an already answered question.

    So my problem is every time I Leopard mail, it prompts me for my Gmail password, I enter it, and click the box saying "keep this password in my keychains"

    Well next time i oepn mail I do the same thing...AGAIN.

    So I got Leopard mail 3.2 configured with Gmail iMap, it works great except this one hiccup. Anyone have a solution?
     
  2. cmcbridejr macrumors 6502a

    cmcbridejr

    Joined:
    Sep 28, 2007
    Location:
    Alpharetta, GA
    #2
    I use .Mac, Gmail, AOL, Yahoo, and others with Apple Mail on Tiger.

    I get the same problems with my AOL account always asking for the password and I don't know how to solve the issue either.

    I tell it to remember the password in the keychain, but that does not work.

    Hopefully, someone might have an answer.
     
  3. cyclingplatypus macrumors 6502a

    cyclingplatypus

    Joined:
    Mar 15, 2007
    Location:
    Earth
    #3
    I've found that if I have an account that I have something else checking (iPhone) it always knocks the one on the desktop off and ask me for a password. I fixed this by opening a "mobile" account and then the only time I check the desktop account on the phone is if the desktop is asleep. My problem was with a Yahoo account but my solution might help you.
     
  4. applefan69 thread starter macrumors 6502a

    applefan69

    Joined:
    Oct 9, 2007
    Location:
    Medicine Hat
    #4
    Well, I do in fact have Gmail iMap configured with my iPod touch, but my iPod touch isn't on very often, so I doubt it would be constantly syncing with Gmail. But maybe that is where the problem is. I guess now I gotta decide whether I want iMap Gmail more on my iPod Touch, or more on my Macbook.
     
  5. Terwal macrumors regular

    Joined:
    Jan 29, 2008
    #5
    Same problem ?

    I have exactly the same problem: I use Mail to access my Yahoo Plus emails, and I am being asked for my Yahoo password usually not upon opening Mail, but every 2 minutes when Mail is opened !! :confused:

    Of course, checking the "keep in keychain" box doesn't do anything...

    This is really a pain... :mad:

    Anybody can help please ? :)

    Thanks,

    w.
     
  6. 41qser macrumors regular

    Joined:
    Sep 5, 2007
    #6
    ditto, it's making me crazy.

    I deleted the keychain entry and re-entered my password in mail... no luck.

    It's making me insane.
     
  7. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #7
    I get this problem sometimes with .Mac email. It usually goes away on its own if I quit Mail and open it again later. I have no idea what's causing it, either... and like the posters above me it drives me bonkers. :(
     
  8. Terwal macrumors regular

    Joined:
    Jan 29, 2008
    #8
    I would hate having to give up using Mail and just use Yahoo Plus web mail's interface...
     
  9. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #9
    do you have your password entered under Accounts in Mail's Preferences?
     
  10. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #10
    I have mine entered for all of my accounts. For some odd reason, only .Mac complains, though. :confused:
     
  11. Terwal macrumors regular

    Joined:
    Jan 29, 2008
    #11
    For me as well... entered in my accounts in preference...

    And suprisingly, the issue came up only recently (after more than a month of using Mail with no pb)...
     
  12. wwooden macrumors 68000

    wwooden

    Joined:
    Jul 26, 2004
    Location:
    Burlington, VT
    #13
    I'm having the same problem. I'ved used mail with my gmail account for years and this problem only occurs in Leopard.

    For me, I think it started when I installed Office 2008 and Entourage. I setup entourage to work with my gmail as well, maybe I should try turning it off and see if that solves the problem.

    I had Leopard on my computer for a while before I got the new Office and I don't recall it having this problem. I'll update this thread if I find out anything.
     
  13. turbomads macrumors newbie

    turbomads

    Joined:
    Apr 4, 2008
    #14
    Possible solution

    Hey,

    having had the same problem, the following worked for me:

    1. Open the "main keychain" (I have a danish system, dunno really what you call it :) )
    2. Locate the password key, giving problems and delete it.
    3. Close the key chain program, relaunch mail and try again.
    3. Mail will now ask again for your password when trying to access your mail provider, but should now be able to remember it, if you check the "remeber password"-checkbox, naturally.

    Best regads
    Mads
     
  14. Nathalie macrumors newbie

    Joined:
    May 27, 2008
    #15
    Has anyone solved the problem?

    Hi, a bit of a late post, I've only just seen the thread, but did anyone manage to solve this problem?

    I'm unable to send email from Mail 3.2 on either my Yahoo! or ntlworld email accounts and my passwords keep getting rejected too... :mad:

    I spoke to a 'Genius' in an Apple store today and he had a look. He basically thinks it's an issue with compatibility with these email providers and Leopard. He said the only email provider that seemed to work was gmail... Great, if only I used it!

    I already tried resetting the keychain passwords, doesn't make a difference. :(
     
  15. cmcbridejr macrumors 6502a

    cmcbridejr

    Joined:
    Sep 28, 2007
    Location:
    Alpharetta, GA
    #16
    I think you need to use an Apple Mail plug-in to make it work.

    Try here:

    http://www.tikouka.net/mailapp/

    Maybe the HTTPmail plug-in.

    Let me know if that works.
     

Share This Page