Leopard Mail & Certificates

Iso79

macrumors member
Original poster
Aug 15, 2007
40
0
Every time I open Mail to check my email it keeps asking me to verify my certificates for all my email accounts except gmail and every time I check the always trust check boxes and made sure the always trust is selected in the drop-downs, but for some reason every time I open Mail, the same certificate verification pop-ups keeps popping up! Is there anyway to disable these or is it a bug?
 

Yuppi

macrumors regular
Aug 6, 2007
197
0
I had this problem when I used the tiger-mail client. But now in leopard this problem finally was solved. The problem in my case was that the certificate was self signed without a CA.
Maybe your certificate was expired or invalided in another way (like using the wrong host name to connect).
 

Iso79

macrumors member
Original poster
Aug 15, 2007
40
0
I had this problem when I used the tiger-mail client. But now in leopard this problem finally was solved. The problem in my case was that the certificate was self signed without a CA.
Maybe your certificate was expired or invalided in another way (like using the wrong host name to connect).
Yeah they have expired Feb, 2007. How do I renew them?
 

analog

macrumors newbie
Nov 21, 2007
1
0
I'm having the same problem now as well.
Every time I launch mail it asks me to verify the certificate, even though I have changed it to always accept. It will even say the certificate is trusted, but ask me to verify.
Any help would be much appreciated. I didn't start having this problem until I updated to 10.5.1 and added 2 new mailboxes.

thanks
 

apfhex

macrumors 68030
Aug 8, 2006
2,670
4
Northern California
I have this problem when Mail checks for new messages. Not sure if it started with Leopard's Mail.app or when I got Gmail IMAP setup (they happened about the same time). It's like it will randomly pick one of my accounts (two IMAP and two POP) and tell me the certificate is bad. Happens so many times a day I'm starting to get pretty mad.
 

mikes63737

macrumors 65816
Jul 26, 2005
1,133
310
I solved this problem a few days ago. When the dialog box pops up, click on either the little triangle (if there is one) or the button on the left (i forgot which) and some more options will come up. It's in there somewhere.

Sorry I can't be more specific.
 

big_malk

macrumors 6502a
Aug 7, 2005
557
1
Scotland
I have the same problem in Mail and Safari.

I've checked the checkbox to say always trust, when I expand the triangle things it says it's marked as trusted for all users, yet EVERY time I still have to tell it to continue.

It's pretty annoying because I have to work with about 3 website that do this every day, and have about 3 accounts in Safari that do this, so I have to re-tell it to trust these certificates about 10 times a day.

Is there nothing that can sort this??
 

Similar threads

  • Gregg2
0
Replies
0
Views
42
  • indychris
4
Replies
4
Views
259
Replies
0
Views
201
Replies
3
Views
353
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.