leopard no install destination available..

Discussion in 'macOS' started by nielssiem, Oct 27, 2007.

  1. nielssiem macrumors newbie

    Joined:
    Oct 27, 2007
    #1
    I bought family pack.
    Installing leopard on iMac went fine.

    Now i try to install leopard on my mac book pro.
    During the installation routine. I have to choose a destination were I want to install leopard on..I would expect to see my harddisk..but noting is available..i can't make any selection.

    Can someone help me? Thanks in advance.
     
  2. Shaduu macrumors 6502a

    Shaduu

    Joined:
    Jan 31, 2007
    Location:
    Southsea
    #2
    How much space have you got free on your drive? If your free space is insufficient, Leopard won't install. Saying that, your drive should still show up regardless of whether you have enough space or not.

    Try an Apple store? :eek:
     
  3. Sijmen macrumors 6502a

    Joined:
    Sep 7, 2005
    #3
    I called AppleCare for the same problem, and according to the rep I wasn't the first experiencing it. This has also come up a couple of times here on the forums.

    The rep told me to click in the empty space (where the drives should be) to refresh the listing. After a couple of times the drive should show up. Others have reported that waiting also works.
     
  4. Luap macrumors 65816

    Luap

    Joined:
    Jul 5, 2004
    #4
    Yes.. Quite a well documented problem already.. But in all cases I heard about, simply waiting will cure it. It can take several minutes on occasion though..
     
  5. nielssiem thread starter macrumors newbie

    Joined:
    Oct 27, 2007
    #5
    But there seems no accurate solution. Waited already 60 minutes, 40 gb available and also click in the window were the hd icon should appear.
     
  6. jersey macrumors regular

    Joined:
    Jul 9, 2007
    #6
    i had the same problem. Make sure you're updated all the way. I had an efi bootrom update for my mb I had neglected. After installing it, the install DVD found my drive.
     
  7. skinnylegs macrumors 65816

    skinnylegs

    Joined:
    May 8, 2006
    Location:
    San Diego
    #7
    I had the same problem. I turned my computer off the on again with the DVD still in and it worked for me. Smooth sailing ever since.....
     
  8. nielssiem thread starter macrumors newbie

    Joined:
    Oct 27, 2007
  9. lorax3 macrumors regular

    lorax3

    Joined:
    Jun 25, 2007
    #9
    Install

    I had the exact same issue, and looking around Apple's support forums I found a "solution"
    When at the "Select a Destination" screen go up to the menu bar and open Disk Utility, as you will see your main HDD is there, but your OS X partition is missing. I just click on my hard drive, and waited ten mins and the drive re-appeared.

    Although it seems like a lame solution, it worked for me and many others.

    Check this forum topic on Apple Discussions for more Info.

    http://discussions.apple.com/thread.jspa?messageID=5647688&#5647688

    Update:
    Apparently this works also
    "We solved it:
    at the "select destination" screen it stops and shows nothing
    open up terminal from utilities
    type df -k
    firt time, the internal volume isn't seen
    type df -k again
    now the volume is there!
    close terminal and continue."
     
  10. happydude macrumors 65816

    happydude

    Joined:
    Sep 2, 2006
    Location:
    a gasping dying planet
    #10
    same problem

    waited an hour, no disk showed up. i'll try some of the suggestions here and report back
     
  11. phantasmagoria macrumors regular

    Joined:
    Nov 15, 2006
    Location:
    UK
    #11
    I had the same issue, and fixed it the same way with a reboot.
     
  12. happydude macrumors 65816

    happydude

    Joined:
    Sep 2, 2006
    Location:
    a gasping dying planet
    #12
    problem solved for us

    we just restarted the computer, ejected the disc. reinserted the disc, started up the installer, when restarted and installer up and going, the HD was found.
     
  13. finchwizard macrumors member

    finchwizard

    Joined:
    Nov 15, 2005
    Location:
    Australia
    #13
    Just for reference.

    I had it happen earlier.

    The reason it takes a while to show up on some machines is that the installer is doing a file system check on the disc first.
    It would of been nice to have something saying that, but ah well.

    You just need to wait till the disk has finished it's check, then it will show up.
     
  14. Hobofuzz macrumors regular

    Joined:
    Oct 9, 2006
    #14
    I posted this in an earlier thread:

    Try this in the terminal.

    Code:
    diskutil list disk0
    If your disk is not the first one, then replace disk0 with whatever number the disk is minus 1.

    What you should see is a list of the partitions on the disk. Look for the one that says "Apple_HFS". Take note of the entry on the right, in the "identifier" column.

    Now, type
    Code:
     diskutil mount (whatever the identifier was from the list)
    It will take about a minute or two, but it should mount, and you'll be all set.

    An even easier way to do this is to just type:
    Code:
    diskutil mountDisk
    It should mount the first disk in your system, along with ALL partitions on it. If you only have one partition on that drive, it should make things much easier, but if you have more than one partition because of Bootcamp or something, the "diskutil mount" command is quicker.
     
  15. craigp macrumors member

    Joined:
    Feb 28, 2007
    #15
    Thanks for your help guys. I had the same problem with a friend's machine that I was upgrading for him, and this solved it.

    First builds of new Apple OS versions, eh? I love being an early adopter.
     

Share This Page