Leopard <-> PC, crossover cable

Discussion in 'macOS' started by mark88, Nov 16, 2007.

  1. mark88 macrumors 6502a

    Joined:
    Oct 30, 2004
    #1
    I just installed Leopard and my network has gotten messed up. I've now got 1 crossover cable connecting my iMac to my PC and it's still not working correctly.

    On each machine I have set a static IP and subnet Mask only. On the PC side I can browse the Mac just fine but I have to manually enter 192.168.2.10.....

    On the mac side, none of the windows shares appear in the sidebar, doesn't even appear when I click 'browse' in the connect to dialog. To gain access to the windows machine I have to manually enter smb://192.168.2.2 and then "192.168.2.2" appears in my sidebar and I can share files.

    But this isn't how it's supposed to be!! Why aren't the computers finding each other on their own? All firewalls are turned up. Workgroups are set to the be the same also.
     
  2. unity macrumors 6502a

    Joined:
    Sep 30, 2005
    Location:
    Green Bay, WI
    #2
    Try turning off the firewalls.

    Have you updated to 10.5.1? Some have reported better results with .1

    Also you dont need a cross-over cable, those are a thing of the past. All recent Macs (as of 5 years ago) auto-sense the cable config. Same for newer PCs. I have a PC and Mc at work connected via 1 regular patch cable.
     
  3. dalvin200 macrumors 68040

    Joined:
    Mar 24, 2006
    Location:
    Nottingham, UK
    #3
    what's a patch cable?
     
  4. mark88 thread starter macrumors 6502a

    Joined:
    Oct 30, 2004
    #4
    All firewalls are off and I've updated to 10.5.1 already
     
  5. mark88 thread starter macrumors 6502a

    Joined:
    Oct 30, 2004
    #5
    I've just tried the same thing with an older mac running Tiger, setting the same IP address and my PC appears automatically under the workgroup in Finder.
     
  6. eluk macrumors 6502a

    eluk

    Joined:
    Dec 14, 2006
    Location:
    East London, UK
    #6
    A normal Ethernet cable.
     

Share This Page