Leopard + Silicon Image 3132 eSata expresscard

Discussion in 'Mac Accessories' started by okachobi, Oct 30, 2007.

  1. okachobi macrumors newbie

    Oct 30, 2007
    I'm having a very odd problem. I have a WD MyBook ES that has both USB and eSata ports. I have 2 partitions on it- 1 is HFS+ and the other is FAT32. Both work fine with USB.

    With the ExpressCard however, I encounter a problem with the HFS+ partition. Both show up under Leopard, but after I copy 1 or 2 files to the HFS+ partition I get either a "Filename too long" error or an "unexpected error" -50 error code on any other operation. From that point forward, the partition acts as if its read-only, but doesn't show that in any of the permissions. All write operations fail after this.

    However, the Fat32 partition continues to work just fine, and does not appear to suffer from the same problems. It seems I can copy files to and from it all day without problems. Both are on the same drive, going across the same controller.

    The card is a T-EC2R made by ONNTO (onnto.com). Its essentially a reference implementation of the sil3132 expresscard eSata 2. In fact, I've flashed the reference bios to try to troubleshoot the problem, and I'm using their drivers since ONNTO does not provide mac drivers for this card. The short story is that I ordered the T-EC2S, which does have drivers for OS X, but they shipped me the T-EC2R. When I realized it was a reference design, I just used the drivers from Silicon Image.

    I've tried a few things. After I noticed this problem, I tried flashing the non-RAID bios onto the card, and this worked ok. The card functions under bootcamp and Windows just fine, and it appears as though everything works initially under OS X.

    I just don't understand why HFS+ is failing and Fat32 is succeeding. I've run a disk check on the drive and HFS+ checks out just fine. All I can imagine is that Fat32 is getting silently corrupted if indeed there is a problem.

    I tried a verify on the disk, and it came back ok. So I tried a repair just for kicks, and it fails to unmount the drive. No applications have the drive open. Using Fat32 really isn't an option because I anticipate having files over the 4 gig limits with video production. Also, it seems the time machine doesn't like Fat32....figures.

    At this point, I'd just like to find a good card that works with a MacBook Pro running Leopard. But if I could fix this situation I'd be fine with it. Before someone screams firewire 800, I have an original intel MacBook Pro (1.0 rev) that has Firewire 400. I use the system for recording and push about 12 channels of 24 bit/48khz through the firewire port now. I will admit that I have not tried recording over USB to the MyBook because I don't trust that its fast enough to handle that amount of data. It might be, but nothing sucks more than recording a take and discovering there was problem.

    Finally, i had tested this card before the Leopard upgrade and I thought it was working fine in OS X. I had not done extensive testing with it though because I've been doing the recording under Windows. I've seen others talk about the Silicon Image drivers working fine with Leopard betas. So I'm at a loss.
  2. tricil macrumors member

    Oct 30, 2007
    I too am a musician in the same boat...

    I have a MBP as well (2nd gen) and a Seagate FreeAgent Pro eSATA/USB
    with a 3132-enabled Merax card.

    The drive is 500GB and i've got it partioned down the middle... 233 for Audio and 233 for Time Machine backup

    I have gotten every single one of the errors you've described - I went crazy trying to figure it out - even Time Machine wasn't playing nice. I had copied over the important audio files (but had to sacrifice some seeing as I had more data than internal space) and erased and re-partitioned countless times.

    I was about to return the still warrantied drive until i had the revelation that it had USB and Time Machine _finally_ started backing up my drive and I knew I was in business...

    Now, the question is, when will Silicon Image release Leopard drivers?

    thanks for confirming my problem
  3. gyza macrumors newbie

    Oct 31, 2007
    Same here... I use the same WD My Book eSATA drive, express card and Silicon Image driver and have exactly the same symptoms as you :mad:

    I was previously running 10.4 Tiger for a couple of months with this setup and everything worked fine.

    Do you think it is something that a revised driver from Silicon Image would solve? Or an update from Apple... I'm not holding my breath on that one...
  4. Inconsequential macrumors 68000

    Sep 12, 2007
    God im getting EXACTLY the same issues as you guys!!!

    However my Akasa eSATA 2.5" 7K200 200Gb external works fine :confused:

    I mean, properly fine, I have my Lightroom library on there and its fine :eek:
  5. okachobi thread starter macrumors newbie

    Oct 30, 2007
    So its not just me

    So I'm not the only person having this issue after all. I think this is a good indication that the problem is simply a driver issue that Silicon Image can resolve with some minor code changes to support Leopard. I'm just a little surprised that their developers hadn't tested Leopard in Beta and hadn't already made those changes. Or maybe they did, but since they're an OEM shop, they may not have put the driver up for download yet.

    I've emailed their OEM support to see if I can't find out more. The contact information is supplied during the driver install:

    email: steelvinesupport@siliconimage.com
    phone: (408) 962-4212

    although it says after this "Please contact your Sales representative to get support for products not purchased direct from Silicon Image". Maybe there is someone here with an OEM relationship with Silicon Image who could inquire?

    Update: I've opened a support ticket with ONNTO, who is the OEM that makes the ExpressCard I'm using, and asked them to get in contact with Silicon Image about newer drivers for Leopard. They have responded and are investigating. Hopefully I'll hear back from them within a few days, but I'm not holding my breath.
  6. tricil macrumors member

    Oct 30, 2007
    I just did the same thing, emailed both steelvinesupport and Merax (my vendor).

    No reply yet, but let's get the buzz going!

    UPDATE: Merax wrote me back, but won't know anything until next week. Let's keep our fingers crossed!
  7. palexandridis macrumors newbie

    Nov 2, 2007
    Portland, OR

    Same thing going on here. Same chipset on my EC/34 card made by NitroAV, same problems writing to a 500GB Seagate Free Agent Pro (100% FAT32). I also was poking around the Silicon Image site, but they haven't said anything yet. I guess I'll switch to USB 2 for now.

    I will add that when I try to copy a file it copies a certain amount, then gives me a similar error (36, I think), at which point the folder I was in shows no files. Also, I can no longer eject the drive at this point - have to log out or restart. Works fine in BootCamp as far as I can tell. The price of speed:(.

    Update - I've sent my OEM a ticket as well.
  8. boggled macrumors newbie

    Nov 3, 2007
    I am annoyed. I have just upgraded to Leopard, and, now, I get all these error messages. I have the Apiotek EC-0003D expresscard and WD My Book 500GB.
    I've had no problems copying files and backing up in Tiger 10.4.10. I went to Apiotek's website. They have a driver for Leopard. I downloaded and installed it; I still get the same error messages.

    Does anyone else have this card?
  9. intlplby macrumors member

    Jul 14, 2004
    It doesn't matter who the vendor is. It's completely Silicon Image's responsibility.

    The vendors are just going to wait for SI to fix it.

    All these cards use the same chipset.

    I don't know of another SATA II expresscard with port multiplier support that doesn't use the 3132 chipset
  10. gomatt macrumors member

    Feb 21, 2006
    FINALLY i found ppl with my problems.... I have all the above and...

    when trying to time machine backup, it fails...


    the mounting and unmounting is not playing right, sometimes it will just randomly unmount and sometimes it wont let me copy. Also, I cant do anything to the drive in disk util...

  11. tricil macrumors member

    Oct 30, 2007
    email your card's vendor... let's get this buzz loud enough so we can finally have some Sil support!
  12. okachobi thread starter macrumors newbie

    Oct 30, 2007
    any luck?

    Has anyone had any luck getting information on this?

    The reps from ONNTO have tried to recreate the problem and cannot and apparently they're getting information from Silicon Image that they too have been unable to recreate the issue.

    Is there some commonality between our systems?

    I have a MacBook Pro 1.86 ghz 15 inch system with 1 gb of memory and with motherboard revision 1,1. Boot rom MBP11.0055.808 and SMC version 1.2f10. The video chipset is the Radeon X1600 rev 0. The internal SATA chipset is the Intel ICH7-M. Its internal drive is a 100gb 7200 rpm. Nothing has been upgraded on the hardware. My external eSata drive is the MyBook ES 512meg version. I have 2 partitions on it, a Fat32 and a HFS+ partition.

    The only thing I can think of that I'm running that might have affected this was a utility that strips universal binaries of their powerpc code to free up disk space. Its called monolingual and also strips out multilingual strings when you don't intend to use them. It saved a few gigabytes of space on the laptop drive.

    I also run OpenVPN which I believe has a kernel driver. I believe the MyBook ES installed a program to handle when the USB shutdown button on the drive is pressed as well.

    Finally, are there any other eSATA express cards not based on the Silicon Image 3132 chipset? I need to restore high speed connectivity to my external drive and I'm about ready to put this card on ebay and get a different card.
  13. okachobi thread starter macrumors newbie

    Oct 30, 2007
    Possible issue acknowledgement

    I found this over at the Apple Support Forums:


    To paraphrase, they say that there is an issue with the chipset when used with a drive enclosure that supports both USB and eSata interfaces. The author of the post claims to have confirmed it himself by using a eSata enclosure without a USB interface.

    I'm not sure how this would be a problem since the USB interface should be disabled when you are using the drive as eSata, but I can't test it myself.
  14. Chris Collins macrumors newbie

    Nov 15, 2007
    MacPro and MacBook Pro have this issue

    I find it hard to believe this is an eSata + USB enclosure issue. I have the following configs:

    MacPro with SI 3132 PCI express card

    MacBook Pro with SI 3132 express card

    5 bay raid case with a silicon image esata port multiplier (was configure as a raid 5 array using 4 disks).

    1 drive estata + usb enclosure.

    My MacPro literally hangs and reboots when I plugin the raid case. I had it working ok for about 20 mins where I was able to configure the array on the macpro with Raid 5.

    The Macbook just acts very sluggish when I plugin either the single drive enclosure or the array. Sometimes the raid software recognizes the existence of the array, but mostly not.

  15. boggled macrumors newbie

    Nov 3, 2007
    I had contacted Silicon Image support and they have responded

    I have received three emails from Silicon Image support. Here they are. They acknowledge the problem and they are working on it. I wrote in my email telling them what the genius at my local genius bar told me.

    1st email:
    "The previously released 1.1.9 drivers do not implicitly support 10.5 and
    Silicon Image, Inc. is currently qualifying Mac OS X 10.5 Leopard.

    In the last week I've received one other request for support. An end
    user using SiI3132 Mac OS X drivers 1.1.9 was successful in getting the
    driver to work after she reinstalled the driver.

    As a side note, Since Silicon Image builds chips and does not
    manufacture add-in cards. Consequently, I do not know which driver the
    card manufacturer supports with your device.

    I've added to an alert list that I'll use to send an update once SIMG
    completes testing with Mac OS X 10.5."

    2nd email:
    "Since Silicon Image (SIMG) builds chips and does not manufacture add-in
    cards, I do not know what the card manufacturer or the card reseller
    promised you. Silicon Image, explicitly supports 10.4.x and 10.5 Tiger.

    Although SIMG does not offer any consumer products, SIMG does work
    directly with card manufacturers and resellers to resolve problems. Would
    you ask the genius to contact SIMG direct?"

    3rd email:
    "Just noticed a typo in my last email. I realize Tiger is 10.4 while Leopard is 10.5. While Silicon
    Image, Inc. notes support for 10.4, we're now working to complete
    qualification with Leopard 10.5.

    Please let me know if this help resolve the problem. If not, I'll pass
    your problem report on to a developer for further study."
  16. okachobi thread starter macrumors newbie

    Oct 30, 2007
    I hope you told them that NO the last response does not resolve your problem, and yes please have a developer study it further??? :confused:

    ONNTO, the maker of my SiI3132 rebranded expresscard, was unable to recreate the problem using various configurations, though they did say in a malformed way that silicon image was working on the issue. I think their exact words were "We got feedback from Silicon Image that they need some to modify the driver." I believe the missing word there is "time".

    I didn't see an explicit acknowledgment of the existence of the problem from Silicon Image in your email thread. They said they were working through "qualification", but I'm not sure that really acknowledges a problem so much as some testing to qualify it for Leopard.
  17. stephenrx7 macrumors newbie

    Nov 16, 2007
    Oxford Semiconductor vs eSATA Expresscard chipset

    I too am having similar problems with my Seagate Freeagent Pro USB2/eSATA combo drive, only with larger files, and only in Leopard. I am using 1.1.9 version of Sonnett's Tempo Expresscard 34 eSATA card drivers. When I copy large files (800mb MP4 movies mainly), I get a -36 error in the Finder and the drive stops responding until I re-seat the cable). This only happens on the eSATA interface in Leopard, and only with my Seagate Freeagent Pro drive.

    I just got off the phone with Sonnett tech support. He informed me that it is their position that there is a bug in the firmware of the Oxford Semi Chipset that is used in the Seagate Freeagent Pro drives and WD MyBook drives and that this problem also exists in Tiger (I can't reproduce this part). He mentioned that his engineer is working with Oxford Semi to resolve this issue, but gave me no ETA on a workaround. He did say that I could write to support@sonnettech.com to ask for a beta driver when it becomes available.
  18. okachobi thread starter macrumors newbie

    Oct 30, 2007
    Isn't it funny that if you use Bootcamp and Windows XP, then install the windows xp driver they provide, there is no bug in the drives firmware anymore. Imagine that! :eek: Suddenly the card is 100% compatible with the drive, bugs and all, and obviously the problem isn't with the driver ;)

    Its also funny that with the eSATA card I use on another PC, which is another Silicon Image chipset (not the 3132), the drive is working just fine. It is only with the latest release of Leopard that there has been any difficulty with the the eSATA standard and my drive.

    I too did not have this problem under Tiger (10.4.x). It began with Leopard (10.5.x). I just wish Silicon Imagine would issue a notice to their vendors that there is a problem, and that they are resolving it. It may very well be some kind of unexpected response from the affected eSATA drives, but other eSATA card's drivers don't have the compatibility issue and as such I suspect the drives are still working within the eSATA standards. Which is more likely, all other cards & drivers are flawed in such a way that they just happen to work correctly, or the Sil3132 drivers for OS X made a bad assumption?

    Either way, it appears that since the sane drive and same card talk fine under windows there will be a driver "fix" for OS X. I just wonder if we will get it this year.
  19. n0d3 macrumors regular

    Oct 12, 2006
    I'm using an Apiotek eSATA card with drivers from Silicon's site. Worked fine with my external eSATA drive without any errors (transferred a couple of files ranging from 1GB to 3++GB).
  20. boggled macrumors newbie

    Nov 3, 2007
    I have several WD My Book Premium ES Edition drives. I get two error messages. "The Finder cannot complete the operation because some data in "file" could not be read or written (Error code -36)"

    "You cannot copy some of these items to the destination because their names are too long for the destination. Do you want to skip copying these items and continue copying other items?" - I don't get this error when I use the USB interface. So it can't have anything to do with a file name being too long.

    I never had any problems before I had upgraded to Leopard. So, now we can't be sure if the Sil3132 chipset and the WD My Book firmware are incompatible with Leopard. Or, if Silicon image needs to develop a driver for Leopard.
  21. boggled macrumors newbie

    Nov 3, 2007
    Yes, I emailed him back telling him that non of his support has worked or helped. I haven't heard back from him, yet.
  22. tokyojerry macrumors newbie

    Nov 22, 2007
    PCI Express eSATA Driver for Leopard

    Somewhat of a long link below, but, I just picked up on this information from a website of one Japanese. I installed this driver in Leopard 10.5.1. All the drives in my case (4-HDD case with Multiplier) recognized instantly. Hope this helps for all you folks that might be attempting to connect external eSATA boxes to Macs via a PCIexpress card.


    If the link above does not work directly for some reason, then go to the Silicon Image website Support page....


    alternatively, try to search for Sil3132 and OS-X Leopard on their site. I hope this helps.
  23. tricil macrumors member

    Oct 30, 2007
    These are the old, non-functioning drivers.

    EDIT: I tried them out again, thinking maybe the 10.5.1 update miraculously "fixed" these drivers (they didn't) and got a sucessfull 16MB time machine backup (still not unusual) but then tried the usual copy a directory over and got the darn -36 errors:

  24. okachobi thread starter macrumors newbie

    Oct 30, 2007
    What I've heard now...

    I may have already posted some of this info, so forgive me if I repeat myself.

    The issue supposedly stems from the firmware in the Oxford 921 chipset. There is supposedly a newer firmware that resolves the issue, but Oxford Semiconductor does not distribute the firmwares directly to end-users since they have not been tested with every enclosure.

    The affected drives include the WD MyBook ES and the Seagate Freeagent Pro drives since their enclosure is based on this chipset.

    I attempted to open a case with Western Digital, but after a week their claim of "24 hour" response has left me wondering what kind of clock they use. I guess when you use the phrases "firmware bug" and "exchange my drive because its now unusable" in the same issue, it takes them a while to process it.

    The manufacturer of my card, ONNTO, has been very responsive. They went as far as to get an updated firmware from Oxford and tested it with an oxford921-based enclosure, reporting that their current firmware release is working. I do not know if they ever recreated the issue though. They've also been in contact with Silicon Image who told them that there will be a new driver released in early December to address the issue.

    This was the first time I had heard an acknowledgment of the issue and a timing of a driver update. So keep watching the Silicon Image drivers page. I'll respond here if I see an updated driver.
  25. MoNeart macrumors newbie

    Nov 29, 2007
    Kernel panic when inserting the eSATA expresscard

    This is the most annoying issue. When I bootcamp into vista ultimate, i was able to load and install driver without a problem. When I go back into leopard, I get a kernel panic when I pop in the card:

    Thu Nov 29 10:16:12 2007
    panic(cpu 0 caller 0x00427BC7): "getPhysicalSegment() out of 32b range 0x119471600, len 0x200, class IOBufferMemoryDescriptor"@/SourceCache/xnu/xnu-1228.0.2/iokit/Kernel/IOMemoryDescriptor.cpp:1471
    Backtrace, Format - Frame : Return Address (4 potential args on stack)
    0x5af97718 : 0x12b0e1 (0x455670 0x5af9774c 0x133238 0x0)
    0x5af97768 : 0x427bc7 (0x49897c 0x19471600 0x1 0x200)
    0x5af97838 : 0x5d39ae6d (0x9525d80 0x0 0x5af978ac 0x19cf19)
    0x5af97878 : 0x5d3a7099 (0x69a7000 0x699f0bc 0x10000000 0x5af978ac)
    0x5af978c8 : 0x5d3a7438 (0x4659d05c 0x699f0bc 0x5af97980 0x0)
    0x5af97908 : 0x5d3a2ddc (0x4659d05c 0x5af97980 0x0 0x465a6000)
    0x5af979d8 : 0x5d3a4b3e (0x4659d05c 0x699f0bc 0x0 0x0)
    0x5af97a48 : 0x5d39b63f (0x4659d05c 0x699f0bc 0x5af97a6c 0x8281300)
    0x5af97a78 : 0x5b6fabb0 (0x69a7000 0x8281400 0x0 0x3e8070)
    0x5af97aa8 : 0x5b9810d9 (0x8266600 0x825f700 0x5af97aec 0x5af97ae8)
    0x5af97af8 : 0x5b989809 (0x8266600 0x825f700 0x825f700 0x0)
    0x5af97b28 : 0x5bcffd26 (0x8283000 0x825f700 0x7530 0x5bd00064)
    0x5af97b98 : 0x5bcfd453 (0x8283400 0x9525d80 0x0 0x0)
    0x5af97c18 : 0x5b3e3405 (0xde80f00 0x9525d80 0x0 0x0)
    0x5af97c88 : 0x5b3e5619 (0xde80f00 0x9525d80 0x0 0x0)
    0x5af97ce8 : 0x5b3e8455 (0x8283100 0x0 0x0 0x9525d80)
    Backtrace continues...
    Kernel loadable modules in backtrace (with dependencies):
    dependency: com.apple.iokit.IOSCSIParallelFamily(1.5.0)@0x5b6f6000
    dependency: com.apple.iokit.IOPCIFamily(2.4)@0x54f94000
    dependency: com.apple.iokit.IOSCSIArchitectureModelFamily(2.0.0)@0x5b97b000
    dependency: com.apple.iokit.IOStorageFamily(1.5.2)@0x5b3e0000
    dependency: com.apple.iokit.IOSCSIArchitectureModelFamily(2.0.0)@0x5b97b000

    BSD process name corresponding to current thread: kernel_task

    Mac OS version:

    Kernel version:
    Darwin Kernel Version 9.1.0: Wed Oct 31 17:46:22 PDT 2007; root:xnu-1228.0.2~1/RELEASE_I386
    System model name: MacBookPro3,1 (Mac-F42388C8)

Share This Page