Leopard update changed my connectivity!

Discussion in 'macOS' started by edcoche, Nov 10, 2007.

  1. edcoche macrumors regular

    edcoche

    Joined:
    Nov 2, 2007
    #1
    Hello I am writing to see if anybody else encountered this problem. Today recieved my new macbook in the mail and I had been using it all throughout the day and after I performed a software update i turned on my family's pc and after windows loaded up (and connected to my wireless network) i grabbed my mac and I saw that I lost my internet connection and it prompted me to enter in my password. I thought that was wierd b/c I had already entered in my password and told it to remember the connection. Anyways, i reentered my password and after 3-4 seconds i see something that says: "incompatible security." So I disable the wireless internet on the pc and suddenly the macbooks wireless works again (w/ no pword request.) What do I have going on here? Any software updates required? I am stumped!
     
  2. mock5120 macrumors newbie

    Joined:
    Nov 1, 2007
    Location:
    Norman, OK
    #2
    DSL Router

    If you have DSL and they gave you a 2Wire router, try putting "$" in front of the WEP code. For some reason that's the only way those routers recognize WEP codes coming from a Mac a hexidecimal.
     
  3. edcoche thread starter macrumors regular

    edcoche

    Joined:
    Nov 2, 2007
    #3
    I have a Belkin Pre-N wireless router. It has been a good router for me the past 1 1/2 years. I just got a macbook and now it seems that ol PC and MAC are fighting for the wireless network, and arent willing to share it! :(
     
  4. edcoche thread starter macrumors regular

    edcoche

    Joined:
    Nov 2, 2007
    #4
    So, I am still having problems with my local network. I live at my parents place (for now--it blows) and we have 3 items connected to the WEP protected network: their PC, my Wii (which always is connected to the network) and my mac. For some reason which I do not understand, the mac and the pc cannot be connected to the network at the same time. If I disconnect my parents PC and connect with my mac, the pc then will not connect, and vise versa. When I try to connect to the network when the PC is connected I get a message saying "incompatible security." This is so very annoying. I have seen threads of people with similar networking issues (many of which are users who upgraded from tiger.) I find it so hard to believe that apple would release an OS that has network connectivity issues. What in the world am I doing wrong.

    I see people saying that if you disable the WEP password then the incompatible security issues cease but thats ridiculous. I want to have a secure network and I want the internet to work on any of the 3 options available here.

    Anybody know whats going on here?
     
  5. edcoche thread starter macrumors regular

    edcoche

    Joined:
    Nov 2, 2007
    #5
    Here was the problem the WHOLE TIME. I had no way of knowing this but a Belkin tech guy told me to enter in a "$" before the WEP password and it should work. He proceeds to tell me that PC's don't need the dollar symbol before the password whereas macs do! Is this commonly known knowledge?
     
  6. mock5120 macrumors newbie

    Joined:
    Nov 1, 2007
    Location:
    Norman, OK
    #6
    should have tried it

    I guess it's an issue with more than just the 2wire routers. It has something to do with the router not recognizing mac passwords as hexadecimal without the $ sign.
     
  7. JSchwage macrumors 6502a

    JSchwage

    Joined:
    May 5, 2006
    Location:
    Rochester, NY
    #7
    Great tip! I had been trying to connect to the secure wireless here at work and had kept on getting that incompatible security error message. Tried adding a dollar sign in front of the WEP key and it worked perfectly!
     
  8. panamajack macrumors member

    Joined:
    Aug 14, 2006
    #8
    '$' trick not working....

    Came home for the holidays, only to discover that my folks WEP enabled network doesn't work for my Leopardized 12" PB. :mad:

    Even worse, the $ trick doesn't seem to be working either. It's an old SMC g router.

    Any other suggestions ?
     
  9. fredstahl macrumors newbie

    Joined:
    Jan 16, 2008
    #9
    Work around for "incompatible security" in Leopard

    Quite by accident, i discovered a practical albeit cumbersome way to get back on your wireless network.

    1. When you awaken Leopard you get the "None of your preferred networks are available" message.

    Cancel it.

    2. Ask Safari to open any page. It will, of course, hang with the message "You are not connected to the Internet."

    Click on the "Network Diagnostics..." button in the message box.

    3. You should get a dialog box titled "Network Diagnostics". The list of "locations" should have the name of your usual network setup highlighted in gray. All the network status signals down the left side will be red.

    Click on the "Continue" button in the dialog box.

    4. You should see a fresh Network Diagnostics box subtitled "Choose network port configuration"

    Click on the AirPort radio button.
    Then click on continue.

    5. The Network Diagnostics box should be refreshed. You should now see "Select AirPort network" as a subtitle, and one or more wireless network names listed.

    Click on your wireless network name (the one your AirPort knows).
    Click the Continue button.

    6. Type your password in the Password box in the next refresh. (No need for a $. Just your password.) (Don't bother checking the Remember password... box. It seems non-functional.)

    7. Click the Continue button.

    8. The Network Fairy awakens, makes all the status signals on the left green, turns on your wireless signal strength icon in the top bar, loads your Safari page, and leaves you with the message: "Your Internet connection appears to be working correctly."

    9. Beats me why the "other" WEP password entry process consistently fails.

    Fred
     
  10. methnmonk macrumors newbie

    Joined:
    Mar 10, 2008
    #10
    incompatible security

    hi guys,

    Just purchased the new macbook pro 2.6G, had the same problem connecting to my wireless home network. The system always replied with 'incompatible security'. I tried the putting a $ infont of the WEP but it did't work. Also tried to connect thru network diagnostic as suggested but that didn't work either...any other suggestion.
     
  11. fredstahl macrumors newbie

    Joined:
    Jan 16, 2008
    #11
    Make sure you have six or more characters in your password. ... and the $ goes in front when you enter th hex equivalent to your password.
     

Share This Page