Leopard upgrade help

Discussion in 'MacBook Pro' started by autigergal75, Dec 20, 2012.

  1. autigergal75 macrumors newbie

    Joined:
    Dec 20, 2012
    #1
    Hi, I have a MacBook Pro running OS X 10.5.8. I just purchased an iPhone 5 and found that the iTunes is not compatible and in order to upgrade iTunes, I need to upgrade my operating system. Question #1, Do I need to upgrade all the way to Mountain Lion or will an upgrade to Snow Leopard suffice and #2, I need to get an external hard drive to back up my system. While looking at them online at BestBuy.com I noticed that some will work with only Leopard and Snow Leopard while others work only with Snow Leopard, Lion and Mountain Lion. Are there any out there that would work no matter what OS I have?
     
  2. justperry, Dec 20, 2012
    Last edited: Dec 20, 2012

    justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #2
    All external HD's should work with any OS, except if you don't have the connector on your MBP, so lets say you buy a Thunderbolt external and your MBP does not have such connector it would not work but that seems to be obvious.

    I am not to sure about your iPhone 5, I think it needs iTunes 11 and I think the minimum is Snow Leopard.

    Edit: This might help you out.

    You could also use a VM and run iTunes in Windows in a VM.
     

Share This Page