Leopard Webkit (Safari 7 for 10.5/10.6) - Any version for Lion/ML?

Discussion in 'macOS' started by im_to_hyper, Apr 20, 2015.

  1. im_to_hyper macrumors 65816

    im_to_hyper

    Joined:
    Aug 25, 2004
    Location:
    Glendale, California, USA
    #1
    I found this open-source version of Webkit to enable installation of the newer version (Safari 7 from Mavericks) on Leopard PPC/Intel and 10.6 Intel.

    Does anyone know of a version that will work on Lion / Mountain Lion? I have Googled around and haven't found anything!

    Link to App
     
  2. redheeler, Apr 21, 2015
    Last edited: Apr 21, 2015

    redheeler macrumors 603

    redheeler

    Joined:
    Oct 17, 2014
    #2
    Doesn't work with Snow Leopard either. A shame since my 2008 MBA could use a lightweight browser in Snow Leopard and Safari is already several years old.

    Edit: I tried another link on there to an older build for Snow Leopard, but it just crashes. Looks like I'll be sticking to Firefox.
     

    Attached Files:

  3. Mr. Retrofire macrumors 601

    Mr. Retrofire

    Joined:
    Mar 2, 2010
    Location:
    www.emiliana.cl/en
    #3
    Google Chrome runs on 10.6.8 and is quite usable, if you disable all the automatic functions (plugins and so on) in the preferences. Chrome uses the same WebKit version as the newest OS X version of Safari (AFAIK).
     
  4. redheeler macrumors 603

    redheeler

    Joined:
    Oct 17, 2014
    #4
    Chrome no longer uses Webkit, rather a Webkit derivative. I'll give it a try but I doubt it'll perform much better than Firefox.
     

Share This Page