Leopard will not automatically sleep!!

Discussion in 'Mac Basics and Help' started by Hutchy, Nov 27, 2008.

  1. Hutchy macrumors member

    Joined:
    Apr 13, 2007
    #1
    Please help me!!

    I have tried everything I know to resolve this problem, but i cannot get my iMac (intel) to automatically sleep!!

    I have reset PRAM, unplugged all USB etc, tried deleting some pref files but all to no avail.

    There are a few threads already on this but none have come up with a trouble-shooting guide.

    Are there any steps I could follow?
    Is there a way to 'see' the sleep timer so I can see what i resetting it?
    Are there any known programs that can cause this?

    I noticed on some programs there was a check-box enabling 'Do Not Sleep' when active. I'm wondering if one of these (now redundant) programs have left the computer in a 'do not sleep' state?(!)

    Any help would be much appreciated. Thank you.
     
  2. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #2
    Little Snitch is known to cause sleep problems. Transmission has an option to prevent from sleep with active transfers but doesnt prevent from sleeping with the option unchecked or with no active transfers.
     
  3. Hutchy thread starter macrumors member

    Joined:
    Apr 13, 2007
    #3
    ah, i did have little snitch installed not so long ago until the demo expired. I wonder if I re-install and then maybe try and uninstall it again it might get to the bottom of my problem. Would deleting any related preference files help at all?
     
  4. Hutchy thread starter macrumors member

    Joined:
    Apr 13, 2007
    #4
    Hi,

    I did a fresh install/uninstall of Little Snitch but unfortunately it not help.

    I have a few odd messages on the console which may help:

    27/11/2008 23:25:15 com.apple.coreservicesd[48] NOTE: Using non-mach-based version of client -> server communication, via direct function calls.

    I have searched google but I have no idea what it means.

    Also, occasionally, this StuffIt one pops up too:

    27/11/2008 19:09:15 Safari[393] Cannot find function pointer MyCMPluginFactory for factory 02E3F072-9CCB-11D5-A0B2-00306575F8A2 in CFBundle/CFPlugIn 0x16675880 </Library/Contextual Menu Items/StuffItCM.plugin> (bundle, not loaded)

    Thanks far all your help richthomas.
     
  5. Hutchy thread starter macrumors member

    Joined:
    Apr 13, 2007
    #5
    Hi all.

    Has anyone got any better ideas? I am still trying to find a solution but to no avail unfortunately. Thanks.
     

Share This Page