Leopard won't boot nor find startup disc

Discussion in 'macOS' started by jcernyj, Jan 1, 2009.

  1. jcernyj macrumors newbie

    Joined:
    Jan 1, 2009
    #1
    Hey guys,

    I need your help please. It all started when I was trying to install Windows XP under Boot Camp on my Macbook Pro (Leopard). I followed the manual and made the partition for Windows (32GB), but when I inserted Windows XP Install CD and had to choose partition to install it on, there was just one that seemed to be my Leopard startup disc (it had some 120GB). I did not know what to do, so I just left the installation process and the notebook restarted. When it loaded, it was trying to boot from the Windows CD so I tried to install it, but same problem appeared -> restart. I tried to load Leopard by holding Option key while loading, but only options for windows and windows cd appeared, no Leopard -> Shut down. While booting, I force-ejected the CD by holding down trackpad button -> blinking underscore on black screen appeared. I shut the MBP down by holding power button and inserted Leopard Install CD. When it loaded, I booted from the CD by holding Option key. This time I was ready to even re-install Leopard just to make it work but when I had to chose the harddisk to install Leopard on, there was none. It seems to me that somehow nobody can see the harddisk and I have no idea what to do with it. I hope that someone knows how to solve it.

    Thanks
     
  2. Cerebrus' Maw macrumors 6502

    Joined:
    Mar 9, 2008
    Location:
    Brisbane, Australia
    #2
    Looks as if the entire harddrive has been formatted to NTFS.

    Boot to the Leopard install disk, and select Disk Utilities under the Utilities menu bar on top.

    Select the Hard drive from the left (it will say something like 120GB - Serial Number) and format the drive into Extended Journaled. Once thats done, you should be able to install Leopard.

    If that fails, try booting into single user mode (cmd+s on start up), and type fsck -fy on the prompt
     

Share This Page