Leopard won't connect to my University's 802.1X

Discussion in 'macOS' started by rmh, Oct 30, 2007.

  1. rmh macrumors regular

    Joined:
    Sep 12, 2007
    Location:
    Texas
    #1
    ..its depressing. I'm almost done partitioning my MacBook's HD and installing Tiger on it. Anyone else have connectivity issues after the upgrade? Or is it just my university's outdated wireless infrastructure?
     
  2. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #2
    If you're using WPA Enterprise you might have to wait for your university to provide a solution.
     
  3. mwdmeyer macrumors member

    Joined:
    Dec 23, 2004
    Location:
    Sydney, Australia
    #3
  4. creator2456 macrumors 68000

    creator2456

    Joined:
    Jul 10, 2007
    Location:
    Chicago
    #4
    I had problems today getting connected as well. About an hour and trying different things got me to the correct solution. Not really sure what I did so I am not much help other than I can say try things.
     
  5. beetnik macrumors newbie

    Joined:
    Nov 1, 2007
    #5
    yeah this completely sucks i cant log into our corporate wireless either, you would think that apple would have tested this as it just plain does not work.

    Snagged a copy of internet connect from a tiger machine and am back up but its not an ideal solution
     
  6. yeti5d macrumors newbie

    Joined:
    Apr 27, 2007
    #6
    At my uni my solution was....

    Network -> advanced -> 802.1x tab

    Domain = system
    state = 802.1x enabled
     
  7. davidwarren macrumors 6502a

    Joined:
    Aug 28, 2007
    #7
    I have this problem too. We have gotten around it for now by selecting join other network, typing in the network name--it doesn't save it, then selecting 802.1x and entering user and password. Really annoying. I hope this is fixed soon.
     
  8. davidwarren macrumors 6502a

    Joined:
    Aug 28, 2007
    #8
    I grabbed internet connect app from my tiger and it works just as before leopard, perfectly.
     
  9. creator2456 macrumors 68000

    creator2456

    Joined:
    Jul 10, 2007
    Location:
    Chicago
    #9
    I'll have to grab it off my Tiger .dmg once I get home and make sure to try it tomorrow at class.

    Good hint/solution/idea.
     
  10. Dark Eternal macrumors newbie

    Joined:
    Jul 22, 2007
    Location:
    Katy, Tx
    #10
    I have tried everything, every setting, you name it and can not make it work. I see your in Texas, dont happen to goto UTD do you? That is where I can not make my iBook work. Im going to try and grab internet connect from Tiger, see if I can not make it work, this is the first I have heard of it.
     
  11. creator2456 macrumors 68000

    creator2456

    Joined:
    Jul 10, 2007
    Location:
    Chicago
    #11
    Confirmed.

    Internet Connect from Tiger works for 802.1x in Leopard.
     
  12. absoluttl macrumors newbie

    Joined:
    Jun 30, 2007
    Location:
    Vancouver, BC
    #12
    yeah, same problem here. I upgraded from Tiger to Leopard and it seems like Leopard doesnot remember the 802.1x setting (although i have gone into the Network-> advance -> preferred network -> clicked on the network and typed in my username and password with "remember this network"). Somehow, Leopard just can't seem to remember it :(

    i have no problem with WPA/WPA2 Personal though...
     
  13. creator2456 macrumors 68000

    creator2456

    Joined:
    Jul 10, 2007
    Location:
    Chicago
    #13
    Just 5 minutes ago was the first time back on campus after the 10.5.1 update and so far it seems as though 802.1X is working correctly.

    Can anyone else confirm that the update has fixed their problem?
     
  14. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #14
    Worked fine for me since 10.5.0. It's not very good at reconnecting after waking from sleep though.
     
  15. sopranus macrumors newbie

    Joined:
    Feb 3, 2008
    #15
    Problem Solved with Old School Setings on 802.1X

    Hey I solved the problem, all you need to do is download the Internet Connect.app and install it in Leopard, and from the system menu add a new 802.1X connection, just like in Tiger. Here's a Link to download the Internet Connect.app

    Rafy

    https://docs.rice.edu/confluence/dow....zip?version=1


    Forgot to say, if any questions email to supranus@hotmail.com
    and gladly will answer your questions
    Reply With Quote
     
  16. tristan123 macrumors newbie

    Joined:
    Jul 6, 2005
    Location:
    Montreal, QC
    #16
    Thanks! This solved my problem.
     
  17. JSweeny macrumors newbie

    Joined:
    Apr 25, 2008
    #17
    FIX: Leopard fails to remember preferred network(s)

    I have been searching high and low for a fix to this and none have worked…until now!

    I spotted a fix to this problem that strangely centered on the specific location of the “System Preferences.app”, if other than the standard location of the root of the “Applications” folder. I had in fact moved mine and would NEVER have thought it related to this bug. Hmmm!

    If you have moved the System Preferences application (not alias, actual app) to any other location for any reason, your newly joined preferred network will NOT be properly remembered and will NEVER be properly rejoined. Apparently one of the multi-step system procedures involved in properly saving a preferred network assumes the location of System Preferences to be the standard location. Period.

    FIX:
    1) Move “System Preferences.app” back to “Applications\”.
    2) Delete all instances of “Preferred Networks” in “Network Preferences”.
    3) Delete all “Airport network password” instances in “Keychain Access”.
    4) Restart your Mac.
    5) Add/Join applicable preferred network using the Airport pulldown menu or in Network Preferences (as if for the first time). Use “Advanced” in “Network Preferences” to confirm the existence of your preferred network and the correct settings. Use “Keychain Access” to confirm the existence of the applicable “Airport network password” instance and the correct settings.
    6) Restart your Mac. The OS should now find your preferred network and join it on its own. Good Luck!

    NOTE: Simply moving back System Preferences will NOT suffice. Deleting and re-adding/joining the preferred network is a must after the app has been moved.
     

Share This Page