Letter alternate popups driving me nuts while typing

Discussion in 'OS X Yosemite (10.10)' started by netslacker, Jul 21, 2015.

  1. netslacker macrumors 6502

    Joined:
    Jan 21, 2008
    #1
    Hi All,

    I have an issue that has been driving me crazy. As I type, I keep getting the letter alternate popup (i.e.: hit E key and get options for è é ê ë ē ė ę on the screen). These things drive me nuts because if I just keep typing then the letter I hit gets omitted. I'm a fast typer... 80wpm, but it's CONSTANTLY popping up in random places and then I have to go back and correct the words. It's so frustratingly annoying that I want to launch the computer across the room sometimes.

    It seems that this popup should only come up if I press and hold a key. But it comes up even during regular, fast typing... no holding of keys. Then the letter gets skipped because I didn't chose an option (of course not, I'm on the next word already).

    My wife's air does not have the issue, but my MBP does.

    I've looked for delay settings (increase the delay before it shows) and can't find that other than the repeat delays, which don't seem to have any effect on this issue. Any suggestions?

    It happens in Safari, Word, etc.

    Yosemite 10.10.4, 2009 MBP, 8gb.
     
  2. netslacker thread starter macrumors 6502

    Joined:
    Jan 21, 2008
    #2
    For now, I've found a defaults command that removes those character accent menus from popping up. Things are much better now, though I wish it would just work like it's supposed to.

    For those that find this after me:

    Disable them:
    Code:
    defaults write -g ApplePressAndHoldEnabled -bool false
    Enable them:
    Code:
    defaults write -g ApplePressAndHoldEnabled -bool true
    logout and back in for the change to take effect.
     

Share This Page