Letters not showing up

Discussion in 'OS X El Capitan (10.11)' started by bhammer77, Dec 20, 2015.

  1. bhammer77 macrumors newbie

    Joined:
    Dec 20, 2015
    #1
    Hey guys, not sure if this has been posted before but I am recently having problems with letters not appearing while I am on the internet. Primarily it is whenever there is an "F" and an "I" next to one another. I have tried font finagler and that did not help. I have posted a screenshot to show you what I am talking about.
    Any one else having this issue?
     

    Attached Files:

  2. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #2
    the fi combination is a ligature, also another with an f would be fl (FL)
    Something has happened to the font that Safari uses, and the typographical combinations may not be showing properly.
    Try changing to another font in Safari. The simplest step to try is, in Safari, go to the View menu, then Text Encoding.
    See that the checkmark is next to Default. If your language is US English, then select Western (ISO Latin 1) as a test. After changing the selection, Quit Safari, and re-launch Safari. Go to a page where you see the fi combinations. Are they displaying correctly now?
     
  3. bhammer77 thread starter macrumors newbie

    Joined:
    Dec 20, 2015
    #3
     
  4. bhammer77 thread starter macrumors newbie

    Joined:
    Dec 20, 2015
    #4
    I tried that initially to no avail. I actually tried a couple different fonts.
     
  5. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #5
    Trying "a couple of different fonts" is not equivalent to changing the text encoding setting.

    Text encoding determines how the fonts are displayed. If you have a UTF-8 setting, for example - that will be different font display setting from Western (ISO Latin 1). It doesn't actually change the font used, but changes how that font is displayed.

    Does it only happen in Safari, or does it happen with other browsers, such as Chrome, or Firefox?

    Do you have the same issue when NOT using a browser?

    I doubt that the old Font Fanagler utility would be worth using in El Capitan. The font caches for the system are just not the same now. That being said, you can do a quick restart into safe boot mode. (Restart while holding the Shift key. You can release the shift key when you see the boot progress bar begin the load) The Safe Boot mode rebuilds the system and user font caches, and may remove your issue with how the fonts are displayed. Restart normally after that Safe Boot, then check one of your sample pages.
     
  6. bhammer77 thread starter macrumors newbie

    Joined:
    Dec 20, 2015
    #6
    It doesn't happen in Chrome, only Safari. Only started after I started the El Capitan beta.
     
  7. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #7
    OK!
    In your Safari Preferences/Extensions
    What do have installed? You can try disabling each, and check by restarting Safari to see if your font issue disappears.
    Check also in Safari Preferences, then the Advanced tab - What is selected for Style Sheet?
    And what appears as the Default Encoding setting in that advanced tab?
    You can also enable the Develop menu from that Advanced page...
    In the Develop menu - what do you have selected for User Agent? I have Default (Automatically Chosen) set. If you also have that same default, try changing to Safari 9.0.3 there.

    Again, if you change any of those settings, restart Safari, and check again for your issue with fonts.
     

Share This Page