Lexmark printer no longer works on usb not wireless after snow leopard

Discussion in 'macOS' started by marisa8184, Aug 30, 2009.

  1. marisa8184 macrumors newbie

    Aug 17, 2008
    Title of the post says it all really. My printer is one of the ones supposedly supported (x4690) and it works fine when connected by usb, but not wirelessly. I have tried everything I know to get this working.

    The only clue I have is when I try to print and run a log, it says

    Stopping job because the scheduler could not execute a filter.
    E [30/Aug/2009:14:17:13 +0100] Unable to execute /usr/libexec/cups/backend/lexnet3: insecure file permissions (0100755)

    So, any help with this would be really appreciated. I've tried to submit the problem to Lexmark, but the 'submit' button doesn't work on their website, so I emailed them directly, but am not holding my breath!
  2. scottackerson macrumors newbie

    Aug 30, 2009
    Same here

    I'm having the same problem with my Lexmark x4650.
  3. xIGmanIx macrumors 6502a

    Dec 21, 2008
    see what happens when third parties don't support your OS? sucks!! hopefully they will release drivers shortly to get you back on track. I personally wouldn't migrate until there are revised drivers for all my hardware
  4. jmpage2 macrumors 68040


    Sep 14, 2007
    Have you guys tried to reload the drivers for 10.5 from the Lexmark site?
  5. calderone macrumors 68040


    Aug 28, 2009
    Repair permissions? The line you posted from the logs suggests permissions.
  6. marisa8184 thread starter macrumors newbie

    Aug 17, 2008
    Eventually I managed to get this fixed.

    I knew the new driver was OK because it worked when connected by USB
    I knew my network was ok because all the pcs in the house can use and print to this printer, and everything else was OK.

    What I did was to add the printer manually. I went to printers in the system preferences, clicked the plus sign to add another printer, chose the tab called IP and then manually put in the printer's IP address which I got from the printer itself. Mine has a mode on it where it will print out all it's information.

    I called it Lexmark and then chose the correct driver from the list, for me this was the 3600-4600 series.

    I can't remember which protocol I chose, I just kept fiddling about with this and all of a sudden it worked

    I hope this helps someone else with a similar problem.

    Good luck!
  7. snickers01 macrumors newbie

    Sep 4, 2009
    Lexmark 4550

    Tried the optional installs from the SL disk, then went to Apple to check drivers
    knew that I had correct drivers as would print from USB
    deleted the lexmark from prederences, then added new printer, chose to add through IP address, use HP printing protocol then add printer software from option dropdown. In this you will find the correct lexmark driver, will be named as a series.
    hey presto it worked - still took 2 hours to solve this though.
  8. lovelypit macrumors newbie

    Mar 1, 2009
    Thanks marisa8184! I got it to work. I'm using the X4650...used the Hp protocols from the choices...I'll use it like this for now until lexmark makes a formal installer...Can't seem to get the scanner to work yet though. Any ideas peeps?
  9. NoelEiffe macrumors newbie


    Apr 12, 2006
    Thank you very much...this is what worked for me too...the trick was to pick the HP JetDirect option. Worked on 3 machines. Go figure.

  10. ManMonkey macrumors newbie

    Sep 7, 2009
    North East England
    marisa8184, snickers01 and everyone else - huge thanks for this! ( I joined this forum just to thank you guys!)

    Two minutes sorted this out for me - still can't use the scanner wirelessly so I have kept the usb printer set-up for that. I guess we'll have to wait for a new Lexmark driver for that.

    If you are struggling to find the IP address - on the X4650 you'll get the Ip address from the printer's maintenance button and then Network set up then Print set up page.
  11. barfoed macrumors newbie

    Sep 8, 2009
    The solution suggested by snickers01 and marisa8184 also works for Lexmark c530dn.

    Add the printer manually and select HP protocol - then the printer will work.

    If you select IPP protocol, the printer will be found, but will not print.

    Thanks for the good solutions.

  12. mrheisman macrumors newbie

    Sep 10, 2009
    Howdy, first time poster, long time lurker.

    I also have a Lexmark x4650 and running SL. I have the same problems and I've tried all the above suggestions. When I tried snickers01's suggestion of using the HP protocol everything seemed to work well. It connected to my printer, said it was completed successfully, and then went back to the "Printer Ready" status. However, it didn't print. It didn't attempt to spool or even make any kind of noise.

    Does anyone have any idea what might be the problem? Thanks.
  13. jmpage2 macrumors 68040


    Sep 14, 2007
    Did you reset the printing system afterwards? Running latest drivers for the printer?
  14. mrheisman macrumors newbie

    Sep 10, 2009
    Yea, I've tried those.

    I can't figure it out to save my life. I may just have to wait until Lexmark updates their drivers.
  15. jmpage2 macrumors 68040


    Sep 14, 2007
    Try loading the Leopard version of the drivers for your printer.
  16. efrenernesto macrumors newbie

    Jul 16, 2009
    Lexmark x4690 driver for snow leopard doesn't work (wirelessly)

    In short, lexmark has released drivers for snow leopard for a bunch of multi-functional printers, such as the x4690 which is what I have.

    However, I found that the x4690 only works for the printer, not for the scanner. When I try to scan a page it stucks in trying to download the list of apps, with no success after a minute or two. All of the above is for working wirelessly.

    Is any1 experiencing the same problem?



    BTW, the x4690 driver for snow leopard apparently is version 1.0.2, but the latest driver for leopard is v 1.0.10, which kind of makes me feel lexmark really is releasing a previous driver that they found works with snow leopard.
  17. dustingold09 macrumors newbie

    Sep 13, 2009

    I have found a link which is related to printers issues. You should have check

    it out. It might be very useful to resolve lexmark printer wireless

    connectivity issue.

    Laser Printer
  18. silversurfer001 macrumors newbie

    Dec 9, 2009
    This did the job for me. I used the HP protocol.
  19. AgentRed macrumors newbie

    Mar 11, 2010
    You need a static IP address

    The fix described here will not be a permanent solution.

    The problem is that for many Lexmark wireless inkjet printers the driver remembers where the printer is by it's IP address. The problem comes when the DHCP server (your router) assigns the printer a new IP address, the drivers on your Mac can no longer find it.

    The answer is to assign a static IP address to the printer, and reinstall the drivers. This article explains how to do that. While you are at it you should check the Lexmark site for the latest drivers since there have been recent updates to most of the drivers.
  20. julietetlours macrumors newbie

    Sep 22, 2010
    iMac & Macbook pro don't work with Lexmark

    I bought a Macbook Pro like a year ago and installed a HP printer which came with mac. However, when I tried to install my parent's wireless Lexmark 4600 at home it didn't work, actually it didn't do anything. It didn't recognise the device.
    I recently bought an iMac, and tried to install the same wireless Lexmark (4600) printer. Now it does install it with no complications at all but it doesn't work. it always says Error

    Does anyone have an idea why this happens? Are Apple Mac compatible with Lexmark?

  21. Spendt1 macrumors newbie

    Dec 2, 2010
    Got it to work

    After several hours messing with my new x4650 printer I got the wireless printing/scanning and ipad printing to work by doing things in this order:

    1. Download the OSX 10.6 driver from Lexmark site
    2 Use Lexmark Wireless Setup Assistant and Download Apple Update when prompted (download will not complete without number one).
    3. Restart your Mac like it is an old Windows 2000 device (probably not necessary but I was getting pissed)
    4. Everything should work even scanning

    For ipad
    1. Downloaded Lexmark app
    2. Would not find printer (tempted to restart ipad but didn't)
    3. Downloaded Lexmark Listener on Mac with updated driver
    4. WOW it worked. Now I am take screen shots of whatever I want on ipad and printing them to wireless printer. For whatever reason the app only prints from Photos and its own web browser. What the hell, its free and I got off cheap with this discontinued printer. Hope this saves you the hours of trial and error I put in.
  22. Urusai89 macrumors newbie

    May 15, 2011
    Just stopping by to thank you guys for the help. I was messing with this issue for a while now, and I feel kind of stupid for not having gone to Lexmark's site in the first place.

    Downloading their version of the installer for Snow Leopard solved everything. It installed, it didn't see the printer right away, but it actually popped up this time asking if I want to accept incoming connections (of course I said yes), and it allowed me to type in the IP address to add a remote printer (since it still wasn't showing in the list).

    I have a DHCP reservation for the printer, which is basically like a static IP, so no issue there.
  23. dmedia macrumors newbie

    Jan 6, 2012
  24. han5 macrumors newbie

    Sep 17, 2012
    Update Lexmark driver to Snow Leopard stops printer

    when my Snow Leopard shows things to update I answer yes and the Lexmark PRO200-S500 driver is one of the updates. This makes the printer to stop work and then I have to find my installation CD and re-install the printer which then works until I make the mistake again.
    Tired Hans

Share This Page