Lexmark Printer with Snow Leopard

Discussion in 'Mac Accessories' started by guzzlamiamor, Aug 30, 2009.

  1. guzzlamiamor macrumors member

    Joined:
    Oct 19, 2008
    #1
    Does anyone else have a Lexmark printer that is working with Snow Leopard? I have an x4850 and after updating it tells me I need to install the software to make the printer work. Of course, Lexmark's site is completely unhelpful and makes no mention of OSX 10.6 at all. Any help would be appreciated.
     
  2. srl7741 macrumors 68020

    srl7741

    Joined:
    Jan 19, 2008
    Location:
    In my world
    #2
  3. VishalArora macrumors newbie

    Joined:
    Sep 1, 2009
    #3
    Me too

    Mine just stopped working as well. I contacted Lexmark support and they say they will be releasing new drivers compatible with Snow Leopard in batches starting next week. The agent had no idea which printer drivers would be released when. He just kept saying that they would be released in the coming weeks.

    For what it's worth, I have the Z1480.
     
  4. AppleFan360 macrumors 68020

    Joined:
    Jan 26, 2008
    #4
    Same here. My Lexmark printer stopped working as well. I hope Lexmark works it out.
     
  5. jacvinson macrumors newbie

    Joined:
    Sep 4, 2009
    #5
    Ditto:

    I have the 9575, same problem, and Lexmark gave me the same gibberish about "working on drivers". On mine, it keeps saying I have the wrong cartridge in the printer.. But I don't get that message with my pc's that are networked to it. Also, they told me that I wouldn't have a problem if I used a USB cable. (currently I'm wireless). Haven't tried the cable because, frankly, after the 3rd tech, I was pretty sure I knew more about their printer than they did. The first one insisted (after 4 cartridges were R&R'd) it was bad print cartridges and she told me it "must the a bad batch from Office Depot". I told her that I was "just gonna hang up now, and call back, with hopes of getting someone that actually had a modicum of sense"... btw, didn't happen, (the common sense thing).
     
  6. gorjan macrumors 6502

    Joined:
    May 16, 2009
    Location:
    CPH
  7. manuelreinaldo macrumors newbie

    Joined:
    Sep 5, 2009
    #7
    X1155 seams that will not be suported

    I got an answer yesterday from Lexmark saying that my printer, a Lexmark X1155 multifunction, will not be supported in Snow Leopard and they offered me a discount if I decide to by a new printer.

    To me this looks like they have already figured out which printers are going to be supported.
     
  8. MacAttack1959 macrumors newbie

    Joined:
    Sep 5, 2009
    #8
    Lexmark Printer issues

    I have a X5410 and had the same problem after upgrading...I went back to Lexmark's site and made sure I had the proper driver for the printer. Removed the old software and installed the copy I downloaded, even though it was an older version of the driver...and now it works...took me three times to remove and install but it does work now.
     
  9. mbtalle macrumors member

    Joined:
    Sep 19, 2008
    Location:
    ATL
    #9
    I had a similar problem with mine. Are you trying to print wirelessly? If so, you're screwed and you'll have to plug in USB.
     
  10. snickers01 macrumors newbie

    Joined:
    Sep 4, 2009
    #10
    Lexmark wireless ok

    I have a 4550, please see post below I made in response to similar issue

    Lexmark 4550
    Tried the optional installs from the SL disk, then went to Apple to check drivers

    http://support.apple.com/kb/DL901?vi...S&locale=en_GB

    knew that I had correct drivers as would print from USB
    deleted the lexmark from prederences, then added new printer, chose to add through IP address, use HP printing protocol then add printer software from option dropdown.

    In this you will find the correct lexmark driver, will be named as a series.
    hey presto it worked - still took 2 hours to solve this though.
     
  11. AppleFan360 macrumors 68020

    Joined:
    Jan 26, 2008
    #12
    This worked for me. Thanks!
     
  12. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #13
    For orphan printers.

    Keep forgetting that a lot of the newer printers have emulation modes, for their network versions logging into the printer's service page using a browser and switching them to something like HP emulation is always an option.
     
  13. guzzlamiamor thread starter macrumors member

    Joined:
    Oct 19, 2008
    #14
    I decided to give this another shot having just got the 10.6.1 update stating that some printer issues had been fixed. When it didn't work I googled the issue and came back to this, my original post. Using some of the info on here, I switched from wireless to USB and found that it works that way so I know I have the right driver. I tried to advice for getting wireless to work posted by someone, but I was unable to get it working. I can ping the printer all the while so I know I have wireless connectivity to it. I tried using the IP and HP protocols, however neither worked. I know I am selecting the correct software from the list because I am selecting the exact software in use when the printer is connected via USB and working. I suppose I will wait a few more weeks and try again. Since this is my IMac with the printer in close vicinity it is not an issue, but I doubt I will ever purchase a Lexmark printer again. The website is completely unhelpful and still doesn't list any real helpful information about SL other than try to install the optional packs from the SL disk.
     
  14. wakka092 macrumors 6502

    wakka092

    Joined:
    Jun 20, 2007
  15. hypergraphics macrumors newbie

    Joined:
    Jan 1, 2010
    #16
    Whew $%@!@#$! Apple ?????

    Wish I would have known about these problems when I got my FIRST Apple :apple: computer ( back in 1982 )

    Seems that Lexmark CAN NOT keep up with the OS updates (Panther AND Tiger were slow problem,s for them also.

    Seems odd for Lexmark to expect that by providing poor support and service a credit on your printer that is no longer supported will momentarily blind you and convince you to wasete your money AGAIN!!!

    I have an X-83 ( now a doorstop ) the Apple driver issues do NOT sole the scanner driver / software issues they WILL NOT WRITE THE PATCHES TO SUPPORT THEIR PRODUCTS!!!!

    WHEW!!!!!!

    enough comments - just don't believe Lexmark
    will reputably do ANYTHING!!! :mad:
     
  16. petercohrs macrumors newbie

    Joined:
    Jul 25, 2008
    #17
    Old Forum, no changes. Lexmark still doesn't work

    I have a Lexmark C935.
    Printing from iMac with 10.7.4 runs fine
    Printing from MacProRetina or MacAir with 10.8.1 is printing into the air
    Lexmark Website is useless for this printer it jumps back to their homepage!
     

Share This Page