Lexmark x4650 - Macbook Air can't find wirelessly

Discussion in 'Mac Basics and Help' started by magicshoemonkey, Dec 9, 2012.

  1. magicshoemonkey macrumors newbie

    Dec 9, 2012
    There is a three or four year old thread that deals with this (kind of), but it didn't help me and hasn't had any posts in the last few months. I thought it better to start a new thread than resurrect an old; I hope that's acceptable.

    So, I have had this printer for years, but the Air is one I got (refurbished) a few months ago. I've been trying to get it to connect to my Lexmark x4650 for those months, off and on. I tried the straightforward method of installing the wireless setup software to my Mac, connecting the printer to the network through the Macbook Air, and searching for the printer over the network with my Mac, but, while the printer connects to the network fine, the Mac doesn't see it over the network.

    I tried connecting through the IP address, but even that didn't work. It first said it couldn't identify the printer, then when I ignored that and connected anyway it said there was a new printer connected through the IP but wouldn't print or anything.

    I also installed the updated software and drivers from both Apple and Lexmark. After all of that and trying for a 50th time to re-setup the wireless connection, I went to the printer settings on my Mac and searched for the printer to add. At the time I still had it connected through the USB, and that connected fine, but when I went to add another printer to the queue, while the USB connection was visible in the list, the wireless wasn't. Then, like some sneaky French ghost, the Bonjour connection popped into existence, but when I moved the cursor up to click on it, it disappeared. It did that twice. I feel like I'm living in a cartoon now.

    I feel there must be something obvious I'm missing, but I haven't been able to guess what that is yet. Maybe somebody here can help?
  2. RoyalEagle02 macrumors newbie

    Jan 1, 2013
    Had the same issue and found a solution on another thread that worked...

    Add the printer like you did before through the IP address. System Preferences>Print & Scan> click the "+" sign. Click on "IP" and enter your printer's IP address in the top line. Then select "HP Jetdirect - Socket" in the Protocol drop down menu.

    Then under the "Use" drop down menu, click on "select printer software..." and click Lexmark 3600-4600 Series. Then click add and it might work. It did for me.

    Best of luck.
  3. magicshoemonkey thread starter macrumors newbie

    Dec 9, 2012
    This worked! I actually gave up on this after no reply for a week or two.

    Thanks so much.
  4. pradercomet65 macrumors newbie

    Jan 7, 2014
    Thank you Thank you!

    My wife just got a new Macbook Air, and we were having the same problems as the poster. Once I connected the Air to the printer via USB (let them shake hands) and installed the software it NOW realized it needed, I followed you advice and SHAZAM! it work.

    Thank you for your help and willingness to share. [emoticon deleted out of respect]

  5. Bill0328 macrumors newbie

    Nov 17, 2012
    Worked for me too!

    Let me join others in thanking you. It worked like a charm.

    For others, in order to find out what the current IP address is of your printer, there is a setup option on the printer that will print your network information.
  6. Artimus12 macrumors 6502a


    Nov 13, 2011
    Another new Mac user saying Thanks ...it's working great now.:apple:
  7. jmoore104 macrumors newbie

    Dec 21, 2014

    I've been trying to figure this out for months! Thank you so much - one quick change and it works perfectly now. Why couldn't Lexmark have this (obviously crucial) instruction somewhere in its documentation??
  8. Calinski macrumors newbie


    Jan 5, 2015
    Yorkshire, UK
    I came here because I had the same problem. I used the Wireless Setup facility for the printer and that was not playing well with my MB Air. Added by IP address as you suggested and BAM, it worked like a charm. Thanks!
  9. Carminoush macrumors newbie

    Mar 24, 2015
    I google the problem and found the solution. Had to create an account just to respond to this thread and say THANK YOU!!!
    I had this problem for over 10 days and it's now solved. Thanks to you.

Share This Page