Lexmark x9575 OSX Lion Fix

Discussion in 'Mac OS X Lion (10.7)' started by ARon145, Jul 21, 2011.

  1. ARon145 macrumors newbie

    Joined:
    Jul 21, 2011
    #1
    So yesterday I downloaded and installed Lion. Its perfect! but it wasn't complete without my printer. my Lexmark x9575 AIO printer was not printing wirelessly. I immediately contacted Lexmark Support and was helped and fixed. Now right now i would like to help you all set up your Lexmark 9500 Series printers to print wirelessly.

    1. He told me to download both OSX 10.7 support softwares that can be located here: http://support.lexmark.com/index?segment=SUPPORT&userlocale=EN_US&locale=en&productCode=LEXMARK_X9575&page=product&frompage=null#1

    [​IMG]

    You must download both.

    2. Secondly you must install the printer driver and then the wireless setup assistant.
    When you get the setup window for the wireless assistant follow all steps and press done when you have finished. (dont go into system preferences and add yet)

    3. ok now go into safari and click on the bookmarks tab and click on the 9500 Series under the Bonjour services.

    [​IMG]

    [​IMG]



    4. Copy the address of your printer.



    5. Open system preferences and add a printer, go under IP printer, now paste the ip addressed you copied under the "Address:" line. Also make sure you select HP Jetdirect - Socket.
    [​IMG]
    You can name the printer anything you would like.


    6. After you press add the driver will load and the printer will connect to your computer.


    7. Now it should be set up and ready to go. Note: once you start printer starts printing you queue window will show an error saying ink is out. ignore that message unless you know your ink is really out.

    'Well thats is, your Lexmark 9500 Series should now print wirelessly on OS x Lion v10.7.:D:D:apple:
     
  2. TheOrioles33 macrumors 6502

    Joined:
    Apr 3, 2008
  3. Birring macrumors newbie

    Joined:
    Aug 8, 2011
    #3
    mac ox x 10.7 lion and Dell 968

    After spending at least 14 hours over a week I was given your post and I worked through it. It was fine until step 3 - what is Bonjour all about (I didn't even need it) and then I got confused and lost, I worked through it just to find the printer and laptop wouldn't talk. After a bit more advice from a friend, I realised that the IP address could be found on my printer, when I did that, it was as you said, and wow they are now talking to each other, and it prints. Thank you.:)
     
  4. paulpallesen macrumors newbie

    Joined:
    Aug 12, 2011
    #4
    Never thought this day would come!

    Hi,

    After more than 40 hours of pulling my hair, chewing my nails and yelling at the computer (macbook pro 2007) for not talking to my printer...or was it the other way around I am now SAVED. Literally 30 min ago I was ready to go out and buy a brand new printer that would talk and communicate with my mac, but then I found this post. I followed the instructions and much to my surprise I found the problem and managed to fix it. These steps worked like a charm.

    Finally my computer and printer are talking to each other and working perfectly.

    On a side note I was scanning a document that wouldn't scan with my old Lexmark software. For anyone who have had the same problem you can plug the printer into your computer's USB port and open IMAGE CAPTURE and you'll see how easy it is now.

    Thank you again for you help, you have saved me countless of frustrating hours and more importantly from going insane.

    Paul:)
     
  5. robert.feltey macrumors newbie

    Joined:
    Aug 12, 2011
    #5
    Thank you!!

    These instructions worked perfectly! Now ... hopefully a future "Software Update" from Apple won't break the Lexmark drivers like we saw in previous versions...

    Thanks again!

    :p
     
  6. Cantello macrumors member

    Joined:
    May 29, 2008
    Location:
    Lüneburg
    #6
    Thanks, works here, too, for my X7675. I never thought of using the HP Jetdirect protocol for my Lexmark.
     
  7. jimmeronthemac macrumors newbie

    Joined:
    Apr 7, 2009
    Location:
    London
    #7
    Image capture rejecting scanner

    I followed your instructions - all good, thanks (except with the Bonjour link I kept getting a timeout. Got the ip address from the printer's little screen in the end).

    Now, when I go to scan, Image Capture opens, looks like it's about to do something, and then suddenly says "Scanner Unavailable" and I have to unplug the USB and put it back in.

    It won't scan at all.

    Any ideas? :confused:
     

Share This Page